Jump to content
The simFlight Network Forums

Ver. 7.0.5 - FSUIPC7 is not starting through the batch file.


Recommended Posts

I too am having a challenge getting FSUIPC to connect with the sim. I can't see any tray icon or interface for FSUIPC v7.

 

Here is a copy of my sim xml.

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>EXE.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>


-<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>FSUIPC7</Name>

<Path>C:\FSUIPC7\FSUIPC7.exe</Path>

<CommandLine>-auto</CommandLine>

<NewConsole>False</NewConsole>

</Launch.Addon>

</SimBase.Document>

 

Thanks for any assistance.

Brad

Link to post
Share on other sites
1 hour ago, ba43 said:

I too am having a challenge getting FSUIPC to connect with the sim. I can't see any tray icon or interface for FSUIPC v7.

 

Here is a copy of my sim xml.

 

<?xml version="1.0" encoding="WINDOWS-1252"?>

-<SimBase.Document version="1,0" Type="Launch">

<Descr>Launch</Descr>

<Filename>EXE.xml</Filename>

<Disabled>False</Disabled>

<Launch.ManualLoad>False</Launch.ManualLoad>


-<Launch.Addon>

<Disabled>False</Disabled>

<ManualLoad>False</ManualLoad>

<Name>FSUIPC7</Name>

<Path>C:\FSUIPC7\FSUIPC7.exe</Path>

<CommandLine>-auto</CommandLine>

<NewConsole>False</NewConsole>

</Launch.Addon>

</SimBase.Document>

 

Thanks for any assistance.

Brad

 

71B5947B-CF84-4A17-8DAE-354383A50F89.jpeg

Link to post
Share on other sites
4 hours ago, Roland said:

I think I found a solution for the exe.xml problem.

There are to cases that work

If FSUIPC7.exe is set to start as administrator, you must start MSFS with admin rights.

If FSUIPC7.exe is NOT set to start as administrator, do must start MSFS WITHOUT admin rights.

Every other combination does not work.

It is and always has been the case that all programs that are communicating with the FS have to be ran at the same level as the FS.

 

Link to post
Share on other sites
3 hours ago, ba43 said:

I too am having a challenge getting FSUIPC to connect with the sim. I can't see any tray icon or interface for FSUIPC v7.

Your EXE.xml (not sim.xml) is fine. Your problem is most probably that highlighted in the README.txt, which also tells you how to resolve:

Quote

Problems running FSUIPC7
========================
1. If you receive the following error when running FSUIPC7:
        The code execution cannot proceed because VCRUNTIME140_1.dll was not found. Reinstalling the program may fix this problem.
   then you need to uninstall the 2015, 2017 and 2019 VC++ redistributibles from the Windows App management panel, and then re-installed
   the combined redistributable packages (usually both the x86 and x64 ones) from here:
       https://support.microsoft.com/en-in/help/2977003/the-latest-supported-visual-c-downloads

   Also see https://answers.microsoft.com/en-us/windows/forum/all/vcruntime140dll/8fe4965d-2013-49cb-816e-17cc2bb0c077?auth=1
2. If you receive a pop-up System Error from MSFS when auto-starting FSUIPC7, also please also try the steps outlined in 1. above.
   You can also try starting FSUIPC7.exe manually to see if any errors are given.

 

Link to post
Share on other sites
11 minutes ago, John Dowson said:

Your EXE.xml (not sim.xml) is fine. Your problem is most probably that highlighted in the README.txt, which also tells you how to resolve:

 

Got it. Updating the C++ libraries fixed this. The module now runs as required. Thank you

 

Link to post
Share on other sites
On 3/23/2021 at 7:03 AM, Roland said:

I think I found a solution for the exe.xml problem.

There are to cases that work

If FSUIPC7.exe is set to start as administrator, you must start MSFS with admin rights.

If FSUIPC7.exe is NOT set to start as administrator, do must start MSFS WITHOUT admin rights.

Every other combination does not work.

 

Roland - I agree, I have verified this as well.  However I do not know how to check if MSFS is starting with or without Admin rights.  But I have found that if I uncheck FSUIPC7.exe "Run this program as administrator"  then it auto starts as it should.  The minute I run as administrator it will not startup.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.