Jump to content
The simFlight Network Forums

Recommended Posts

Hello,

Last night (Mar 3rd local) I purchased FSUIPC6 to use with P3Dv4.5 from simMarket, order #2668065.  After re running the installation and entering the registration information, it continues to give me an error "Registration details for FSUIPC6 not valid - please re-enter and try again."

- installed FSUIPC6 v6.0.12, downloaded from the website and from the simMarket email.

- FSUIPC was installed in the Documents/Prepar3D v4 Add-ons folder.  Other locations were tried as well but still yielded the same results.  Complete uninstall was done from each location.

- All 3 fields (name, email and key) were entered multiple times by both typing manually and by copy-and-pasting to ensure they were correct as provided. (WideFS Key was left blank as this was not purchased).

- FSUIPC appears to be running fine unregistered in Prepar3D as it shows in the add-on menu and its window opens when selected.

- The provided documentation mentioned checking the computer system's date and time as this was said to cause problems.  As the purchase was made late at night (just before midnight) I didn't know if that could have an effect.  In the end the system time checks ok.  

Would there be anything else I could try to get it working. 

Thanks.

 

Link to post
Share on other sites
9 hours ago, FireFlyer said:

- All 3 fields (name, email and key) were entered multiple times by both typing manually and by copy-and-pasting to ensure they were correct as provided. (WideFS Key was left blank as this was not purchased).

Did you then click the Register button? Of so, you would have seen a pop-up message telling you if your registration was successful or not. What did you see?

Link to post
Share on other sites

Yes, after clicking on the Register button, a pop up window appeared with the message "Registration details for FSUIPC6 not valid - please re-enter and try again" along with the recommendation to copy and paste to ensure that the information entered is exactly as what was provided in the confirmation email.

Link to post
Share on other sites

 

 

1 hour ago, FireFlyer said:

Yes, after clicking on the Register button, a pop up window appeared with the message "Registration details for FSUIPC6 not valid - please re-enter and try again" along with the recommendation to copy and paste to ensure that the information entered is exactly as what was provided in the confirmation email.

Yes, sorry - you did say this in your original support request.

I have checked your registration details here and they are good.

Can you run FSUIPC7 by double-clicking the FSUIPC7.exe window? Or do you get an error?

If so, it is probably due to your VC++ redistributables being corrupt. You need to uninstall any of the VC++ redistributables from 2015, 2017 & 2018, then re-install the combined package (both x64 an x86) from https://support.microsoft.com/en-in/help/2977003/the-latest-supported-visual-c-downloads

Link to post
Share on other sites
10 hours ago, John Dowson said:

Can you run FSUIPC7 by double-clicking the FSUIPC7.exe window? Or do you get an error?

Just to confirm that you mean FSUIPC6.exe?  If so, no, I can not find that application installed.  Only Install_FSUIPC6.exe and UninstallFSUIPC6.exe.  These I can run by double clicking on them.  And by following the instructions in that window to install eventually takes me to the registration screen where I enter the information, press "Register", and get the pop up error message.

The only FSUICP window I can access is through the P3D program's Add-on menu which gives all the information and logging options in the unregistered version.

10 hours ago, John Dowson said:

If so, it is probably due to your VC++ redistributables being corrupt. You need to uninstall any of the VC++ redistributables from 2015, 2017 & 2018, then re-install the combined package (both x64 an x86) from https://support.microsoft.com/en-in/help/2977003/the-latest-supported-visual-c-downloads

I uninstalled the VC++ 2015, and reinstalled x64 and x86 packages as suggested.  Re-ran Install_FSUIPC6.exe, entered the information, and still received the same pop up registration details not valid message.

Link to post
Share on other sites
3 hours ago, FireFlyer said:

Just to confirm that you mean FSUIPC6.exe?  If so, no, I can not find that application installed. 

Sorry, was getting confused and was referring to FSUIPC7. There is no exe for FSUIPC6.

I have PM'ed you a key file. Please place that in your FSUIPC6 installation folder.

Link to post
Share on other sites
  • 1 month later...
5 hours ago, vanislepilot said:

Same issue for me. No key is being generated.

As mentioned above, did you click the Register button and if so what happened?
If it said your key was valid, then check your installation location - make sure you haven't installed FSUIPC6 under your Documents folder, especially if you are using OneDrive or some other cloud-based storage mechanism for your Documents.

If all else fails, you can manually create your key file. Create a file in your FSUIPC installation folder called FSUIPC6.key, with the following contents, substituting the details in bold with those from your SimMarket order:

Quote

[User]
Name=Name you used  for the license purchase
Address=Email you used  for the license purchase
FSUIPC=Your key

 

Link to post
Share on other sites
On 4/9/2021 at 10:24 AM, John Dowson said:

As mentioned above, did you click the Register button and if so what happened?
If it said your key was valid, then check your installation location - make sure you haven't installed FSUIPC6 under your Documents folder, especially if you are using OneDrive or some other cloud-based storage mechanism for your Documents.

If all else fails, you can manually create your key file. Create a file in your FSUIPC installation folder called FSUIPC6.key, with the following contents, substituting the details in bold with those from your SimMarket order:

 

I just had the same issue with FSUIPC7, the installer didn't want to accept the registration data.

I created a FSUIPC7.key file manually as you suggested and it works fine. There is something wrong with the installer.

Maybe it's because I have some special characters in my name - the letter 'Ł' and a dash '-'?

Link to post
Share on other sites
1 minute ago, kowgli said:

Maybe it's because I have some special characters in my name - the letter 'Ł' and a dash '-'?

Maybe, but I don't think so. I have verified details here when this has happened (using the installer) and they have been fine. For a few users, re-installing the VC__ redistributables have solved this issue, for others not. However, as this is a rare occurrence, there is an easy work-around, and I cannot reproduce, its not really worth me investigating this at the moment, especially as I have so much else on my plate at the moment....

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.