Jump to content
The simFlight Network Forums

Using Throttle Set with FSL A320


Recommended Posts

I am trying to setup the FSL A320 using FSUIPC on the Honeycomb Throttle Quad.  The suggested way is using Throttle 1 Set and Throttle 2 Set and then using the various detent zones in the FSL MCDU to set the range for the various selections (CL, TOGA, REV etc.).  This worked great with my old CH Products throttle but does not seem to work with the Honeycomb.  The Honeycomb axis are reversed and I cannot figure out how to select reverse in FSUIPC with the Throttle Set (Send to FS as Normal Axis) selected.  

By setting Throttle set I am getting the full range of motion on the throttles and in the sim, albeit reversed.  If I try to use direct to FSUIPC or Throttle Set with Ignore Set on the calibration page then the throttles do work in the right direction but the range is about 60% of the full range of the throttles.  The only go from TOGA to about 30% thrust and nothing below. 

Any ideas on how to fix this?

Link to comment
Share on other sites

On 3/6/2021 at 2:00 AM, Mark777 said:

The Honeycomb axis are reversed and I cannot figure out how to select reverse in FSUIPC with the Throttle Set (Send to FS as Normal Axis) selected.  

Did you try unchecking the 'Exclude THROTTLEn_SET'  on page 3 of the calibration page, and then reverse the axis there for Throttle 1 and Throtttle2?
You can still calibrate in FSUIPC when sending to the FS, but this may result in multiple values being received by the sim (due to priority levels). I don't have the FSLA320, you you need to check this.

On 3/6/2021 at 2:00 AM, Mark777 said:

If I try to use direct to FSUIPC or Throttle Set with Ignore Set on the calibration page then the throttles do work in the right direction but the range is about 60% of the full range of the throttles.

You could also try assigning direct to FSUIPC calibration and to Throttle 1 and Throttle 2 and calibrate in FSUIPC. Otherwise, check that you have 'No reverse zone' checked in the individual throttle calibration screen as this would reduce the available range if unchecked.

Also maybe try assigning to the Axis Throttle n Set controls (under 'Send to FS as normal axis) instead.

Link to comment
Share on other sites

13 minutes ago, Mark777 said:

Someone on the FSL forums posted this and it worked.  I needed to add this to the fsuipc.ini


[JoystickCalibration.Fslabs]
...
UseAxisControlsForNRZ=Yes

Ok, yes - forgot about that option (sorry!). That will switch to using the Axis Throttle<n> Set controls using the full range (-16383 idle, +16383 max)

Link to comment
Share on other sites

John, one question for you.  this is a new Honeycomb Bravo Throttle quad.  I noticed after messing about for a while trying to get this to work that on Throttle #1 the range goes from -16383 to Zero in the movement space of about 2 millimetres.  Then the rest of the movement travels smoothly from zero to 16383.  the other throttle axis all travel through the full range.  Is there something I can do to try and reset the numbers range or do you think this is a defective pot that I have received.  It was not doing this when I first got it so I think the pot should be ok.

Link to comment
Share on other sites

8 hours ago, Mark777 said:

I noticed after messing about for a while trying to get this to work that on Throttle #1 the range goes from -16383 to Zero in the movement space of about 2 millimetres

Usually when an axis jumps like that and has two values, its because it is registered incorrectly as a digital axis (on/off) in windows.

Your could try clearing the registry entries and letting it re-register. There is a FAQ entry on how to do this for Saitek devices - you need to adjust (vendor and product ids) as needed - see 

 

Link to comment
Share on other sites

3 hours ago, John Dowson said:

Usually when an axis jumps like that and has two values, its because it is registered incorrectly as a digital axis (on/off) in windows.

Your could try clearing the registry entries and letting it re-register. There is a FAQ entry on how to do this for Saitek devices - you need to adjust (vendor and product ids) as needed - see 

 

Perfect, thanks!

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.