Jump to content
The simFlight Network Forums

FSUIPC WASM module + client-side API + lvar/hvar discussion topic


Recommended Posts

  • Replies 250
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Will be a while coming...I'm going to take the weekend off (bar support) and start on this next week...

Thank you sir! Much appreciated. I'm planning on some further development to make it possible to save the cockpit state of other models as well. I will include your WASM module and give you the c

I have just released version 0.4.3. This supports of to 1022 lvars. There is also a minor change to the CDAType enum that may require code changes to anyone implemeting their own client.

Posted Images

39 minutes ago, Airbuspilot said:

How can i realize that? * is not possible as a Filename.
I am a german Citizen and have a german OS Layout. Do i have to change it, to name it *.hvar?

Sorry. the '*' is just a wildcard, you replace that with letters that match as a substring to the aircraft title, as indicated by @SAC002

Link to post
Share on other sites
19 hours ago, SAC002 said:

John, here's my first version of the hvar file for the TBM.

It is probably not complete but it covers the G3000. 

Cheers,

TBM.hvar 1.07 kB · 8 downloads

Did you succeed to use the knob for the map with fsuipc (? H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC)

For me it does not work, do you use a spécifical paramter ? same question for H:AS3000_PFD_1_SOFTKEYS_1 (It work with mobiflight wasm but not with fsuipc wasm module)

 

Link to post
Share on other sites
27 minutes ago, guit33 said:

Did you succeed to use the knob for the map with fsuipc (? H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC)

For me it does not work, do you use a spécifical paramter ? same question for H:AS3000_PFD_1_SOFTKEYS_1 (It work with mobiflight wasm but not with fsuipc wasm module)

First, check you have those hvars listed in the FSUIPC hvar file for your aircraft. You can check this by using the Add-ons->WASM-> List Hvars menu option. If they are not there, then you need to add them to the hvar file and then Add-ons->WASM->Reload.

Once you have confirmed the hvars are available, create a macro file to use them. Note hvars do not have an associated value/parameter. Your macro file should look something like this:

Quote

[Macros]
1=H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC=Set
2=H:AS3000_PFD_1_SOFTKEYS_1=Set

And then assign your buttons (or keys) to the hvar name.

You can also try to execute the hvar (before adding it) using the Add-ons->WASM->Execute Calculator Code function, using, for example, the following:
    (>H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC)

Link to post
Share on other sites
35 minutes ago, guit33 said:

Did you succeed to use the knob for the map with fsuipc (? H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC)

For me it does not work, do you use a spécifical paramter ? same question for H:AS3000_PFD_1_SOFTKEYS_1 (It work with mobiflight wasm but not with fsuipc wasm module)

And I've just checked the MF events and those hvars don't exist! Should they be:
    H:AS3000_TSC_Horizontal_BottomKnob_Small_DEC
    H:AS3000_PFD_SOFTKEYS_1
?
Maybe try with those instead - first via Execute Calculator code to see if they are available and work, and if so you can add them to your hvar file and assign.

  • Thanks 1
Link to post
Share on other sites

I am agree the good one is 

H:AS3000_TSC_Horizontal_BottomKnob_Small_DEC and not H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC

so the HVAR in the previous  post for the TBM930 is not good.

And I finally to lake all this work !

Thanks for help

Link to post
Share on other sites

This is certainly very interesting...

here  are my HVAR file, my macro file and my FSUIPC config file...

and I can confirm that all of these buttons works in my cockpit with the latest version of the work title garmin 3000 with the TBM 930.

I also opened the model behaviour window in the dev mode of MSFS2020 and open the AS580 submenu and i can see the hvars with the _1_...

Maybe John can explain what is going on if some of you can make it work without putting the _1_ in the var name for the PFD and TCS variables...for the MFD, you don't need the _1_ because there is only one MFD...

Cheers,

Daniel

 

FSUIPC7.ini TBM.hvar TBM930.mcro

Link to post
Share on other sites
3 hours ago, SAC002 said:

 

I also opened the model behaviour window in the dev mode of MSFS2020 and open the AS580 submenu and i can see the hvars with the _1_...

Maybe John can explain what is going on if some of you can make it work without putting the _1_ in the var name for the PFD and TCS variables...for the MFD, you don't need the _1_ because there is only one MFD...

Cheers,

Daniel

Might the Pilot PFD be considered "1" and the co-pilot PFD is "2"?  There is only one MFD so that is that.  On the TBM I saw this on GTC 580.  The events where the one closest to the pilot is "1" and the other closest to the co-pilot is "2" (TSC_Horizontal_1... and TSC_Horizontal_2...) for example.

Edited by hiddencreative
corrected spelling error.
Link to post
Share on other sites
13 hours ago, SAC002 said:

This is certainly very interesting...

Yes indeed...

13 hours ago, SAC002 said:

and I can confirm that all of these buttons works in my cockpit with the latest version of the work title garmin 3000 with the TBM 930.

Do you also use a mod for the TBM930, of so, which?

13 hours ago, SAC002 said:

Maybe John can explain what is going on if some of you can make it work without putting the _1_ in the var name for the PFD and TCS variables...for the MFD, you don't need the _1_ because there is only one MFD...

Not at the moment - seems strange that the _1.. version works for some, and the one without for others. I can only think that it must be different mods or versions. It makes sense having _1... and _2.. versions for 2 PFDs, as also indicated by @hiddencreative, but I don't understand why this is different for different people unless the mods used are different...

I haven't installed the WT G3000 yet, I'll take a look sometime. Maybe the difference is using this with or without the GTC 580 (the touch-screen controller)...

Link to post
Share on other sites
1 minute ago, SAC002 said:

Not sure what they are called...i actually have 2 (don't use them together)..

I will go to the sim shortly and report

Ok, thanks. Would be useful to know what those are and if they can account for the differences...

Link to post
Share on other sites

ok without any addons for the TBM or the G3000, it still works..

H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC

While in MDF mode, the range decrease as i rotate the rotary which is mapped to this variable via the button assignments in FSUIPC.

In fact, all my variables with a _1_ in the hvar file works...(all 12 PFD softkeys for example)...

With the Working title G3000 mod installed, version 0.6.1, still works...

With my TBM mod (aircraft-tbm930x_1.14.5.0_LfSPW) and the G3000 mod, still works...

Cheers,

 

Link to post
Share on other sites
25 minutes ago, SAC002 said:

ok without any addons for the TBM or the G3000, it still works..

H:AS3000_TSC_Horizontal_1_BottomKnob_Small_DEC

While in MDF mode, the range decrease as i rotate the rotary which is mapped to this variable via the button assignments in FSUIPC.

In fact, all my variables with a _1_ in the hvar file works...(all 12 PFD softkeys for example)...

With the Working title G3000 mod installed, version 0.6.1, still works...

With my TBM mod (aircraft-tbm930x_1.14.5.0_LfSPW) and the G3000 mod, still works...

Interesting. Did you try using H:AS3000_TSC_Horizontal_BottomKnob_Small_DEC to see if that also works? You can try this using the Add-ons->WASM->Execute Calculator Code function (if its not in your hvar file), using: 
        (>H:AS3000_TSC_Horizontal_BottomKnob_Small_DEC)

Strange that it doesn't work for @guit33.

I'll take a look but probably not until the weekend. Trying to get the garden in shape this week (as it it has been abandoned the last 6-12 months or so!) so am only covering basic support until next week...

Link to post
Share on other sites

yes and it does work....and I also tried H:AS3000_TSC_Horizontal_BottomKnob_Push and it affected both touch screen displays at the same time...while H:AS3000_TSC_Horizontal_1_BottomKnob_Push only affected the pilot touch screen...

interesing hein ?...lol

Link to post
Share on other sites
3 minutes ago, SAC002 said:

yes and it does work....and I also tried H:AS3000_TSC_Horizontal_BottomKnob_Push and it affected both touch screen displays at the same time...while H:AS3000_TSC_Horizontal_1_BottomKnob_Push only affected the pilot touch screen...

interesing hein ?...lol

Yes, and that kind of makes sense...I just don't know why it isn't working for some....

Link to post
Share on other sites
On 5/3/2021 at 8:30 PM, John Dowson said:

Sorry. the '*' is just a wildcard, you replace that with letters that match as a substring to the aircraft title, as indicated by @SAC002

Thanks John for the Explanation.

Link to post
Share on other sites
On 5/3/2021 at 7:57 PM, SAC002 said:

Replace the * by the substring match to the aircraft title

for example, TBM 930.hvar

 

Thanks for your Reply. I will try it.

Link to post
Share on other sites
Quote

Yes, and that kind of makes sense...I just don't know why it isn't working for some....

This is interesting.  I previously wrote some LUA that was using the AS3000_TSC_Horizontal_1_TopKnob_Large_INC style references using the "number 1" to represent the left/right 580 and that was working.  I have to mention here, that that event was used with Mobiflight on an overlay I created for Air Manager.  That being said, the "1" used to control the left 580 and a "2" controlled the right 580, and "no number" controlled both, just as stated here.  I am also using the Working Title G3000.  Now, today, I am seeing the same problems that are being discussed.  My 580 overlay stopped working completely.  When I removed the reference numbers for the left/right 580... guess what.  Everything works again.  The only thing is I have lost individual control of the two 580's.  Pushing a button or turning a knob does so for both instruments now.
 

Link to post
Share on other sites
31 minutes ago, hiddencreative said:

Now, today, I am seeing the same problems that are being discussed.  My 580 overlay stopped working completely.  When I removed the reference numbers for the left/right 580... guess what.  Everything works again.  The only thing is I have lost individual control of the two 580's.  Pushing a button or turning a knob does so for both instruments now.

What has changed on your system since this change? Was anything updated - MobiFlight, G3000 or the 580 overlay?
 

Link to post
Share on other sites
Quote

What has changed on your system since this change? Was anything updated - MobiFlight, G3000 or the 580 overlay?

The 580 overlay I wrote myself.. no change there.  I have not updated the WT G3000, or Mobiflight since my last flight, but I did make a change, and I don't know how I can revert or retest without a full removal and re-installed. Day before yesterday I applied World Update II (USA) -- I know behind as it came out a while ago, and there was n update to the MSFS SDK that I download and applied.  The SDK is easy enough to back out... but the World Update... not sure.  I still need to definitively go through the system to verify that nothing else changed.  I have to run an errand but I will take a deeper dive looking for any other change this afternoon.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.