Jump to content
The simFlight Network Forums

Unable to access Mouse Macros


Recommended Posts

Sorry if this is the wrong place to post this question.

I have downloaded and installed FSUIPC 6.1.1. I have a number of mouse macros created in my previous version of FSUIPC that appear in the .ini file (after install of 6.1.1) but do not show up when trying to assign buttons. Aircraft profile is checked.

Am using P3D v 5.1.

Thanks for any help.

Martin

 

 

Link to comment
Share on other sites

10 hours ago, Bigmarty said:

I have downloaded and installed FSUIPC 6.1.1. I have a number of mouse macros created in my previous version of FSUIPC that appear in the .ini file (after install of 6.1.1) but do not show up when trying to assign buttons. Aircraft profile is checked.

You need to show us your FSUIPC6.INI file as otherwise we have no information with which to assist!

Pete

P.S. I moved your question to the correct place, the Support Forum. You posted in a programming sub-forum.

 

Link to comment
Share on other sites

18 minutes ago, Bigmarty said:

The .ini file is attached.

So your macro files are these:

[MacroFiles]
1=6 DHC
2=737
3=400 Q
4=9 CRJ
5=7 crj
6=DHC 6

Did you copy your FSUIPC INI file over from your previous version? Could that list possibly have been carried over from the last installation? That would be expected and reasonable. But did you also move those 6 .mcro files over as well? They need to be in the same folder.

You have assignments to macros in several different profile assignments. If not all, which ones are you saying aren't now recognised?

Pete

 

Link to comment
Share on other sites

The .ini file contained the macros after the 6.1.1 was installed. I did not copy anything over myself. The following files are contained within the Modules folder, but outside of the .ini file.  Hope this is what you asked about.

None of the macros appear when trying to assign a button with "Select FS Control". In the previous FSUIPC version, all of the macros came up under Axis Assignment and Buttons and Switches.

Appreciate your help.

Martin

 

 

400 Q.MCRO.bak 737.MCRO.bak 737.MCRO 400 Q.MCRO 6 DHC.MCRO.bak 9 CRJ.MCRO.bak 9 CRJ.MCRO 6 DHC.MCRO

Link to comment
Share on other sites

53 minutes ago, Bigmarty said:

The .ini file contained the macros after the 6.1.1 was installed. I did not copy anything over myself.

Sorry, I'm confused.  When you said:

19 hours ago, Bigmarty said:

I have downloaded and installed FSUIPC 6.1.1. I have a number of mouse macros created in my previous version of FSUIPC

did you mean your "previous version" also being an FSUIPC6? Are you saying you just updated, for example from 6.1.0 to 6.1.1? If so, then I misunderstood. I thought you meant from FSUIPC5 to FSUIPC6.

According to your list of .mcro files, you've actually of got 4. Of these:

[MacroFiles]
1=6 DHC
2=737
3=400 Q
4=9 CRJ
5=7 crj
6=DHC 6

you are missing 7 crj and DHC 6. You don't have any assignments to 7 crj, but you do have just one to DHC 6 (Button 3 on Joy #1.

However, I understand that isn't the problem. You appear to be saying that none of the macro files are providing entries in the Buttons, Keys or Axes assignments drop downs. Is that correct? And they were listed with your previous version of FSUIPC? 

Belatedly, I now see that the INI file you posted is from FSUIPC 6.008. Why haven.t you provided the INI file from your current 6.110 version? I need to see the current one, please.

Pete

 

 

Link to comment
Share on other sites

Ok, there are three log files and all 3 are attached with the install file.

I also reinstalled FSUIPC 6.1.1 just now but the .ini file (attached) is still showing version 6.008. My previous version of FSUIPC was 6.0.8. I have a screenshot of the FSUIPC opening page in version 6.0.8 but I am not sure if I should post it here. I will if it helps.

All the Macros were available entries before the install of 6.1.1.

I should also say that I am not using all of the macros and I don't have a problem rebuilding the ones I use if you don't want to look into this any further.

Martin

 

 

 

FSUIPC6.1.log FSUIPC6.2.log FSUIPC6(1).ini InstallFSUIPC6.log FSUIPC6.log

Link to comment
Share on other sites

Oh boy, this is a real construction. 😀
As a side note, there's no sign of v6.1.0 having been installed.

Well, there's the proper installation path set for FSUIPC for P3Dv4, that is C:\Program Files\Lockheed Martin\Prepar3D v4\Modules...yet there actually isn't...there's a flag for FSUIPC installed in D:\FSUIPC for P3Dv5..
You use both v4 and v5 of Prepar3D, correct ?
You also use multiple machines, since I notice you have WideFS.
The installer went on to uninstall the previous version from that location, then set it as the new default location and proceeded.
But there's more at another place...probably here...please could you go to these two locations if both exist:

D:\Martin\Documents\Prepar3D v4 Add-ons\FSUIPC6
and
D:\Martin\Documents\Prepar3D v5 Add-ons\FSUIPC6

Verify you see a file named add-on.xml in both locations ?
(taking into account the state of everything we also might wanna check XML's at addon folders for P3Dv4 and v5 at  C:\Users\Martin\AppData\Roaming\Prepar3D v4 Addons, C:\Users\Martin\AppData\Roaming\Prepar3D v5 Addons, C:\ProgramData\Prepar3D v4 and C:\ProgramData\Prepar3D v5...

Mr.Dowson, if you are over your head with a lot of work, can I take this ?
Bigmarty, I would gladly help fix your issue if it turns complicated.

Link to comment
Share on other sites

5 hours ago, Milan Putnik said:

Mr.Dowson, if you are over your head with a lot of work, can I take this ?

That's very good of you. Yes please.  Both of us Dowsons have a lot on our plates right now, and this one is supposed to be "retired" 😉

Pete (the elder Dowson).

 

  • Like 1
Link to comment
Share on other sites

Those logs are from 3rd Feb  and 8th March, and the ini's are probably just as old.
So it looks likeyou have installed in another folder to your original installation folder. You need to determine where you have actually installed v6.1.1. The best way to do this is to use the Open Folder button in the logging tab.

But, probably the best thing to do is to just re-install again. This will uninstall your current version, and allow you to select the installation folder. Make sure that you select your old installation folder - the one where your .mcro files are located.

7 hours ago, Milan Putnik said:

Mr.Dowson, if you are over your head with a lot of work, can I take this ?
Bigmarty, I would gladly help fix your issue if it turns complicated.

A re-install into the correct folder should fix his issues, but you can certainly continue with this if the OP has more issues, thanks.

  • Like 1
Link to comment
Share on other sites

First, let me say that when posting my issue I was hoping there was a simple fix - I certainly did not intent for this to be a big time consumer when everyone is so busy. So many thanks to everyone.

I reinstalled version 6.1.1 as suggested and while this resulted in v6.1.1 showing as the installed version, the macros still were still not available in FSUIPC buttons. Then I uninstalled FSUIPC via Windows control panel (instead of letting the FSUIPC install process remove the previous version), reinstalled 6.1.1 and now everything is back to as before, that is the axis assignments, and button assignments including the macros

So, back to normal and thanks again for all the time spent and help.

Martin

 

Link to comment
Share on other sites

26 minutes ago, Bigmarty said:

I reinstalled version 6.1.1 as suggested and while this resulted in v6.1.1 showing as the installed version, the macros still were still not available in FSUIPC buttons.

This is because you installed it into a different location where the macro (.mcro) files were not present.

27 minutes ago, Bigmarty said:

Then I uninstalled FSUIPC via Windows control panel (instead of letting the FSUIPC install process remove the previous version), reinstalled 6.1.1 and now everything is back to as before, that is the axis assignments, and button assignments including the macros

Uninstalling via the windows app panel runs the generated FSUIPC uninstaller. The only difference running it manually (rather than letting the installer run it for you) is that the default installation location will be different. When you run the installer an it first uninstalls, when you come to install again the default installation location will be the previous installation location. If you uninstall manually first, when you run the installer the installation location will default to either C:\FSUIPC6 or your P3Dv5 add-on xml folder (depending on if you install for just P3Dv5 or P3Fv4).

You should really take note of your installation folder (and change it if needed) when you install. Your issues were due to the fact that you installed in a different folder, and all the files you posted were from your original installation folder and so were out-of-date / not relevant to your issue.

I suggest that you read the Installation and Registration manual which will tell you how the installer works and where files are installed.

And remember that you can always use the 'Open Folder' button to determine where your installation folder is, and where the files that we request will be located.

John

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.