Jump to content
The simFlight Network Forums

Recommended Posts

I have a working installation of FSUIPC on my windows 7 box. FSX has been installed since 2010 (or maybe 2012).

I installed FSX on my new Win10 box, installed FSUIPC, and although it pops up, and allows me to program buttons on my Saitek yoke and throttles, I also have a DTK rotary encoder box. Six rotary encoders connected with USB. 

On my win7 box, I had them programmed as HDG, OBS1, ALT, VS, TRIM and OBS2.

On my win10 box, I get "This has multiple actions already! Please edit it in FSUIPC.INI"  The checkbox for select for FS Control is greyed out, and the Control Sent when button pressed is CORRECT, but greyed out. It doesn't work, either. I get other FS things happening, like flaps, view rotation, etc.

My FSUIPC4.INI is attached.  What do I edit?

Ed

FSUIPC4.ini

FSUIPC4.ini

Link to post
Share on other sites
49 minutes ago, edgreenberg said:

On my win10 box, I get "This has multiple actions already! Please edit it in FSUIPC.INI"  The checkbox for select for FS Control is greyed out, and the Control Sent when button pressed is CORRECT, but greyed out. It doesn't work, either. I get other FS things happening, like flaps, view rotation, etc.

My FSUIPC4.INI is attached.  What do I edit?

You attached two INI files, but neither show a file which has been used by a running copy of FSUIPC -- they look like they've been edited quite a bit. for example, the [JoyNames] section doesn't identify any devices actually connected:

[JoyNames]
AutoAssignLetters=No
J=Saitek Cyborg Evo Force
J.GUID={72295FC0-D3CF-11E0-8001-444553540000}
T=Saitek Pro Flight Throttle Quadrant
T.GUID={5CB02AD0-353A-11E1-8001-444553540000}
R=DTA Rotary Encoder << MISSING JOYSTICK >>

These show you HAD two devices attached, but the lines are missing showing they've been detected and giving the ID numbers.

Now look at your [Buttons] section, You have many of the same assignments repeated -- I've separated the repeats out so you can see:

[Buttons]
ButtonRepeat=20,10

1=PR,1,C65880,0
2=PR,0,C65879,0
3=PR,5,C65893,0
4=PR,4,C65892,0
5=PR,2,C1027,0
6=PR,3,C65662,0
7=PR,9,C65607,0
8=PR,11,C65664,0
9=PR,10,C1029,0
10=PR,6,C65894,0
11=PR,7,C65895,0
12=PR,8,C65615,0

13=PR,1,C65880,0
14=PR,0,C65879,0
15=PR,3,C65662,0
16=PR,2,C65663,0
17=PR,7,C65895,0
18=PR,6,C65894,0
19=PR,9,C65607,0
20=PR,8,C65615,0
21=PR,5,C65893,0
22=RR,4,C65892,0

23=UR,4,C3,0
24=PR,1,C65880,0
25=PR,0,C65879,0
26=PR,3,C65662,0
27=PR,2,C65663,0
28=PR,5,C65893,0
29=PR,4,C65892,0
30=PR,9,C65607,0
31=PR,8,C65615,0
32=PR,11,C65664,0
33=PR,10,C65665,0
34=PR,7,C65895,0
35=PR,6,C65894,0

36=PR,1,C65880,0
37=PR,0,C65879,0
38=PR,3,C65662,0
39=PR,2,C65663,0
40=PR,5,C65893,0
41=PR,4,C65892,0
42=PR,7,C65895,0
43=PR,6,C65894,0
44=PR,9,C65607,0
45=PR,8,C65615,0


I've no idea how your arrived at this mess. Possibly you have been using Profiles at one time and then deleted the profile section headings -- [Buttons.<profile name>]?  I can't see any other way you might have done this.

Don't you have a copy of your working FSUIPC4.INI from the Win7 PC? It would be better to start from that.

With this INI there are some steps you can take, but to be honest there's very little of any use in it. You might be better off deleting it altogether and letting FSUIPC build another. With just 12 buttons to assign, and all to standard controls by the look of it, that would be pretty quick to do.

If you want to persist with this one, delete all but one of those blocks of repeating assignments.

BUT if you want further support please update to a supported version of FSUIPC. You are on 4.80. The current version is 4.976. You can get it on FSUIPC.com. And next time please make sure you run FSX first before supplying the INI, and don't edit it before showing us.

Pete

 

Link to post
Share on other sites

Peter, thanks for the quick reply.  This FSUIPC4 file was from the Win7 machine. My recollection is that it works, though I've moved all the peripherals to the Win10 machine.  Given that the only customizations are my six rotary encoders, I'm happy to toss all of it and rebuild. Can I do that by just deleting the file and let it recreate? 

Also, can you confirm the correct location of the file? Is it in the FS directory under modules?

Thanks, Ed

Link to post
Share on other sites
38 minutes ago, edgreenberg said:

This FSUIPC4 file was from the Win7 machine.

Well it doesn't appear to have been used there. Still, if it was you'd certainly have encountered the same "multiple actions" problem.

39 minutes ago, edgreenberg said:

Given that the only customizations are my six rotary encoders, I'm happy to toss all of it and rebuild. Can I do that by just deleting the file and let it recreate? 

Yes, just delete it before starting FSX.

40 minutes ago, edgreenberg said:

Also, can you confirm the correct location of the file? Is it in the FS directory under modules?

Yes. Everything concerning FSUIPC in the FSX Modules folder.

Please don't forget to download and install the current version of FSUIPC4.

Pete

 

Link to post
Share on other sites
11 hours ago, edgreenberg said:

First, I confirm that I have 4.976 on my Win10 machine.  I now have the encoder box working fine.

Good to hear! Happy flying.

Pete

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.