Jump to content
The simFlight Network Forums

WideFS with P2A & MSFS


V3ER
 Share

Recommended Posts

Hi there, I have noticed lots of stutters when using WideFS connected to P2A on MSFS. I have significant stutters on arrival upon TOD. I was able to verify WideFS causing this as turning Wide off and disconnecting it made the stuttering stop instantly.

FSUIPC 7 by itself does not cause any issues.

Regards

V3

Link to comment
Share on other sites

Welcome to the boards!
The method you employed cannot indicate anything substantial let alone the specific cause of your issue.
Could you please zip and attach your latest files named:

FSUIPC.ini
FSUIPC.log
WideServer.log
WideClient.log
(if applicable)


If you need help finding them, I can guide you.

M

Link to comment
Share on other sites

Posted (edited)

Thanks! Find attached the requested files minus the client.

This is the third flight where having Wide run with P2A caused severe stutters in the sim and disabling Wide stopped it.

 

New folder.rar

Edited by V3ER
Additional information
Link to comment
Share on other sites

4 hours ago, V3ER said:

This is the third flight where having Wide run with P2A caused severe stutters in the sim and disabling Wide stopped it.

WideFS is only doing what P2A requests of it. The proper test to show that it isn't WideFS causing the problem is surely to stop P2A running instead.

Note also that MSFS will use as much processing power as you allow it, and any other activity on the same PC (such as that instigated by add-ons like P2A, even if via WideFS) will be noticeable as stutters. Make sure you limit MSFS frame rates to something your PC can manage consistently whilst running your add-ons.

You omitted to supply the WideClient.Log file from the P2A PC, which is in fact the most important, as it will show if WideClient was having problems.

The only odd thing showing up in the files you have supplied is the number of repeated Device Scans logged in the FSUIPC log. The scans only occur in two circumstances:

1 visiting the axis or button assignments options in FSUIPC, or
2 there's some USB reconnections occurring.

If you didn't keep opening those option windows, then you need to check your USB connections. Maybe you have a Hub which is playing up.

Pete

 

Link to comment
Share on other sites

9 hours ago, Pete Dowson said:

The only odd thing showing up in the files you have supplied is the number of repeated Device Scans logged in the FSUIPC log. The scans only occur in two circumstances:

1 visiting the axis or button assignments options in FSUIPC, or
2 there's some USB reconnections occurring.

Thanks for the response Pete. Yes this may have happened as I had issues with the USB device not working, so I had to remove and replug it. I am on the new AMD platform and they've had issues with USB.

I have attached the WideClient logs from the other computer as well. 

 

Thanks. 

WideClient.log WideClient0.log

Link to comment
Share on other sites

9 hours ago, Pete Dowson said:

Make sure you limit MSFS frame rates to something your PC can manage consistently whilst running your add-ons.

I have limited to 30 FPS which I have no problems with when not using P2A in Wide config. I intend to move P2A to the main PC and run it to see if it causes same issues without the Wide connection. Will report back my findings.

Thanks.

Link to comment
Share on other sites

I am not sure if this connection interruption from WideClient.log is of any significance:

  1815828 Error on client pre-Connection Select() [Error=10060] Connection timed out

Aside from that detail, the rest looks like you have quite a lot of traffic happening.
Check out if it gets better if you turn down the amount of traffic and whatever else there is, so that you lower the amount of data sent between machines and see how it performs...although with a solid CPU it shouldn't be a problem...
Yes it is very good to check how does everything work when you run the P2A locally on the sim machine - I'd appreciate hearing how did it go.

I'd like to suggest we try a few things that might alleviate the network traffic related stutters:
First, is your CPU model the latest Zen3 architecture (Ryzen 5000 series) ?
The issue with USB devices disconnecting at random has been patched for Zen3 suported AM4 X570, and select B450 and X470 motherboards by AMD back in April.
Make sure you run the updated BIOS with the latest AGESA v3801 for your chipset - that one will get you rid of those USB issues.
It is not excluded your stutters could be the result of those firmware bugs, because those disconnects actually steam from certain issues related to PCIe4.0, so if you run a PCIe4.0 NVMe drive or/and one of the latest nVidia or AMD GPU's you'll surely gain performance and stability.

Lastly:

1. Press Win key and X at the same time - release - then press W

2. Network settings open - click Change adapter options

3. Right click your active network connection's adapter icon then Properties

4. In the new window go Configure
 
6. Then to Advanced tab

7. Make sure that Number of RSS queues is set to the maximum number available

8. Make sure Receive Side Scaling is set to Enabled

9. Jumbo frames confirm set to Disabled

10. Set the Transmit Buffers size so that it is exactly double the Receive Buffers size  and at least 512

11. Click OK, confirm, OK, OK OK

12. Restart both machines

See how the P2A and the whole sim generally perform.

All the best !
M

Link to comment
Share on other sites

Thanks Milan, I am unsure where its getting all the traffic from as I have all AI and Multiplayer traffic disabled in the sim. Wonder if IVAO was running in the background. 

I do have an X570 with a Zen 3 chip. I've updated the BIOS from Gigabyte to the latest F33 the nvme is pcie 3 bit the vid card is running on pcie 4.

I will implement your suggestion with the network settings first thing tomorrow and report back my experience.

Thanks.

  • Like 1
Link to comment
Share on other sites

14 hours ago, V3ER said:

I have attached the WideClient logs from the other computer as well.

They show everything working well. Pilot2ATC is using the facility well:

  1786984 **************** Individual client application activity ****************
  1786984 Client 1220 requests: 4670 (Ave 2/sec), Data: 6129012 bytes (3435/sec), Average 1312 bytes/Process
  1786984 ***********************************************


So if running Pilot2ATC detracts noticeably from the performance of your MSFS installation then either

1 your MSFS PC is underpowered from what you are asking it to do, ot more likely
2 you are letting MSFS run as fast as it can with no limits and therefore notice small drops when these are occurring because of other things happening.

To deal with the latter you need to limit the frame rate in MSFS, for example by setting the Vertical Sync option. To deal with the former you may need to reduce some of your settings for MSFS graphics and maybe choose a simpler aircraft to fly.

I see Milan has made some more technical suggestions relating to your Network. I would never have thought of anything like that, I just use the network as it is -- my main 737 cockpit uses a Network of 10 PCs using WideFS for many external programs as well as ProSim, another Network user, and I aim for and achieve a smooth 25 fps with Prepar3Dv5. Except over London I could easily get a smooth 30 fps, but I like dense scenery. (I don't yet use MSFS on that system because it uses two projectors for a 200 degree field of view out of the cockpit and this cannot be done yet with MSFS).

One thing you could change in your WideFS configuration which may help a little is to use UDP protocol instead of TCP. To do this use the parameters

ServerName=DESKTOP-O2B600O
Protocol=UDP

in the [Config] section of the WideClient.INI file (in your WideClient folder).

Pete

 

Pete

 

  • Upvote 1
Link to comment
Share on other sites

13 hours ago, Milan Putnik said:

1. Press Win key and X at the same time - release - then press W

2. Network settings open - click Change adapter options

3. Right click your active network connection's adapter icon then Properties

4. In the new window go Configure
 
6. Then to Advanced tab

7. Make sure that Number of RSS queues is set to the maximum number available

8. Make sure Receive Side Scaling is set to Enabled

9. Jumbo frames confirm set to Disabled

10. Set the Transmit Buffers size so that it is exactly double the Receive Buffers size  and at least 512

11. Click OK, confirm, OK, OK OK

12. Restart both machines

Hi Milan, my server computer (main pc with FS) had all the settings as mentioned except transmit and receive were both set to 512. I changed the transmit to 1024 while keeping the receive at 512. On my client PC I do not have any of these options as it is a laptop running on WIFI.

Link to comment
Share on other sites

4 hours ago, V3ER said:

Hi Milan, my server computer (main pc with FS) had all the settings as mentioned except transmit and receive were both set to 512. I changed the transmit to 1024 while keeping the receive at 512. On my client PC I do not have any of these options as it is a laptop running on WIFI.

That is good - you now basically increased the amount of RAM memory dedicated to your network adapter so now when it offloads the work of processing such types of more granulated types of TCP or UDP traffic from the CPU (all kinds of data streamed into the sim, local IO traffic such as WideFS and the rest of the standard services) - it's able to process more data per cycle.
It also knows that it has twice the amount of one above other, so it will reschedule packet handling accordingly (it mostly makes for a much "sharper" network packet scheduling).
Not everybody is cranking that to the max and it's not widely known because if used just like that "let's go rock n roll" it can even negatively impact performance or cause the network adapter to drop the connection.

You have such options on your laptop as well, you just left click the active wireless network adapter that you'll also see in the list - then properties....the same...although drivers often make the layout visually different, add more features and misplace others, it mostly boils down to the same concept.
Anyway, those options are present on every network adapter be it wired or wireless. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.