Jump to content
The simFlight Network Forums

FSUIPC 5.153 or 5.157 Where to buy this version?


Recommended Posts

Dear Pete & John,

I need to buy FSUIPC 5.153 or 5.157 versions, due I'm using Linda 3.1.1 and it not works with FSUIPC 6. Then one of this two  this versions its mandatory.

I'm trying to buy it throught Simmarket, but there are only V4, 6 &7 versions, but not 5.

I'm a v6 registered user, but this licence does not work with FS5.

Where I can found 5.153 or 5.157 versions to buy?

Thank you,

Toni Cumellas

Link to post
Share on other sites

I've moved your message to the Support Forum. Please do NOT post support questions to any of the reference subforums.

20 hours ago, ToniC said:

I need to buy FSUIPC 5.153 or 5.157 versions, due I'm using Linda 3.1.1 and it not works with FSUIPC 6. Then one of this two  this versions its mandatory.

FSUIPC5 is replaced by FSUIPC6 and is no longer in development and is not sold.  I think you must be wrong in any case -- there are plenty of Linda users on FSUIPC6 (and even FSUIPC7, for MSFS). Check with Linda support.

Pete

 

 

Link to post
Share on other sites

Dear Pete,

I'm Toni, using friend's account.

I'm not wrong. Following the LINDA manual, there are 3 LINDA versions

3.1.1,  3.2.6 and 4.0.5

3.1.1 for FSX to P3D v4.5 (See bold required FSUIPC versions below. It depends of simulator used)

3.2.6 For P3Dv5 and FSUIPC 6

4.05 for MSFS2020 and FSUIPC 7

 

Due I'm using P3Dv4.5, I must mandatory use 3.1.1 version and  the LINDA MANUAL  is very clear about it: (Copy&paste)

This release requires a registered version FSUIPC5 5.153 or later to work with P3Dv4. FSUIPC4 4.974 or later is required for other 32-bit Flt Sims (FSX, FSX-SE or P3Dv3.4). LINDA WILL NOT FUNCTION WITH OLDER VERSIONS OF FSUIPC.

IT IS NOT COMPATIBLE WITH P3Dv5 OR FSUIPC6.

So I undestand from above, that I must use 5.153 or later, but it's not with FSUIPC 6 compatible.

I've tried it. Not works with my FSUIPC 6 registered copy.

I have bought FSUIPC 4, and 6, but not 5, and there are no place to buy it. So, new users using P3D4.5 with LINDA cannot use their VRINSIGHT COMBO, due the impossibility to buy discontinued 5.153-5.1.57 versions.

 

But dont worry, I 've find an old backup of  5.157 version and all is working fine again.

Only for your knowledgment.

 

Best wishes,

Toni

 

Links:

https://www.avsim.com/forums/topic/512119-linda-311-32-64-bit-compatible-16-feb-2020/

https://www.avsim.com/forums/forum/427-linda-downloads/

Link to post
Share on other sites
13 minutes ago, agusti747 said:

But dont worry, I 've find an old backup of  5.157 version and all is working fine again.

Fine, but you should certain make an extremely strong complaint to the LINDA people. If it refuses to run with FSUIPC6 it can only be because they've deliberately incorporated a check on the version number,  because FSUIPC6 is 100% compatible with FSUIPC5.

The whole point of the way the FSUIPC programming interface has evolved (and the Lua library included) is to do with ongoing compatibility. This has been so since FS98 days. New facilities are added but existing facilities are kept compatible. It would be possible for an application to be written for FSUIPC6 or 7 and not be compatible with FSUIPC5 or 4, but not vice versa.

Pete

 

 

Link to post
Share on other sites

Thank you for your clear explanation, Pete.

Then I don't understand why LINDA people wrote in his forums that LINDA 3.11  it's not compatible with FSUIPC 6.

 

Perhaps is an error, but for me, FSUPC 6 does not works with LINDA 3.11 and with 5.157 yes.

A mistery. I will tell you here if I'm able to find and answer.

 

Again, thanks for your time.

 

Link to post
Share on other sites
20 hours ago, agusti747 said:

Then I don't understand why LINDA people wrote in his forums that LINDA 3.11  it's not compatible with FSUIPC 6.

Because they evidently check specifically for FSUIPC5. I don't know why, you'd have to ask them.

However, as John points out, you need to update your LINDA. Evidently they changed that check in the later version. If the later version of LINDA doesn't work that needs sorting out. FSUIPC5 will not be probably not be supported for much longer.

Pete

 

Link to post
Share on other sites
12 hours ago, agusti747 said:

I found a backup of an old fsuipc 5.157

FSUIPC5 is always available from the download section here, and also in www.fsuipc.com.
It is only the license that is no longer for sale. But if you have already purchased a license, you can always retrieve your license details from your SimMarket account.

However, you should really move to FSUIPC6 if you have a license for that, and resolve your Linda issues with that version.
FSUIPC5 is still supported (for P3Dv4.5), but is closed for future development.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.