Jump to content
The simFlight Network Forums

fsuipc switch allocation


Recommended Posts

I am using P3D v 5.1 I want to be able to control the mag/start switches for 2 engines. I can set each switch in fsuipc as follows : mag off/mag R/mag L/mag both/Start...  When I try to use the switch it goes from OFF/R/Both... thats it. It bypasses mag L and will not go to Start. IF I change the mags from L / R  order and try the switch it goes OFF/L/Both and no start  ???  How do I fix this ?

Link to comment
Share on other sites

7 hours ago, rodder47 said:

I am using P3D v 5.1 I want to be able to control the mag/start switches for 2 engines. I can set each switch in fsuipc as follows : mag off/mag R/mag L/mag both/Start...  When I try to use the switch it goes from OFF/R/Both... thats it. It bypasses mag L and will not go to Start. IF I change the mags from L / R  order and try the switch it goes OFF/L/Both and no start  ???  How do I fix this ?

How are you assigning these actions? You need to describe what you've done. Using controls, keystrokes, or what? Is it a multiway switch showing button presses for each position? Show us your FSUIPC6.INI file.

Note that the 'Start' position is spring-loaded to return to 'Both', so that one has to be repeated until the engine starts.

 

 

Link to comment
Share on other sites

Hi Pete,

Thanks for the quick reply.

I use Leo Bodnar boards, BBI 32 & BU0836X. I assign the switch actions using FSUIPC / buttons/switches section and using the preset items listed there. The two switches are 12 position switches but blocked to use only 5 positions. As stated above I have allocated each position on the switch using the preset items found under buttons/switches in FSUIPC. I would like to have a separate switch for each engine of the Baron. With engines running and the switch for say No 1 engine on BOTH, if I rotate it anti clockwise it will go direct to R mag and the engine rpm will reflect this action. If I then rotate another click to the left the engine will stop, so out of 5 positions on the switch, 3 work (OFF/R/Both) the others do not seem to be recognized at all, i.e the Mag L position is just bypassed and the Start position does not happen  meaning that on the aircraft MIP the mag control lever does not advance past the BOTH position. I hope I have explained the problem clearly. Attached is the FSUIPC.ini file.

FSUIPC6.ini

Link to comment
Share on other sites

9 hours ago, rodder47 said:

I use Leo Bodnar boards, BBI 32 & BU0836X. I assign the switch actions using FSUIPC / buttons/switches section and using the preset items listed there. The two switches are 12 position switches but blocked to use only 5 positions. As stated above I have allocated each position on the switch using the preset items found under buttons/switches in FSUIPC.

I see these settings:

121=P5,13,C65929,0     -{MAGNETO1_LEFT}-
123=P5,14,C65928,0     -{MAGNETO1_RIGHT}-
122=P5,15,C65927,0     -{MAGNETO1_OFF}-
124=P5,12,C65930,0     -{MAGNETO1_BOTH}-
176=P5,11,C65931,0     -{MAGNETO1_START}-

83=P5,30,C65933,0     -{MAGNETO2_OFF}-
133=P5,28,C65935,0     -{MAGNETO2_LEFT}-
135=P5,27,C65936,0     -{MAGNETO2_BOTH}-
136=P5,29,C65934,0     -{MAGNETO2_RIGHT}-
174=P5,26,C65937,0     -{MAGNETO2_START}-

Which seem okay, though I think you need the "Start" action with "Repeat while held" selected. That position is sprung to return to "Both" when released.

You need to check that the correct controls are sent when you operate the switches. Enable button logging in FSUIPC the operate the Magneto switches from OFF to Start and check that the correct control is being sent. That's all FSUIPC can do. You can see the log entries in real time if you select the Console window on the logging tab.

Note that on the light aircraft I use, the order of the positions is Off, Right, Left, Both, Start -- i.e left /right the other way around. Which aircraft have you been testing with?

Pete

 

 

Link to comment
Share on other sites

Hi Pete,

I am using the Beechcraft Baron 58 by Carenado. the mag switches on this a/c are OFF/R/L/Both/Start same as the one you use.  It seems strange. The Saitek Switch panel  works fine and in the correct order, but unfortunately only for multi engines, not individual..

 

Rod

Link to comment
Share on other sites

31 minutes ago, rodder47 said:

I am using the Beechcraft Baron 58 by Carenado. the mag switches on this a/c are OFF/R/L/Both/Start same as the one you use.  It seems strange

Test your switches with a default aircraft. It may be that Carenado don't obey the same standard controls. Maybe they need L:Var control.

Did you check your switch programming using the Logging as I suggested?

Quote

The Saitek Switch panel  works fine and in the correct order, but unfortunately only for multi engines, not individual..

Is that programmed through FSUIPC too? But whether it is or not, see what is sent, again, using the FSUIPC logging.

Not sure how it can stop Engine 1 controls operating on a single engine, which is engine 1 too.

Pete

 

 

Link to comment
Share on other sites

I tried using the A2A cessna but it did not work at all moving the start switch, however I could hear each click as it passed over the different segments and the engine started !!.

 

I also tried having the switches logged and then displayed in the console window but nothing appeared either from the original logging or using the switches with the console window open !!! 

 

Never mind I will just stay with the Saitek switch panel 😞

 

Link to comment
Share on other sites

2 hours ago, rodder47 said:

I also tried having the switches logged and then displayed in the console window but nothing appeared either from the original logging or using the switches with the console window open !!! 

If you managed to assign your switches, as shown in the INI you provided, then with the correct options set in the Logging tab, they simply must be logged! Please show me such a log. Enable Button logging and event logging (not axis events).

2 hours ago, rodder47 said:

I tried using the A2A cessna but it did not work at all moving the start switch, however I could hear each click as it passed over the different segments and the engine started !!.

Strange. But why are you not testing on a default aircraft first? Different add-on developers do things differently. Maybe the A2A one needs L:Vars changed to operate the visual switch.

Many of my switches are connected via Bodnar BU0836 boards. They are very reliable and versatile and I've never had any problems with any of them.

Pete

 

Link to comment
Share on other sites

Hi Pete,

 

I got a readout of the FSUIPC console Log and it shows every item as being turned on including the two Bodnar boards. I loaded up the AC11 Comander aircraft, even though it is a single engine it was the only one I could remember as being a default a/c. Anyway as I tested the mag switches the console recorded every movement from OFF/R/L/Both/Start  and return for both switches. BUT on the aircraft the switch only showed R/L/Both... NO Off or Start.

As for the Bodnar boards and FSUIPC this is the first time I have ever struck a problem. A mate of mine using the same bodnar board and the same type of switches with the Carenado Baron has the same problem as I have with the switches being correctly recognised.  Never mind it is not a big deal and one we can live with

Link to comment
Share on other sites

2 hours ago, rodder47 said:

Anyway as I tested the mag switches the console recorded every movement from OFF/R/L/Both/Start  and return for both switches. BUT on the aircraft the switch only showed R/L/Both... NO Off or Start.

That's weird if the correct controls are being sent!  

One other thing you can try, with the logging options still set, is operating the switch with the mouse and see what is logged then. Most standard cockpit controls use the controls too.

There is another way to set the magneto switch position -- use MAGNETO1_SET and MAGNETO2_SET with parameters 0 - 4 for the successive positions. Maybe those settings would work more consistently?

Pete

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.