Jump to content
The simFlight Network Forums

Registro não funciona


Recommended Posts

Have you called BMTmicro?

Have you confirmed you are using the activation code and not the order confirmation number? Check your email spam folder.

Have you tried copying the activation code, [CTRL] [C], then opened the installer and the code should automatically populate the fields?

Link to comment
Share on other sites

20 hours ago, Cleorides said:

still doesn't work

Have you contacted BMTmicro? cservice@bmtmicro.com (share your order number and purchase date BUT don't email a credit card number!) or call 800-414-4268 (USA/ Canada) / +1 910- 792-9100 (international customers).

If BMTmicro doesn't respond with 24 hours contact feelThere using the support form on Zendesk - feelthere.zendesk.com

Link to comment
Share on other sites

Yes I contacted BMTmicro and they sent the same key. Does not work. They sent me back to you. This has been dragging on since Monday. If there is no quick fix, I will cancel the order.

I've been a FeelThere customer for a long time, with WIlco Airbus. I never had that kind of problem.

Edited by Cleorides
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.