Jump to content

Download link for FSUIPC7 v7.2.10 doesn't work from http://www.fsuipc.com/


Recommended Posts

*** Moved from Download Links sub-forum to main support forum ***

Hey there, could you help find out why I get 'failed - network error' when trying to download from this link FSUIPC7 v7.2.10 found on http://www.fsuipc.com/.

I've also tried right clicking and 'save as', same error.

I'm needing this program to get https://www.remoteflight.net/support working.

Thank you!

Edited by John Dowson
Moved to main support forum
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.