Jump to content
The simFlight Network Forums

Download link for FSUIPC7 v7.2.10 doesn't work from http://www.fsuipc.com/

Recommended Posts

*** Moved from Download Links sub-forum to main support forum ***

Hey there, could you help find out why I get 'failed - network error' when trying to download from this link FSUIPC7 v7.2.10 found on http://www.fsuipc.com/.

I've also tried right clicking and 'save as', same error.

I'm needing this program to get https://www.remoteflight.net/support working.

Thank you!

Edited by John Dowson
Moved to main support forum
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.