Jump to content
The simFlight Network Forums

Render video in P3D throwing exception

Recommended Posts

Hi Fabio

In addition to my post here https://forum.simflight.com/topic/91873-update-v45-microsoft-flight-simulator-flightcontrolreplay-v45-for-microsoft-flight-simulator-june-update-21-discussion/?do=findComment&comment=570215

I recorded a flight with the enhanced P3D version, which plays back in P3D perfectly. However, if I try to record (render) a video of the flight during replay an exception is thrown just after I name the file to save. I've attached a screenshot for info. I tried several times, same result. (FCR is run with admin privileges)

Any suggestions? Or am I doing something wrong?


Dave Nash

Edit - P3D version is

FCR exception thrown.JPG

Link to comment
Share on other sites

  • 5 months later...

Hi All,

I have the same issue in MSFS. Can't record any render. I have the same message as Dave and if I click ok I have an empty MP4 file in the target folder. 

If you can give us a hint to resolve this issue that would be awesome.

Thanks a lot for your work.


Link to comment
Share on other sites

same problem here for p3dv5.3 hf2. I get the same error.

I have the FCR for a while now and not a single time have I managed to render a video out of my sim. Let alone rendering a video, I can not even get it to work for recording!! I download the FCR and then install it as told by the manual. Then for couple of flights I manage to get some recordings and that`s it. After that it doesn`t record anything at all!! 

I believe I have the necessary software that are listed in the manual. and yes I "BELIEVE" because as a computer noob I can never be 100% sure whether I have the correct software with that rather vague explanation for the downloads. For some it may be crystal clear but not for me.

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...

Hey Fabio. Yes the codec is installed. And yet the error is still there when it comes to rendering in p3dv5.3 hf2.

Could you please tell us whether we are doing something wrong or this is just what this is... I mean If you can acknowledge this error and that it exists, you would spare me from wasting my time even further. I`ve been trying to fix this issue for a very long while now... and no success yet.. it`s very frustrating..

Thx anyways...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.