Jump to content
The simFlight Network Forums

Pete!! Only you can help

Recommended Posts


After 2 years or mastering mobiflight and fsuipc and wideFS across fs9 fsx and p3d and helping countless people fix their configs i am now baffled with what is happening to me

Here is the setup:

PC1 runs p3d and has 2 arduino leonardo boards for yoke, yoke buttons, pedals and throttle levers.
One leonardo is purely for yoke and yoke buttons.
Second leonardo is mostly for analog axis but has few buttons connected also.

PC2 runs wideClient and mobiflight and has 4 arduino megas connected to it

For a long time everything was working perfectly. Lately i have done some modifications to the cockpit moving some hardware in and out and worked on some sceneries so i didnt really fly or use any systems, i only loaded flight and slewed around to see the scenery i made. I also rerouted some wires and changed their names in configs and adjusted corresponding actions etc to the new names. Also during those days there were several mobi updates.
So many things happened that i cannot really point out the point in time where things stopped working

Now here is the issue:

Trying to make a flight through nightlights i just made i switched off slew mode and started flying over the city. I flipped my flaps toggle and nothing. I toggled my light switches and nothing.
When i got annoyed i started lookin around and found that everything happens on my physical panel like it should. My announciators for landing lights led comes on. My avionics switch makes my radio and nav displays go on and off. But none of that is happening on the panel in the sim. 
All the yoke buttons via leonardo that are assigned to pan view and reset view are actually panning the camera.
The buttons that are set to trigger fsuipc offsets are not having any effect on the sim. In fsuipc menu i can howe see all of them registering when i press them and all their assignments are correctly setup.
Every input from mega via mobiflight that is directed through fsuipc offsets or events is not working in the sim.
I have few mobiflight switches sending to the fake joystick offset bits. When i toggle that mega mobi switch with fsuipc window open, i can see the switch registered as joystick button and assigned correctly, but again no action happens in the sim.
I’ve tried many planes at this point that worked perfectly.
So whether the input is from mega on PC2 via widefs or on PC1 via leonardo, they are not being executed in sim.

Widefs and wideclient are connected.
Fsuipc outputs are showing on my mobi on PC2. I can see dme distance on my 7segs and frequencies and everything.
I cannot change any of it unless i click them in vc.
Every encoder and switch and button is reflecting the action in my cockpit, panel lights come on, announciators for lights all work, every action is showing on mobi debug perfectly how it should be. Mega flashes every time. Every input is registered. But no input makes it into the sim.

I have even unplugged all megas from PC2 and shoved them into PC1 to eliminate widefs and network and firewall and copied the configs and mobiflight happily runs but same issue persists.

It’s not hardware because that is all passing in mobi debug.
It not network or second pc or widefs cause I have eliminated those now.
I have wiped fsuipc and reinstalled it again and same issue persists
I have used mobi 7 and 8 versions and same issue persists 

The weird thing is that battery master switch works fine. On PC2 and now on PC1 also. That toggle is on mega via mobi to write into fsuipc offset. That works. That is the only one that works to input some action into sim.

And another weird thing is that avionics bus volts used to show power there same as master battery bus volts, but now avionics show zero fsuipc output even if i switch it on in sim with mouse.
That used to work because my conditions were based on certain amount of voltage in the bus that controlled whether my avionics displays were on or not.
But now i cant get it to show anything.
I is the only output value that no longer works for me. 
Everything else for dme and adf and nav and com and AP are reading correctly, but cannot be adjusted by any of my encoders.
Debug shows the encoder actions correctly yet no input in the sim.

Im really stumped here.

It like p3d and fsuipc are no longer communicating together but fsuipc shows up in addons and i can access it.
Also all analog axis are working fine via fsuipc. I can fly and adjust power and steer and brake. I can operate master battery switch.... But that is all 🤕

Has anyone ever seen or heard of anything like this ?

I must arrive to conclusion that somewhere there is a disconnect between fsuipc and the actual sim aircraft.

is fsuipc going directly into p3d or is it using simconnect?

simconnect is the only thing i havent tried lookin at

sim is p3d4.5

i have also created a new config in mobi with only one button to move flaps and that didnt work either to get through to operate them

Link to comment
Share on other sites

First, Pete has now retired (although he does monitor the forums and will occasionally help out), and I am now providing support (and development) if FSUIPC and WideFS.

10 hours ago, Djnigelcage said:

is fsuipc going directly into p3d or is it using simconnect?

FSUIPC uses SimConnect for most interactions with P3D, although not all (e.g. access to lvars is done using the panels.dll functions).

Could you please provide me with your FSUIPC ini file so that I can take a look at your settings. Also, I need to see your FSUIPC log file that shows one of your issues, i.e. a programmed button not working. To do this, activate FSUIPC logging for Buttons & key presses as well as Events, and generate a short log file where you load your aircraft and activate a button or switch that is assigned in FSUIPC (and not working), then exit P3D and show me the log file and I will take a look.


Link to comment
Share on other sites



thank you for the hope your reply has brought me 😄

i dont feel alone anymore 😄

i will forward those when i can get up there to it

if fsuipc communicates with simconnect to input and output also then it must be talkin because the data is received and displayed.

also the master battery works... it is on the same mega as many more... it is on the same gnd as many more... it is configured in mobi sama as many more.... it is the only switch that functions.... i am pretty smart at eliminating stuff whether it's electronics or car issues.... all of this was working perfectly how it was for months and months... it really baffles me and that doesnt happen to me very often 😄 every time something didnt work a little logical thinking discovered errors in wiring or mega settings or mobi settings.... this time everything is happy... yet nothing works


also the total loss of any avionics bus volt and amp readings that previously worked

i didnt want the displays to remain on even when battery is dead, just because the avionics switch is on despite no power to it, so i used the voltage offset in the avionics bus to control the preconditions .... that now wont work so i have switched to the "av switch" offset to go off the switch i have. offset changes tfrom 0 to 1 in my output on mobi but not in the sim...


really melting brain here

Link to comment
Share on other sites

OMG i am an absolute moron 😄


i just fixed it


last week i was sitting and waiting for resample to run few photoreal sceneries so i spent the time going through installed software and uninstalled everything i only tested and forgot to remove and stuff i no longer use etc to make image smalled so i can run backup since everything is working lovely

I remember coming across simconnect entry and at that moment i somehow thought that those were older versions i had there from fspassengers days when i was still on fsx.


so i uninstalled it cause i assumed p3d has it's own simconnect within itself


after that i carried on with many other things for days before i decided to actually use the cockpit for flying


and i had a thought last night that it could be that so i went to download fsx accel simconnect from fspassengers site and installed it and at 3:30am still loaded the sim and same issue so i went to sleep.

turn out the windows needed a restart for the simconnect to kick in, which it never asked for!!


OMG. i havent felt this demented in a loooooong time.... but i knew it had to be between fsuipc and the sim and so it was


only one question now...my fsuipc log now shows all my physical inputs again, BUT not the mastery battery switch.

remember i said battery was the only thing that worked in the sim? well it still works now but there is no entry in the log, i toggle the switch and the switch in sim toggles also, but fsuipc doesnt log that. it logs everything else. if iclick it with mouse it does log.


is there something particularly different about the function of the master battery offset?


everything is normal now as far as functionality. just the missing log for battery is strange


Link to comment
Share on other sites

9 minutes ago, Djnigelcage said:

is there something particularly different about the function of the master battery offset?

Writing to offsets can update the relevant simvar directly if the simvar is writeable, and use events otherwise. This is documented in the FSUIPC Offset document as Ok-SimC when updating a simvar directly, and Ok-SimE when using events (with ?-SimC and ?-SimE being used when status unknown or different for different aircraft). The master battery offset is Ok-SimC and so will update the ELECTRICAL MASTER BATTERY simvar (offset 0x281C) directly and no event will be seen.


P.S. Glad you solved your issue!

Edited by John Dowson
PS added
Link to comment
Share on other sites

Oh i just noticed the name on your post now


i swear my brain was reading Paul a good few times


now i see its John


do i take it that you are the second generation fsuipc master and took up the torch to carry on?


if so, then much respect to you, sir


your family name in the sim world is like jesus in the religious world 😀


many thanks to you and your father (if he indeed is)

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.