Jump to content
The simFlight Network Forums

Cant get an Lvar working in the SWS Kodiak


JumboAg

Recommended Posts

Waiving a white flag and asking for help.  It's probably something stupid I'm overlooking but for the life of me I cannot get a LVAR mapped to my honeycomb.  I've read through the manuals and looked at several posts.  Maybe someone can tell me what I'm overlooking.  Hopefully if I can map one switch, I can reverse engineer and replicate from there.


Trying to map the AUX_BUS switch in the SWS Kodiak to a on/off switch on my honeycomb alpha. Here's what I've done so far:

1) Verified the LVAR I need is XMLVAR_AUX_Bus_ON from hubhop.mobiflight. Listed LVARs with Add-Ons -> List WASM -> List Lvars.  It does show up and has possible values of 0 and 1 (verified by clicking in MSFS on it and refreshing the Lvars list to see it change.

2) I'm using Profiles, so in my kodiak.ini file, I added it as my first LvarOffset as an unsigned bit at what I understand to be the first available free address

[LvarOffsets]
1=L:XMLVAR_AUX_Bus_ON=UB0xA000

3) In FSUIPC7, under assignments -> Buttons & switches, I've checked the profile box, verified it matches the right one and clicked the button on my alpha (it registed as C 18 for what its worth. Hit the checkbox for Select for FS Control

4) Choose Offset Byte Togglebits, offset of xA000 and parameter x01

5) Clicked OK

6) Re-opened button assignments window, chose reload all buttons just in case

7) Double checked the Ini file.  It did add the button entry (Entire file contents below): 

[Profile]
Created=03/02/2022 16:20:49

[LvarOffsets]
1=L:XMLVAR_AUX_Bus_ON=UB0xA000
[Buttons]
0=PC,18,Cx0D00A000,x01     -{offset byte togglebits, offset A000}-

😎 Tried to use the button.  Nothing happens

- What on earth am I forgetting to do?   


 

Link to comment
Share on other sites

Sounds like you are doing everything correctly....
Could you please do the following:
    - activate debug logging in the WAPI. To do this, add the following line to your FSUIPC7.ini file under the [WAPI] section:
         LogLevel=Debug
    - activate logging for Buttons and Keys in FSUIPC7 (Log -> Buttons & Keys)
    - produce a short log file where you load your aircraft and then press the button you have assigned 
    - exit FSUIPC7, and then show me/attach your FSUIPC7.log file and your FSUIPC7.ini file

Thanks,

John

Link to comment
Share on other sites

Thanks John.  In the process of attempting to collect the above,  I found that the button I originally mapped is now working.   I then tried with my next button and it did the same the first originally did (not working) until I exited FSUIPC and restarted it (Did not restart the sim).

Maybe I just misunderstood restart requirements?  I didn't think per a previous thread that I needed to restart FSUIPC after mapping a button to a newly created LVAR line.   The only file I was editing was the <profile>.ini file by adding in the new LVAR line and then doing a WASM reload before assigning the button. 

Link to comment
Share on other sites

Two things may apply:

1. When you manually change the ini, you need to either restart FSUIPC for these to take affect, or, usually if it is an assignment you are changing, you can reload the assignments from the UI assignment panels (see the reload assignments button in each panel).

2. Sometimes lvars are not available on the initial scan for lvars. You can force a rescan/reload of lvars using the Add-ons->WASM->Reload menu option.
For complicated aircraft, it can take up to a minute after the aircraft has loaded for some lvars to be available. There is a parameter that you can set in the WASM ini file (FSUIPC_WASM.ini) called LvarScanDelay. This is, by default, set to 5 seconds. I use a value of 45seconds, but some folks have this even higher. The correct value depends upon your system and the aircraft you are using. If you find that the lvars are not initially available, try a reload to see if they then become available, and if they do, try increasing this scan delay parameter.

John

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.