Jump to content
The simFlight Network Forums

Need help getting Lvar offset working


hikariken
 Share

Recommended Posts

I have been trying to set up some Lvar offset today and I used different forums to try and set up some controls on the B247D through Lvars.

The issue is while I can get the controls to move by using the "set Lvar" option in the FSUIPC mene the Lvars aren't changing when I move the controller axis.

I have checked the axis binding and as far as I can see the relevant one are set as they should be.

So as I don't see where I did something wrong I'd like to ask you to check out my FSUIPC.ini and if you can tell me what is wrong with it so I can make it work.

 

thanks

FSUIPC7.ini

Link to comment
Share on other sites

You should always check your FSUIPC7.log file when adding lvars to offsets as these will most probably tell you what the issue is, and you should also always attach that when requesting support on these issues. Looking at your ini:

Quote

[LvarOffsets.Boeing]
0=L:ENG THROTTLE 1=UB0xA000
1=L:ENG THROTTLE 2=UB0xA001
2=L:ENG MIXTURE 1=UB0xA002
3=L:ENG MIXTURE 2=UB0xA003
4=L:ENG PROPELLER 1=UB0xA004
5=L:ENG PROPELLER 2=UB0xA005
6=L:LEVER OIL SHUTTER 1=UB0xA006
7=L:LEVER OIL SHUTTER 2=UB0xA007
8=L:LEVER CARBURETOR HEAT 1=UB0xA008
9=L:LEVER CARBURETOR HEAT 2=UB0xA008

Several things stand out:

1. you have no profile called 'Boeing'. You have two profiles - '247' and '737'. If you are setting this up for the B247D, it should be:
    [LvarOffsets.247]
i.e. it needs to match the name of the profile that you want to use this with.

2. Your lvar names contain spaces...are you sure this is correct? I suspect they should be
    L:ENG_THROTTLE_1
    L:ENG_THROTTLE_2
i.e. use underscores rather than spaces.

3. You are assigning all those lvars as single unsigned bytes, so that they can only hold an integer number between 0 and 255. Are you sure this is correct? Check what values the lvars you are using hold, and assign them the correct type. Also make sure that the offset size is correct, i.e. if you change the type to a larger size, make sure that the next lvar is not overwriting the offset area  from the preceding one.

John

Link to comment
Share on other sites

Thanks for the help, the .247 instead of boeing did the trick. can't belive i didn't see this after a day of looking at the file

The lvar for the 247 have spaces not underscore and I did find how to transfer the axis value to a value between 0 and 100 so integer is fine.

Edited by hikariken
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.