Jump to content
The simFlight Network Forums

Vatsim text cursor impedes Keysend


Recommended Posts

Hi, I have vpilot on a client pc as remote voice, the host is on my server where I have p3dv5 and FSUIPC6.  I have a few keysends coming from the server to the client (via FSUIPC/wideclient), for example to change voice output from headphones to speakers on the client.  If I press SPKR button in the sim (connected to server), it sends a keysend to the client, for example CTRL+T, to change from headphones to speakers.   

I discovered that this stops working with vpilot, because vpilot always has a flashing cursor ready for text input.  Only if you clear your whole desktop and then click outside of vpilot, then the keysend will work.

So what I do is, before pressing a button that activates a keysend, on the client I press the "Up-arrow" to the right of the taskbar (see the pic below), then I press the SPKR button in the sim, this then works.  But it is clumsy and not very realistic, so I'm sure there must be something in the wonderful FSUIPC that can circumvent this problem, some kind of macro for example that could do the same thing before sending the keysend

(I asked vpilot if the keyboard takeover by vpilot could be deactivated for those of us who do not use text input for ATC, but that was denied)

Rgds

Charles

image.png.4783dc6d838a7e091a499a03652e0e75.png

image.png

Link to comment
Share on other sites

Why is vPilot always waiting for text input? That seems strange...
Have you tried  explicitly bringing the vPilot window to the foreground using the Focus command (see the WideFS technical guide)? If not, maybe try that...

John

Link to comment
Share on other sites

Quote

Why is vPilot always waiting for text input? That seems strange..

Yes, if you click on vpilot it always has the cursor flashing waiting for text input

Quote

Have you tried  explicitly bringing the vPilot window to the foreground using the Focus command (see the WideFS technical guide)?

Perfect, Pete, as always thx, now that works.  The only slightly annoying thing still is if I press the keysend while the cursor is flashing within vpilot, there is an annoying windows "ding" initially, but it does work.  If I click outside vpilot (so that the cursor is not flashing) and then press the keysend, there is no ding.  I can live with this if there is no workaround

Here are my 2 keysends:-

Quote

KeySend3=84,10,Focus,Run1
KeySend4=66,10,Focus,Run1
Run1=C:\Program Files (x86)\VB\Voicemeeter\VoicemeeterMacroButtons.exe

 

Link to comment
Share on other sites

11 minutes ago, chasbruce said:

Perfect, Pete, as always thx, now that works. 

its John - Pete retired a few years ago...

21 minutes ago, chasbruce said:

The only slightly annoying thing still is if I press the keysend while the cursor is flashing within vpilot, there is an annoying windows "ding" initially, but it does work.  If I click outside vpilot (so that the cursor is not flashing) and then press the keysend, there is no ding.  I can live with this if there is no workaround

I'm not sure...I was going to suggest giving the focus to a different window other than vPilot (if it is being used as a hot-key), but that seems to be what you are doing...
You could try with using the Alt modifier rather than Ctrl...Alt modifiers have a special meaning (usually keyboard shortcuts for windows' menus and menu items) and may bypass the "ding"... otherwise, you could try disabling the beep  in windows - see https://bznep.ourproperty.co.uk/articles/disable-sticky-keys-warning-beep-in-windows-10/

John

Link to comment
Share on other sites

Sorry, John, I didn't realise that, your support is equally excellent, please pass on my best regards, Pete has helped me since 2009 for which I am extremely grateful.

Quote

You could try with using the Alt modifier rather than Ctrl...Alt modifiers have a special meaning (usually keyboard shortcuts for windows' menus and menu items) and may bypass the "ding"... otherwise, you could try disabling the beep  in windows - see https://bznep.ourproperty.co.uk/articles/disable-sticky-keys-warning-beep-in-windows-10/

I did the changes in the link you sent re sticky keys, but that has not got rid of it.  I think it's because vpilot, in having its cursor flashing, is awaiting a key input and, as it does not recognize CTRL+T as an acceptable thing to type, the ding occurs

Re the ALT key, I tried just typing ALT+T and, for sure, no beep, but what about the following in the manual?

Quote

Use of the Alt key in many combinations is problematic. Try to avoid this key if possible.

 

Link to comment
Share on other sites

11 hours ago, chasbruce said:

Re the ALT key, I tried just typing ALT+T and, for sure, no beep, but what about the following in the manual?

Quote

Use of the Alt key in many combinations is problematic. Try to avoid this key if possible.

As long as the alt key combination isn't already being used by the application as a menu short-cut, then you should be fine using the alt key as a modifier. It is the windows / win key that is problematic these days and shouldn't be used. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.