Jump to content
The simFlight Network Forums

FSUIPC Throttle Issue


Recommended Posts


I have not flown FS in a couple years but I'm getting back into it.  When I did fly before I never had an issue, but this time I do.

I'm using FS-SE, Eaglesoft C750 2.0, Saitek X52 and FSUIPC4, same exact configuration I used before with no issues.

I've reinstalled everything, but now when my throttle is pulled back to idle, in the sim it's stuck at just under 50%.  Before I installed FSUIPC4 it worked fine.  I've tried calibrating my throttle in the settings but it does not fix this issue.

There is obviously something I'm missing.  Can anyone help?


Link to comment
Share on other sites

First, you posted in the sub-forum for FSUIPC7 / MSFS2020. As you are using FSUIPC4 and FSX-SE, I have moved your post to the main support forum.

Which throttle axis are you using? Did you try other throttle axes? If not, please do. And are you calibrating with a reverse zone or not?

I am not familiar with the Eaglesoft C750 2.0, but maybe check the configuration for that aircraft, as some Eaglesoft aircraft require to be configured, e.g. see this for the Eaglesoft Citation: https://www.avsim.com/forums/topic/377514-eaglesoft-citation-x-problem-with-idle-and-throttle/

Otherwise, please show me your FSUIPC4.ini and FSUIPC4.log files, the latter with axes logging enabled and move the throttle through its full range and exit.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.