Jump to content
The simFlight Network Forums

SU 11 - Built in offsets don't work anymore


activex

Recommended Posts

All,

I have installed FSUIPC 7.3.1.1 (using non-registered version) and I am running SU11 (Canada changes). I am using FSUIPCClientDLL 3.2.21 (latest).

I selected/loaded Cessna Citation CJ4. 

The following lines of code tried to read current thurst input 1 value for the cessna aircraft. Instead of reading the value, it returns always zero.

FSUIPCConnection.Open();

				var thrustInput1Offset = new Offset<short>(0x089A);
				FSUIPCConnection.Process();
				var thrustInput1 = thrustInput1Offset.GetValue(Type.GetType("System.Int16"));
				Console.WriteLine($"thrust input 1={thrustInput1}");

FYI, this offset worked before, now it stopped working.

I did quick dirty test on offset "0x3AE8" (General engine 1 throttle lever position) and this one works.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.