Jump to content
The simFlight Network Forums

Strange interactions of FSUIPC with Bush Trips using Garmin G1000nxi gauge when using Autosave


Recommended Posts


First I have to thank for receiving the 1 Year Member Batch! I'm only wondering as I registered my first FSUIPC in Nov. 2003 and did it since then when a new version required it (well I used FSX till I decided switching to MSFS 2020) !  :-o

Now the observations:

It took a while before nailing the source (that also might be on ASOBO's or on "Working Titles side). However, when trying Bush Trips using e.g. the default Cessna C172 with WT G1000nxi I got in trouble now for several weeks until I took the time tracking it down. I never happened before with the simple G1000.

What happened: After the plane is prepared to start for any leg, after a few minutes the VFR map and the MFD screen begins to show strange routing (like a spider on LSD or so - please see the attached sceenshots). When opening the flight plan it is possible to watch randomly changing active legs. The same time the frame rates are dropping rapidly nearly down to 1.6 to 2.4 fps and sometimes the only possibility to get out was to kill MSFS.

All normal flights are working as expected, except probably PMDG's B737-700, that is on hold while FSUIPC is saving and that takes about 2 to 3 seconds (hey, it's a fast SSD!). Well the latter is an other story.

The attached pics are taken while testing a flight by using the AP, however hand flying doesn't make any difference. When switching the Avionic Bus 2 OFF before the trouble begins, it might work - I'm not really sure at the moment.

What I did:

  • I checked for any Windows 10 Pro events and there was nothing (well, it worked with ~2 fps)
  • I started MSFS in Save Mode (after killing the process before) - no avail
  • I made a reset for all MSFS settings - no avail.
  • I reinstalled all "main files", that took hours (even with a fast connection) - no avail
  • I disabled everything that might have to do with configuration - and thought success (for about a week)

All "check flights" now worked without problems (e.g. the Sicily tour), till today.

Two day ago I crashed a plane (FBW's A320 Experimental) after a long online flight in heavy weather (I forgot the wheels), wanted to set up a saved flight and there was none. I tried to check FSUIPC via hot key and there was no reaction. Actually, I thought I saw the logo during booting the sim. So I reinstalled the actual FSUPC and everything looked okay at the first glance. Today I decided to continue a Bush Trip (the Balkan one) and while standing still on ground the old trouble started again.

  • As FSUIPC reinstalling was the very last and single action I pressed [ALT]+[F] and checked the settings. It was set to save each 6 Minutes as it should an nothing looked unusual. Even the saved files of previous "normal" flights where there.
  • My next attempt ended like the previous one, first the the visual evidence, then stutters an dropping frame rates.
  • I pressed [ESC], called FSUIPC, and disabled all Autosave settings.
  • EDIT: Back to the flight: It recovered and worked well for the next few hours after returning from the Main Menu.
  • Today, almost a day later, I flew without problems. While on ground I switched on FSUIPC's "Autosave", waited some minutes and the mess started again.

BTW, all other Bush trips with planes equipped with Garmin's other devices (inclusive Working Title's Mods) are working without problems.

My conclusion: It is likely a clash between my registered FSUIPC 7 and WT's Garmin G1000nxi (now default) - probably it might be as well their interface.

2022-12-19 05_48,05_AB.jpg

2022-12-19 05_48,22_AB.jpg

Edited by FlyingAxx
Adding an other test the next day.
Link to comment
Share on other sites

On 12/26/2022 at 12:25 AM, FlyingAxx said:

First I have to thank for receiving the 1 Year Member Batch!

What is this? There is no such thing for FSUIPC - it is either licensed/registered or not, and I support both versions.

I can't see how FSUIPC's auto-save facility can be involved in this issue, as all it does is call the SimConnect SDK function SimConnect_FlightSave at the defined interval.
However, there are still issues with this function - it does seem to work sometimes, but also many issues have been reported, and this function is still documented as:
    NOTE: The current status of this function is NO ERROR, NO RESPONSE.
i.e. it is still not working correctly.

Therefore any issues with the saving of flights need to be fixed by Asobo. If it is causing issues for you, then disable this for the time being.


Link to comment
Share on other sites

Hi John,

Thanks for responding so quickly.

Actually, I lived with this phenomena for quite while and never had the idea that FSUIPC could be the cause (it's still the case). I'm running MSFS now for roughly one year and never had the feeling that the sim could be close leaving the early Beta-phase. I only wanted you guys to know that there is something going wrong while using your product - and I was hoping that you might have an idea where to look at. I never saw you as causing party, but rather as knowledge carrier regarding bugs and limitations of the involved interfaces.

Fact is, that everything runs smoothly having Autosave disabled. All right, you say that Asobo's FlightSave could be the reason. It must be a very special bug nonetheless, as there is one single combination needed. That is:

  • The flight is a Bush Trip
  • AND the a/c uses WorkingTitle's Garmin1000NXI (now default for quite some planes)
  • AND FSUIPC's Autosave is activated

Flying a WT Garmin1000NXI equipped plane in a "normal" environment (no Bush Trip) doesn't cause any trouble with Autosave. The same is true with any other gauges on board, even on a Bush Trip.

So I think I have to wait until Asobo (or who ever) fixes it.


Link to comment
Share on other sites

  • 4 weeks later...

This can happen when a flight is being saved, especially if using a complex aircraft. You can check that your flight-save folder isn't being scanned by any anti-virus software, but other than that there is not much that can be done. FSUIPC just uses the SDK provided API, and it is MSFS that actually saves the flight.


Link to comment
Share on other sites

13 hours ago, Jose Antonio said:
Helo FlyingAxx,
I use an application that, among other things, calls autosave. When this happens, MSFS hangs every few seconds. If I disable autosave, everything works fine again.

Hi Antonio,

Your observation is correct, PMDG's 737 seems to be the the best example for me. I never had this phenomena in FSX.  I think that the amount of data cannot be the reason, specifically as all previous versions where using just one CPU kernel. - Opps, John already said the same.

Actually, the case I described could have to do with conflicting autosave functions used by ASOBO. Bush Trips obviously are using something similar at each reached way point, even if you might get in trouble as they are obviously using some kind of standard positioning instead of your real flight situation at a certain time.

Unfortunately Autosave is actually the only function of FSUIPC that seems to be useful for me as there are obviously too many SDK gaps. I'm thinking about smoothing between different weather areas and jumping air pressure and wind directions.

Link to comment
Share on other sites

25 minutes ago, John Dowson said:

Note that FSUIPC also provides an additional control that allows you to turn auto-save on/off (when auto-save is activated). Some folks use this to turn auto-save off on take-off and/or approach to prevent these pauses during critical periods.


Well, I even experienced CTDs just after the first wheel touched the runway after a transatlantic flight. Because of the buggy sim this function served as a kind of safety leash for me. Now I'm using only the "save now" function.

BTW, would it be possible saving the flight plans for other planes as well? PMDG uses obviously an own procedure (probably almost the same as in FSX). I'm missing this, specifically for FBW's A320 and some other birds.

Link to comment
Share on other sites

12 minutes ago, FlyingAxx said:

BTW, would it be possible saving the flight plans for other planes as well? PMDG uses obviously an own procedure (probably almost the same as in FSX). I'm missing this, specifically for FBW's A320 and some other birds.

The SDK doesn't provide any facilities to save flight plans unfortunately, only to load them. It would be up to the aircraft to save this information - I guess that is what PMDG does. You should probably ask FBW about this.

Note also that the FlightSave and FlightPlanLoad SDK functions are still documented as noy working (NOTE: The current status of this function is NO ERROR, NO RESPONSE.) so there may still be issues using those, and the only flight function currently documented as working is the FlightPlanLoad one.


Link to comment
Share on other sites

Hi John, I was afraid about that kind of answer. It's obviously an open Beta test we had payed for (I mean MSFS, to be clear) and missing SDK functions and interfaces are apparently nothing that will be voted too high in the hit list what to be fixed next. Probably they are using some kind of ChatGPD in order to sort their priorities.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.