Jump to content
The simFlight Network Forums

MSFS - PMDG and CRJ Issue w/Precision Flight Control Throttle Quadrant


N987PL

Recommended Posts

My Precision Flight Controls Throttle Quadrant works with all other airplanes in MSFS....BUT not the CRJ 500/700/900 or the PMDG 737.  I went to page 2 in the EFB for the CRJ as instructed on their forum, but the axis were not "seen" by the EFB utility.  In PMDG, throttle 1 axis worked fine, but not throttle 2.  There was some issue with the reverse lever on throttle 2 being very eratic in it's movement, and the throttle would not advance.  Anyone else have this issue with both airplanes?  Again, the Baron and Diamond DA62 work fine (both axis' are mapped in FSUIPC correctly) in MSFS and have worked fine since I installed MSFS 2 years ago, but both the CRJ and PMDG 737 are not working.

PFChid64.log PFCcom64.log FSUIPC7.ini FSUIPC7.log

Link to comment
Share on other sites

First, it looks like the GUIDs of your JAY Rudder and Redbird Alloy YK1 changed at some point, You re-assigned to these devices again when this happened. You don't need to do this - it is easier/quicker to update the [JoyNames] section to handle such changes. You don't have to do anything now, but remember this next time - or post your ini here and I can update for you. For now, I have cleaned your ini to remove these missing devices and the assignments to them - please use the attached ini: FSUIPC7.ini

For the CRJ, you need to assign with 'Send to FS as normal axis' and use the Throttle1 Axis Set Ex1 and Throttle2 Axis Set Ex1 controls/events. You should create a specific profile for this - i.e. in the axis assignment tab, check the Profile Specific checkbox, create a new profile (you can import current axes assignments into the profile), and then clear the throttle assignments and then assign to those controls. You should then go to the calibration tab, again check the Profile Specific checkbox, and then re-calibrate the throttles on page 3. Once that is done, you should be able to calibrate further in the EFB, if needed.

On 2/4/2023 at 4:58 PM, N987PL said:

In PMDG, throttle 1 axis worked fine, but not throttle 2.  There was some issue with the reverse lever on throttle 2 being very eratic in it's movement, and the throttle would not advance.  Anyone else have this issue with both airplanes?

I can't see how throttle1 and throttle2 can be different as the assignments and calibration are the same. However, I suggest you also create another profile for the 737, as many controls are also very different for this aircraft. If you have issues with the throttle then clear your current throttle assignments and assign again using 'Send to FS as normal axis' and use the Axis Throttle1 Set and Axis Throttle2 Set controls. Again, after assigning go to the calibration tab and check the Profile Specific checkbox and check the throttle calibration.

If you still have issues, please attach your updated FSUIPC7.ini file.

John

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.