Jump to content
The simFlight Network Forums

Auto-starting ActiveSky doesn't work


Recommended Posts

Hi, 

I have 3 of programs I want to start with FSUIPC, which works fine but for some reason, one program (ActiveSky) won't start (I only hear a warning "ding" when MSFS is up and running, indicating something's apparently not working, but no message is produced).
What could be the reason for this? 

My .ini entries;
[Programs]
RunIf1=READY,KILL,C:\MSFS_ADDONS\TRAFFIC\fsltl-traffic-injector\fsltl-trafficinjector.exe
RunIf2=READY,DELAY[=30],"C:\Program Files (x86)\FS2Crew Fenix A320 for MSFS\FS2Crew Fenix A320 for MSFS.exe"
RunIf3=READY,KILL,C:\MSFS_ADDONS\WEATHER\AS_FS\AS_FS.exe

1 and 2 start fine, 3 won't. None of the application are starting with admin rights.

Thanks for any ideas,
Stu

Link to comment
Share on other sites

Meanwhile I've figured out in the log* that it's an [Error 740], so although AS_FS.exe is not set to run with administrator rights, it still somehow is (indicated by the little shield) and is not accessible to start by FSUIPC... Might be something ActiveSky-specific, because I could not find out how to change that. 

* 322047 FSUIPC couldn't run: "C:\MSFS_ADDONS\WEATHER\AS_FS\AS_FS.exe" in folder "C:\MSFS_ADDONS\WEATHER\AS_FS" [Error=740]

 

1716125999305.png

Link to comment
Share on other sites

17 minutes ago, Stu Antonio said:

Meanwhile I've figured out in the log* that it's an [Error 740]

That is why I needed to see the log file!

22 minutes ago, Stu Antonio said:

although AS_FS.exe is not set to run with administrator rights, it still somehow is (indicated by the little shield) and is not accessible to start by FSUIPC... Might be something ActiveSky-specific, because I could not find out how to change that. 

I don't think you should change this even if possible - if it is running with elevated privileges then I', pretty sure its doing this for a reason...

Sorry but if AS is being ran with elevated privileges and FSUIPC not, then I don't think it will be possible to have AS auto-started by FSUIPC7.
I do have AS for MSFS so will take a look when I get time (after the SU15 release). You could maybe try adding an entry to the MSFS EXE.xml file instead to see if that can start AS.

Link to comment
Share on other sites

7 minutes ago, John Dowson said:

That is why I needed to see the log file!

I don't think you should change this even if possible - if it is running with elevated privileges then I', pretty sure its doing this for a reason...

Sorry but if AS is being ran with elevated privileges and FSUIPC not, then I don't think it will be possible to have AS auto-started by FSUIPC7.
I do have AS for MSFS so will take a look when I get time (after the SU15 release). You could maybe try adding an entry to the MSFS EXE.xml file instead to see if that can start AS.

Okay, thanks. That's what I thought too. 
Adding it to the exe.xml won't work either, same problem, I don not run MSFS with admin rights, so it won't be able to launch addons via the exe.xml that need elevated privileges, and afaik it's not recommenced to run MSFS with admin rights.

... maybe HiFi will add an auto-launch functionality in the future.
Thanks!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.