Jump to content
The simFlight Network Forums

tex1763

Members
  • Content Count

    9
  • Joined

  • Last visited

Community Reputation

0 Neutral

About tex1763

  • Rank
    Newbie
  1. Sorry for misleading description of the problem, but at first it was very difficult to me to focus it. :huh: By the way, now I changed all fsuipc.ini commands referred to device #0 -> #1 and #2 -> #0 and everything was OK again. I need for sure take a deeper glance to joy letters facilities which I missed to do so far, as I'm planning to add a second throttle quadrant. Thanks for patience and kind regards Stefano
  2. Hi Pete, I reinstalled Fsuipc and 3989u update but nothing changed. However I was able to isolate the problem. When I programmed my Saitek hardware, the joystick assignement in [Joynames] section was like: AutoAssignLetters=No 0=Saitek Pro Flight Yoke 2=Saitek Pro Flight Rudder Pedals But now everytime I start Fs9, even after editing it as above, my fsuipc.ini changes back to: AutoAssignLetters=No 0=Saitek Pro Flight Rudder Pedals 1=Saitek Pro Flight Yoke messing up all my setup, as expected. I recently changed motherboard and since then I have to disconnect my USB hub before powering up (I think because I still haven't updated all drivers for new hardware) and reconnect it after the boot is complete. Sometime I could also have swapped the yoke and rudder USB plug. Has it have anything to do with my issue? Note that after changing motherboard I have used Fs9 and Saitek hardware without any problem until two days ago and the malfunction showed up during a Fs9 session, not after a new boot and not after a new Fs9 start either. Also, I tried disconnecting rudder and starting Fs9 with only yoke connected, but it is still recognised as #1. Now, should I correct all my fsuipc.ini settings according to this new assignement or could it be possible to force the previous joystick assignement? Best regards Stefano
  3. Thanks for quick answer. No, the fsuipc.ini is always the same and no new one is created. Also, a new fsuipc.log is written every time I restart. As soon as possible I will post a copy of both. Best regards
  4. After many months of perfect working, last night my Saitek yoke and throttle suddenly stopped functioning without any apparent reason. It simply did not execute any command which I programmed from user interface, by editing the fsuipc.ini and recording mouse macros. After excluding any hardware or USB driver problem (it still works under FSX which I don't use normally), I noticed that Fsuipc seems unable to access to fsuipc.ini, or at least it behaves just as it does not exist. I was able to restore most commands through the user interface, but if I restart Fs9 the issue is back again. Of course, fsuipc.ini is still in same place and I did not make any change to my system before the problem came out. My SO is Win 7 64, and I've always run Fs9 as administrator. I would be very grateful for any cue or suggestion.
  5. Hi everybody, something strange has happened with my Fsuipc 3.98, it seems that the [buttons] section of my fsuipc.ini is ignored since no general assignment I made for my Saitek cloche and throttle quadrant is working anymore. The only working buttons are the aircraft specific ones, and the hat-switch buttons which I reprogrammed in [buttons] section. The axis are still working normally, both general and specific. Below there is the final section of my fsuipc.ini, which has been working great until this morning. Any clue? Thanks for any suggestion EDIT: To whom it may concern, I found the problem. :) I realized that only the compound buttons assignments are affected by this behaviour, so I checked the involved buttons 0,0 and 0,8 in control panel for an hardware failure, but they were working correctly. However, in order to get the mode button recognized by Fsuipc, I tweaked Fs9 by renaming the file C:\Windows\System32\SaiD0BAC.pr0 as suggested in the topic viewtopic.php?f=54&t=68972 Today, I don't know the reason, the file was written down again preventing the mode button from Fsuipc recognition. The only change I made was yesterday, when I installed the M-Panel driver and software and tried to get it working correctly, but I didn't even try to make it interact with Fsuipc. In addition, I made a complete flight after installing it and my Saitek cloche still worked as expected. [buttons] ButtonRepeat=20,5 0=H0,1,K74,8 ;J - push-to-talk 1=CR(-0,0)(+0,8)0,2,C65754,0 ;ZOOM_IN_FINE 2=CR(-0,0)(+0,8)0,3,C65755,0 ;ZOOM_OUT_FINE 3=CR(-0,0)(+0,8)0,4,C66528,0 ;EYEPOINT_FORWARD (HAT) 4=CR(-0,0)(+0,8)0,5,C66529,0 ;EYEPOINT_BACK (HAT) 5=CP(-0,0)(+0,8)0,6,C65749,0 ;VIEW_MODE_PREV 6=CP(-0,0)(+0,8)0,7,C65567,0 ;VIEW_MODE 9=CP(-0,0)(+0,8)0,15,C65759,0 ;FLAP_INC 10=CP(-0,0)(+0,8)0,14,C65758,0 ;FLAP_DEC 11=CP(-0,0)(+0,8)0,16,C65570,0 ;GEAR_TOGGLE 12=CR(+0,0)(+0,8)0,2,C65641,0 ;NAV1_RADIO_WHOLE_INC 13=CR(+0,0)(+0,8)0,3,C65645,0 ;NAV2_RADIO_WHOLE_INC 14=CR(+0,0)(+0,8)0,4,C65643,0 ;NAV1_RADIO_FRACT_INC 15=CR(+0,0)(+0,8)0,5,C65647,0 ;NAV2_RADIO_FRACT_INC 16=CP(+0,0)(+0,8)0,7,C66448,0 ;NAV1_RADIO_SWAP 17=CP(+0,0)(+0,8)0,6,C66452,0 ;NAV2_RADIO_SWAP 18=CR(+0,0)(+0,8)0,34,C65663,0 ;VOR1_OBI_INC 19=CR(+0,0)(+0,8)0,38,C65662,0 ;VOR1_OBI_DEC 20=CR(+0,0)(+0,8)0,32,C65665,0 ;VOR2_OBI_INC 21=CR(+0,0)(+0,8)0,36,C65664,0 ;VOR2_OBI_DEC 40=CR(+0,0)0,11,C65648,0 ;ADF_100_INC 41=CR(+0,0)0,12,C65649,0 ;ADF_10_INC 42=CR(+0,0)0,13,C65650,0 ;ADF_1_INC 50=CR(-0,0)0,32,C66524,0 ;EYEPOINT_UP (HAT) 52=CR(-0,0)0,36,C66525,0 ;EYEPOINT_DOWN (HAT) 54=CR(-0,0)0,34,C66526,0 ;EYEPOINT_RIGHT (HAT) 56=CR(-0,0)0,38,C66527,0 ;EYEPOINT_LEFT (HAT) 57=R0,20,C65602,0 ;THROTTLE_DECR (reverse) 58=U0,20,C65604,0 ;THROTTLE_CUT (stop reverse) 60=B8320=1 P0,34,C65676,0 ;VIEW_RIGHT in 2d cockpit 61=B8320=1 U0,34,C65674,0 62=B8320=1 P0,38,C65680,0 ;VIEW_LEFT in 2d cockpit 63=B8320=1 U0,38,C65674,0 64=B8320=1 P0,33,C65675,0 ;VIEW_FORWARD_RIGHT in 2d cockpit 65=B8320=1 U0,33,C65674,0 66=B8320=1 P0,39,C65681,0 ;VIEW_FORWARD_LEFT in 2d cockpit 67=B8320=1 U0,39,C65674,0 68=B8320=1 P0,35,C65677,0 ;VIEW_REAR_RIGHT in 2d cockpit 69=B8320=1 U0,35,C65674,0 60=B8320=1 P0,37,C65679,0 ;VIEW_REAR_LEFT in 2d cockpit 61=B8320=1 U0,37,C65674,0 62=B8320=1 P0,32,C66524,0 62=B8320=1 P0,36,C66525,0 [Axes] 0=0X,256,D,1,0,0,0 1=0Y,256,D,2,0,0,0 2=0Z,256,D,4,0,0,0 3=0R,256,D,6,0,0,0 4=0U,256,D,5,0,0,0 5=2R,256,F,65764,0,0,0 [Axes.PMDG 737] 0=0X,256,D,1,0,0,0 1=0Y,256,D,2,0,0,0 2=0Z,256,D,4,0,0,0 3=0R,256,D,22,0,0,0 4=0U,256,D,23,0,0,0 [buttons.PMDG 737] 0=P0,14,K71,11 7=P0,16,K71,8 8=P0,20,K113,8 [JoystickCalibration.PMDG 737] AllowSuppressForPFCquad=Yes ExcludeThrottleSet=Yes ExcludeMixtureSet=Yes ExcludePropPitchSet=Yes SepRevsJetsOnly=No ApplyHeloTrim=No UseAxisControlsForNRZ=No FlapsSetControl=0 FlapDetents=No ReverserControl=66292 Reverser1Control=66422 Reverser2Control=66425 Reverser3Control=66428 Reverser4Control=66431 MaxThrottleForReverser=256 AileronTrimControl=0 RudderTrimControl=0 CowlFlaps1Control=0 CowlFlaps2Control=0 CowlFlaps3Control=0 CowlFlaps4Control=0 MaxSteerSpeed=60 LeftBrake=-16384,16383/16 RightBrake=-16384,16383/16 Flaps=-16254,16380/16 [Monitor] Display=5 [buttons.DreamFleet] 0=P0,19,C65907,0 ;Radio Panel 1=P0,18,C65908,0 2=P0,17,CM1:4,0 [buttons.Aeroworx] 0=P0,19,C65911,0 1=P0,18,C65907,0 [Keys] 1=32,10,65706,0 [buttons.C172 Anniversary] 0=P0,19,C65908,0 [buttons.Cessna Skylane II RG R182] 0=P0,19,C65911,0 [Axes.Aeroworx] 0=0X,256,D,1,0,0,0 1=0Y,256,D,2,0,0,0 2=0Z,256,D,4,0,0,0 3=0R,256,D,14,0,0,0 4=0U,256,D,13,0,0,0 5=2R,256,F,65764,0,0,0 [buttons.Cessna Skylane II RG R182 3] 0=P0,19,C65911,0
  6. Not exactly...I just want to cycle among 2D Cockpit, VC, Observer and Tower views I think this was definitely the point...I completely missed it :oops: This will be very, very useful for the future...thank you Best regards
  7. I cannot get these FS controls working when I associate them to the yoke buttons. I tried to do that both via FSUIPC user interface and via FSUIPC.INI editing. This is from my FSUIPC.INI: 14=P0,7,C65827,0 ;NEXT_VIEW 15=P0,6,C65828,0 ;PREV_VIEW I also tried editing fs9.cfg and changing the default lines NEXT_VIEW=9,10 and PREV_VIEW=9,11 in 83,8 and 83,9 which makes more sense to me, but without result. The only way for cycling views via FSUIPC seems to associate the buttons to keypress S and shift+S, but my aim was to program my yoke with Fsuipc only through FS controls, avoiding keyboard commands as far as possible. All others FS controls I'm using on yoke assignations are working fine. What is wrong? Regards
  8. I'd like to do like that, of course, but my wife doesn't like watching TV in the living room or trying to sleep at night with a 737 taxiing in the next room :wink: . Thanks anyway, I'll search on Ivap or TS forums
  9. Hi, Pete, this is my issue: I wish to run the IVAP User Interface on my 2nd networked PC, in order to avoid the annoying IVAP window on my FS screen always getting the focus and intercepting some keystrokes. The problem is, the audio card on my Pc #2 is not working and I can not get and send any sound. But even if I also have another laptop I could use for that task, I need to keep both audio from Fs9 and TS in the headset connected to Pc #1. I know that normally IVAP User Interface connects directly via TCP/IP to the networked Pc with Fs and Network Interface, but it requires TS to be installed on same machine. I was wondering whether WideFs could help me in launching the IVAP User Interface on Pc #2 and still keeping TS on Pc #1. In other words, I sort of want to do the opposite than controling the PTT of TS on Pc #2 from a joystick on Pc #1. I would be grateful for any suggest Stefano
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.