Jump to content
The simFlight Network Forums

gypsyczar

Members
  • Content Count

    7
  • Joined

  • Last visited

Community Reputation

0 Neutral

About gypsyczar

  • Rank
    Newbie

Profile Information

  • Gender
    Not Telling
  • Location
    Florida
  1. Pete, I reinstalled 5.112 (for the third time) and now it works as advertised. Sorry for any extra work on your part. Issue closed......
  2. Hi Pete, Sorry for the extended delay, I was away from the home computer. I kept this response in the "wrong" thread for continuity Attached is a zip file containing: 1. The fsuipc5.ini for 5.112 2. The Previous log file for 5.111 3. The log file for 5.112 4. The PMDG 737ngx.ini profile file Once again, all was working fine under 5.111. I ran the installer for 5.112 and made no changes to any of the FSUIPC files. After the 5.112 install the Axis Assignments from the profiles were not being made by FSUIPC (or shown in Axis Assignments) for the corresponding selected aircraft. Selecting the Profile Specific ? checkbox on the Axis Assignment tab results in the display of the "Do you want to apply the general assignments to this aircraft" dialog box even though axis assignments exist in the aircrafts profile.ini file I sent you the PMDG 737NGX profile, but the problem was common across all aircraft with profiles. Deleting the 5.112 DLL and reverting to the 5.111 install results in proper operation of the axis assignments.. Profile.zip
  3. Hi Pete. I am having a problem with Axis assignment using profiles in 5.112. All of the other categories buttons, keys, Etc allow selecting existing profile specific however Axis does not. In 5.112 If I select axis and check profile specific I am presented with the new profile dialog even though there are axis settings contained in the specific profile ini file. If I revert back to 5.111 without making any changes to FSUIPC.ini or the specific aircarft profile.ini all is well. Attached is FSUPIC INI. Per this thread I am not missing any joysticks ---------------------- Joystick Device Scan ----------------------- 171 Product= Saitek Pro Flight Quadrant 171 Manufacturer= Saitek 171 Vendor=06A3, Product=0C2D (Version 2.0) 171 GUIDs returned for product: VID_06A3&PID_0C2D: 171 GUID= {1A2CF0E0-F8DA-11E5-800A-444553540000} 171 Details: Btns=9, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X255,Y255,Z255 171 Product= CH PRO PEDALS USB 171 Manufacturer= CH PRODUCTS 171 Vendor=068E, Product=00F2 (Version 0.0) 171 GUIDs returned for product: VID_068E&PID_00F2: 171 GUID= {1A386290-F8DA-11E5-8012-444553540000} 171 Details: Btns=0, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X255,Y255,Z255 171 Product= Pro Flight X65 Control System 171 Manufacturer= Saitek 171 Vendor=06A3, Product=0B6A (Version 1.101) 171 GUIDs returned for product: VID_06A3&PID_0B6A: 171 GUID= {1A38B0B0-F8DA-11E5-8015-444553540000} 171 Details: Btns=50, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R511,U255,V255,X4095,Y4095,Z255 171 ------------------------------------------------------------------- 187 Device acquired for use: 187 Joystick ID = 0 (Registry okay) 187 0=Saitek Pro Flight Throttle Quadrant 187 0.GUID={1A2CF0E0-F8DA-11E5-800A-444553540000} 187 Device acquired for use: 187 Joystick ID = 1 (Registry okay) 187 1=CH PRO PEDALS USB 187 1.GUID={1A386290-F8DA-11E5-8012-444553540000} 187 Device acquired for use: 187 Joystick ID = 2 (Registry okay) 187 2=Saitek X65F Flight Controller 187 2.GUID={1A38B0B0-F8DA-11E5-8015-444553540000}
  4. UPDATE: I restored the original DLL.XML file with all addons. I then reinstalled the GSX app. P3d started fine with FSUIPC enabled the first time. The second attempt at P3D start repeated the crash behavior. Disabling FSUIPC had no affect on performing a succesfull start. I then reinstalled GSX again, enabled FSUIPC and P3D started fine the first time. The second P3d start failed. I then reinstalled FSUIPC and P3D started fine. Once again, the next P3D start failed. It looks like there is some interaction with addon installs going on that I cannot find
  5. Hello all. I am having the same issue. If I install the newest FSUIPC module P3D will run fine the first time. It will crash and leave a process running on the machine on any subsequent attempts to start P3D. I have reduced the DLL.XML file to just FSUIPC....and this behavior persists. If I disable FSUIPC in the DLL file P3D then starts fine. If I turn FSUIPC back on in DLL.XML P3D repeats the crash behavior. Turing FSUIPC on/off in the DLL.XML file generates repeatable cases as described above. <?xml version="1.0" encoding="Windows-1252"?> <SimBase.Document Type="Launch" version="1,0"> <Descr>Launch</Descr> <Filename>dll.xml</Filename> <Disabled>False</Disabled> <Launch.ManualLoad>False</Launch.ManualLoad> <Launch.Addon> <Name>FSUIPC 4</Name> <Disabled>False</Disabled> <Path>Modules\FSUIPC4.dll</Path> </Launch.Addon> </SimBase.Document> When P3D does crash there is no FSUIPC log file generated. The only other addons running are the FSDT addons associated with GSX. There is an as_btstrp_config_manager loaded in EXE,XML but disabling that load has no affect on whether P3D starts, Given this it appears that The new FSUIPC module has an issue with P3D, unless there is some adverse interaction with the GSX programs. Below is the FSUIPC log from the successful initial start of P3D. Minus my personal information. I'm running out of ideas here. ********* FSUIPC4, Version 4.959 (19th December 2016) by Pete Dowson ********* Windows version reported as 6.2.?.9200 Prepar3D.exe version = 3.4.18.19475 Reading options from "P:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\FSUIPC4.ini" Running inside Prepar3D v3 on Windows 8.0 or later Module base=54F10000 User Name= User Addr= FSUIPC4 Key is provided WideFS7 Key is provided 109 System time = 29/12/2016 06:14:14 109 FLT UNC path = "C:\Users\Gypsy\Documents\Prepar3D v3 Files\" 109 NOTE: configuring for no weather reads or writes! 109 ------ Module Version Check ------ 109 acontain.dll: 3.4.18.19475 109 api.dll: 3.4.18.19475 109 controls.dll: 3.4.18.19475 109 fs-traffic.dll: 3.4.18.19475 109 G3D.dll: 3.4.18.19475 109 language.dll: 3.4.18.19475 109 sim1.dll: 3.4.18.19475 109 visualfx.dll: 3.4.18.19475 109 window.dll: 3.4.18.19475 109 ---------------------------------- 109 Trying P:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\SimConnectP3D3.dll 109 Found it: trying to connect 109 FS UNC path = "P:\Program Files (x86)\Lockheed Martin\Prepar3D v3\" 359 Finished: 0 Profile files created 391 ---------------------- Joystick Device Scan ----------------------- 391 Product= Saitek Pro Flight Quadrant 391 Manufacturer= Saitek 391 Vendor=06A3, Product=0C2D (Version 2.0) 391 Serial Number= Saitek 406 Product= CH PRO PEDALS USB 406 Manufacturer= CH PRODUCTS 406 Vendor=068E, Product=00F2 (Version 0.0) 406 Serial Number= CH PRODUCTS 406 Product= Pro Flight X65 Control System 406 Manufacturer= Saitek 406 Vendor=06A3, Product=0B6A (Version 1.101) 406 Serial Number= Saitek 406 ------------------------------------------------------------------- 406 LogOptions=00000000 00000001 422 ------------------------------------------------------------------- 422 ------ Setting the hooks and direct calls into the simulator ------ 422 --- CONTROLS timer memory location obtained ok 422 --- SIM1 Frictions access gained 422 --- FS Controls Table located ok 422 --- Installed Mouse Macro hooks ok. 422 --- Wind smoothing fix is not installed 422 --- SimConnect intercept for texts and menus option is off 422 --- All links okay (with no weather related ones) 422 ------------------------------------------------------------------- 422 SimConnect_Open succeeded: waiting to check version okay 422 Trying to use SimConnect Prepar3D 422 Opened separate AI Traffic client okay 16594 Running in "Lockheed Martin® Prepar3D® v3", Version: 3.4.18.19475 (SimConnect: 3.4.0.0) 16594 Initialising SimConnect data requests now 16594 FSUIPC Menu entry added 16609 C:\Users\Gypsy\AppData\Local\Lockheed Martin\Prepar3D v3\Prepar3D_Default.fxml 16609 P:\Program Files (x86)\Lockheed Martin\Prepar3D v3\SimObjects\Airplanes\IRIS Raptor Driver\Raptor.air 42953 User Aircraft ID 1 supplied, now being used 43516 System time = 29/12/2016 06:14:57, Simulator time = 05:14:01 (11:14Z) 43531 Aircraft="F-22 Raptor - 525th Fighter Squadron" 44547 Starting everything now ... 44547 LUA.0: beginning "P:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\ipcReady.lua" 44547 LUA.0: ended "P:\Program Files (x86)\Lockheed Martin\Prepar3D v3\Modules\ipcReady.lua" 44562 LUA.1: *************************** STARTING LINDA ************************** 44562 LUA.1: LINDA:: [START] Loading System Configuration files 44594 LUA.1: LINDA:: [START] VRInsight MCP Set = mcp 44609 LUA.1: LINDA:: [START] System Configuration files loaded 44750 LUA.1: LINDA:: [START] ************************************************************* 44750 LUA.1: LINDA:: [START] New Aircraft Selected - restarting... 44750 LUA.1: LINDA:: [START] ************************************************************* 44750 LUA.1: LINDA:: [START] Current Aircraft: F-22 Raptor - 525th Fighter Squadro 44906 LUA.1: LINDA:: [START] Aircraft module detected: FSX Default 44922 LUA.1: LINDA:: [START] ************************************************************* 44969 LUA.0: LINDA:: [INIT] Starting Initialisation... 45016 LUA.0: LINDA:: [INIT] Loading Libraries... 45016 LUA.0: LINDA:: [LIB] AivlaSoft library loaded... 45016 LUA.0: LINDA:: [LIB] ATC library loaded... 45031 LUA.0: LINDA:: [LIB] FSX standard library loaded... 45031 LUA.0: LINDA:: [LIB] FS2Crew library loaded... 45047 LUA.0: LINDA:: [LIB] FSX Functions loaded... 45047 LUA.0: LINDA:: [LIB] IVAO library loaded... 45047 LUA.0: LINDA:: [LIB] RealityXP library loaded... 45062 LUA.0: LINDA:: [LIB] Saitek Functions loaded... 45062 LUA.0: LINDA:: [LIB] VATSIM library loaded... 45078 LUA.0: LINDA:: [LIB] VRInsight Function Library loaded... 45078 LUA.0: LINDA:: [LIB] Weather library loaded... 45078 LUA.0: LINDA:: [LIB] A2A MAP library loaded... 45078 LUA.0: LINDA:: [INIT] Initializing Common Variables... 45125 LUA.0: LINDA:: [INIT] User GLOBAL config loaded... 45141 LUA.0: LINDA:: User's modifications script is loaded... 45141 LUA.0: LINDA:: [INIT] User FUNCTIONS loaded... 45156 LUA.0: LINDA:: [INIT] Finalising Initialisation... 45312 LUA.0: LINDA:: [COMM] Checking VRI 45328 LUA.0: LINDA:: [INIT] Module: FSX Default Started... 45469 LUA.0: LINDA:: [INIT] Ready to go, Captain! 45469 LUA.0: LINDA:: [INIT] *************************************************************** 68594 === Calling SimConnect_Close ... 68797 === SimConnect_Close done! 69797 System time = 29/12/2016 06:15:23, Simulator time = 05:15:09 (11:15Z) 69797 *** FSUIPC log file being closed Minimum frame rate was 19.7 fps, Maximum was 20.0 fps Minimum available memory recorded was 2084Mb Average frame rate for running time of 13 secs = 19.8 fps Maximum AI traffic for session was 0 aircraft Memory managed: 100 Allocs, 96 Freed ********* FSUIPC Log file closed ***********
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.