Jump to content
The simFlight Network Forums

RobAins

Members
  • Posts

    62
  • Joined

  • Last visited

Everything posted by RobAins

  1. Hi Pete/John Interesting, this time everything shutdown normally with this latest DLL? Did you make any other changes beyond debug logging? Sunny and 72F at EGCC? Shorts weather right? Cheers, Rob. FSUIPC5.log WideServer.log
  2. Hi John/Pete, This will be the last DLL test I can do for now ... packing for tomorrow's trip and set you up for that fastest PC on the planet 😉 Agree Pete, I never want to install any "debuging" (VS) tools on my main FS PC ... however, with that said, I believe VS 2017/2019 supports remote debugging. I never done this process but I think it would require you to provide me with remote symbol set and of course I would need to setup my PC to accept the connection but I don't actually need VS installed. More details here: https://docs.microsoft.com/en-us/visualstudio/debugger/remote-debugging?view=vs-2019 Again, I've never done this, but know it exists. Cheers, Rob.
  3. On my main FS PC, I never install any of LM's Beta (too many add-ons would not work if I did). Only on my development PC do I install Betas. Cheers, Rob.
  4. I have the same version. I don't see that in my btstrp.txt? This is what I have: For Network setup, SimConnect needs to be installed on the Network PC and there needs to be a SimConnect.cfg defined on the Network PC in the Documents folder: The IP address needs to point to the main FS PC. On the network PC I run AS_P3Dv4.exe which does all the weather process and communication to my main FS PC. Running this program on the network PC and I get the main HiFi AS weather app: The ONLY component installed on my main FS PC is the ASConnect_P3Dv4_Install.exe (this file is copied over to my main FS PC from the Network PC during the AS4 installation on Network PC). This file is executed on the my main FS PC and will create the following directory/files: The as_connect_64.dll is referenced in the DLL.XML file on my main FS PC. I think the KEY here is that WideFS seems to have a reliance on HiFi AS4 actually running on my network PC. Hope this info helps. Cheers, Rob.
  5. Hi John, See attached logs with new DLL. I did find something rather interesting. I run HiFi AS4 from a networked PC. Here are the test scenarios and results: Scenario 1 WideFS enabled HiFi AS4 running from my network PC P3D shutdown correctly (all terminates) Scenario 2 WideFS enabled HiFi AS4 NOT running on my network PC P3D does NOT shutdown Scenario 3 WideFS disabled HiFi AS4 running from my network PC P3D shutdown correctly (all terminates) Scenario 4 WideFS disabled HiFi AS4 NOT running from my network PC P3D shutdown correctly (all terminate) So there seems to be some interaction between WideFS and HiFi AS4 running on a network PC ... is it possible WideFS is looking for some sort of termination event from HiFi AS4 that never happens because it's never started from my networked PC? Cheers, Rob. FSUIPC5_HiFi_AS4_CONNECTED.log WideServer_HiFI_AS4_CONNECTED.log FSUIPC5_HiFi_AS4_NOT_Connected.log WideServer_HiFi_AS4_NOT_Connected.log
  6. Here ya go gents, attached logs. TaskMgr termination of P3D was required so take that into account. Cheers, Rob. FSUIPC5.log WideServer.log
  7. UPDATE: Disable GoFlight entry and GIT entry: <Launch.Addon> <Disabled>True</Disabled> <Name>GoFlight P3D Data Bridge</Name> <ManualLoad>False</ManualLoad> <Path>D:\GoFlight\GFDevP3Dv4.exe</Path> <CommandLine> </CommandLine> </Launch.Addon> and GIT entry: <Launch.Addon> <Name>GoFlight Interface Module</Name> <Disabled>True</Disabled> <Path>D:\GoFlight Interface Tool\GoFlight Interface Module 64.dll</Path> </Launch.Addon> Unfortunately, same result if WideFS is enabled, P3D doesn't terminate. Removed FSUIPC v1.53 and installed v1.52 and the same issue is present with v1.52. Tested the Intel NIC (made changes to accommodate for IP change) and results where the same as the Aquantia NIC, P3D would not shutdown with WideFS enabled. I understand trying to diagnose this is going to be extremely difficult, so I'm happy to just leave this as a mystery as I really don't mind disabling WideFS since I have nothing that relies on it. Appreciate the assistance and support. Cheers, Rob.
  8. I don't think it's a low level problem as that would surface everywhere not just with WideFS (my PC's and add-on are heavily network reliant). I'll test without GoFlight entry and see what happens ... but FYI, I've been using the same GoFlight entry/version for years (plural) without issue and the GoFlight entry doesn't cause any shutdown issues when WideFS is disabled. Is it possible you can create a special build with additional logging points and email to me? I'll run the 1.52 version tonight and see if that makes a difference. But like I said, it's not a big deal for me to just disable WideFS so I have a work-around. Cheers, Rob.
  9. I ran a very quick test flight (1.53) with WideFS enabled and logging (see attached). I don't get to "Closing down now ..." in WideFS log. Obviously I have to manually end task after I trigger P3D Exit (I do wait about 3 mins just to make sure it's not shutting down normally). The shutdown problem is 100% repeatable when I enable WideFS. I'll revert to 1.52 later tonight and test again. Cheers, Rob. WideServer.log FSUIPC5.log
  10. Hi Pete/John, I'm working on something else right now, but will do some more diagnostics later tonight. FYI, I'm using the "Aquantia 5G/10G Ethernet connection Driver for RS5" ... I can switch to old school "Intel(R) Gigabit Ethernet Driver" for testing, but I have been using the "Aquantia" drivers for many months now without issue. Will report back later with your suggestions. Cheers, Rob.
  11. Hi Pete, I should have listened ... it seems WideFS is the source of preventing P3D shutdown. I suspect it's perhaps a combination of add-ons maybe? ... I'm using GoFlight, HiFi, SODE, ChasePlane, Immersion, Orbx, and several others as you can see in the list. I tried to pin point exactly why using a tool called Process Hacker (ethics aside), it's a VERY good tool at determining who's got what, when, and where even down to file I/O. But with that said ... I still couldn't positively ID ... here is my diagnostics work: I've ran about 12 shutdown tests now with WideFS disabled and P3D is shutting down correctly. May I ask why you suspected WideFS? Cheers, Rob.
  12. Hi Pete, I thought you were on holiday? I'm still trying to diagnose, I've eliminated many variables and I'm down to RealSimGear and RXP GNS 530 and A2A as possible triggers. All the info I can get out of TaskMgr is "waiting for network I/O" which I think is generic and not useful. In order to get the RXP to not trigger a CTD when added to an aircraft, I have to run P3D "as Admin" .. P3D is outside Program Files and both RSG and RXP are located in folders under Program Files. I suspect it's some sort of security context issue. Sadly many add-ons I have like to install themselves into Program Files without prompting install paths (SODE, RXP, CP, Immersion, etc.). I was thinking of manually relocating them outside of Program Files, but requires a lot of registry work also and I'm trying to avoid that. I'll do more diagnostics and get back to you, this is a difficult one because I'm not seeing any issues in your log, nothing in SimConnect log (even with Verbose), nothing in P3D logs, there is one "warning" in event viewer but I don't think it's related. Cheers, Rob.
  13. Hi Gents, Installed 5.153 recently and having some odd issues with shutdown Taskmgr ... the process never terminates after a shutdown. I've attached the log, but don't see any issues. Cheers, Rob. FSUIPC5.log
  14. Thanks, Burkhard. Appreciate the continued support. Cheers, Rob.
  15. One quick question, I don't need to apply Beta 2 - 4 before I apply Beta 5 ... Assume Beta 5 is cumulative? Cheers, Rob.
  16. Many of the errors in the P3D error logs are repeat errors so it's unlikely all need to be fixed, just a subset. However, with that said, some of the errors maybe harmless, some are not and can induce stutters and other odd issues in P3D. It's a VERY useful tool to have ... in many cases the errors are relatively simple to fix by end users and hope 3rd party will address them also. It does have a weakness, it does indeed stop reporting after 1000 errors ... there could be other important errors ... so it's good to fix the listed errors as that will allow more errors to be report (if any more exist that weren't shown because of the 1000 error count cap). It's a good tool to have so I wouldn't totally ignore it. Cheers, Rob.
  17. Thanks for the response ... FSUIPC is only showing a single event with my GF-T8 (original). I have those switches disabled in GFConfig so they should not be conflicting with FSUIPC. I'm going to try the GoFlight Interface Tool (polly-pot software - Steve's tool) and see what it shows for my GF-T8 (it's one of the very early GF-T8). Cheers, Rob.
  18. I'm not sure if this is a FSUIPC issue or a GoFlight issue, but my GF-T8 switches are only being seen by FSUPIC as single state ... so they only work at a Toggle and not as an On and Off state? I need an ON and OFF state/triggers. Cheers, Rob.
  19. I'm not having much luck getting any go flight buttons mapped to my MJC Q400 ... I'm monitoring the events via the FSUIPC console and see the events that get triggered when I click on the a button in the Q400 VC ... but when I associate that event to a GoFlight button, press the goFlight button see the event in the console but nothing happens in the Q400 VC. I realize this might be better posted on the MJC forum, but thought I'd ask here in case anyone has some helpful hints or has been able to use FSUIPC with the MJC Q400. This is in P3D V2.3. Cheers, Rob.
  20. I don't know if the Hot+Fix for 2.2 also included other items they had been working on or not ... like you said, most DLLs were not changed so I'm guessing they were able to regress back to the 2.2 release build and just implement code changes specific to fixing the Flight Planner issue. Appreciate your work as always Pete. Cheers, Rob.
  21. 4.931 is working well for me ... including mouse macros. Thanks for the very prompt response and fix. LM released a HotFix to 2.2 on 4/10. I am running released version which is 10438 (not Beta). Cheers, Rob.
  22. Event Viewer reports the following: Faulting application name: Prepar3D.exe, version: 2.2.10438.0, time stamp: 0x53469019 Faulting module name: FSUIPC4.dll, version: 4.9.2.9, time stamp: 0x534ea035 Exception code: 0xc0000005 Fault offset: 0x00028a22 Faulting process id: 0xd08 Faulting application start time: 0x01cf5a01f639b4cd Faulting application path: V:\Lockheed Martin\Prepar3D v2\Prepar3D.exe Faulting module path: V:\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.dll The FSUIPC 4.93 install log: INSTALLATION FOR Prepar3D v2: SetupPath="V:\Lockheed Martin\Prepar3D v2\" Checking version of the Prepar3D v2 EXE: ... Version 2.2.10438.0 (Need at least 1.0.677.0) !! WARNING !! This version of Prepar3D is later than any known by this FSUIPC4. There may be problems. Please check for a later version of FSUIPC4! Checking compatibility with installed SimConnect: Found SimConnect build 60905 (Original) Found SimConnect build 195 (ESP Orig) Found SimConnect build 61242 (SP1 May07) Found SimConnect build 61259 (Acc/SP2 Oct07) Checking if there's already a version of FSUIPC4 installed in: V:\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.DLL ... Version 4.930 found. Prepar3D v2 Modules folder already exists. Okay -- installed FSUIPC4 into "V:\Lockheed Martin\Prepar3D v2\Modules\FSUIPC4.DLL" Looking for the current user's Application Data path: ... found as "C:\Users\Rob\AppData\Roaming" Now finding \Lockheed Martin\Prepar3D v2\Prepar3D.CFG for all users, including this one Looking in "C:\Users\All Users\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Default\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Default User\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Public\AppData\Roaming" ... No Prepar3D.CFG there Looking in "C:\Users\Rob\AppData\Roaming" Found Prepar3D.CFG in "C:\Users\Rob\AppData\Roaming\Lockheed Martin\Prepar3D v2\Prepar3D.CFG" Now checking DLL.XML ... ... There is a previous DLL.XML, checking for FSUIPC4 section. ... FSUIPC4 section already exists but will be replaced. (for FSUIPC4, without Loader) ... FSUIPC4 section of DLL.XML written okay Now checking for a SimConnect.XML file ... ... No SimConnect.XML file found. This is okay. "Modules\FSUIPC Documents" folder already exists. Now installing the Prepar3D SimConnect interface for FSUIPC4 into the "Modules" folder: Installed "SimConnectP3D2.dll" okay Now installing additional files into the "Modules\FSUIPC Documents" folder: Installed "FSUIPC4 User Guide.pdf" okay Installed "FSUIPC4 for Advanced Users.pdf" okay Installed "FSUIPC4 History.pdf" okay Installed "List of FSX and P3D controls.pdf" okay Installed "FSUIPC Lua Library.pdf" okay Installed "FSUIPC Lua Plug-Ins.pdf" okay Installed "Lua License.pdf" okay Installed "Lua Plugins for VRInsight Devices.pdf" okay Installed "LuaFileSystem.pdf" okay Installed "Example LUA plugins.zip" okay Installed "ASN WX Radar facilities in FSUIPC4.pdf" okay Installed "Offset Mapping for PMDG 737NGX.pdf" okay Installed "FSUIPC4 Offsets Status.pdf" okay =========================================================== All installer tasks completed. Registration check for FSUIPC4 and WideFS was successful! (result code 00) I noticed that the FSUIPC.DLL shows a File Version = 2.9.2.9 but the Product Version is 4.93. Windows 7 64bit P3DV2.2 + hotfix (Professional Plus version) Rob.
  23. This turned out to be my fault ... mouse macro's are working VERY well with this Aircraft. I didn't realize I needed to use the 2D panels (just for macro) to make it happen -- only need them to setup the macro, once setup I'm back to VC. VC is working very well now and I'd like to thank you for providing such a wonderful tool in FSUIPC. Finally I can enjoy my GoFlight modules in just about any aircraft supporting 2D panels.
  24. Appreciate your responses Pete, I've brought this up with Lars/QW support forum and see if he/they have any suggestions ... but from what I've gathered, their v1.4 update is final for this aircraft. Some switches do work (panel is updated) like the Strobe light, others do not like Landing Lights (lights go on, but switch isn't updated on panel). Cheers, Rob.
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.