Jump to content
The simFlight Network Forums

Issue Configuring VRInsight MCP Combo II using VSPE and FSUIPC

Recommended Posts



First I do not know where to publish the question, here or send it to VRInsight support.


I have FS9 and want to use the MCP Combo panel II with Qwality wings BAe AVRO RJ100. To make this work I know I have to user the combination of VSPE and FSUIPC to create macros for the different buttons, swicthes, rotary, etc. I have setup the VSPE with the pair COM2 and COM4. I have modify the FSUIPC and include the section:



1=COM3, COM4


The MCP Combo is running in COM3 port.


I started first the VSPE, then the FS9 and when I have the AVRO loaded I then run the VRSim, but it does not change the port in VRSim, it always show the COM3, and I guess it should show COM4.


I followed the doc FSUIPC_VRInsight_mod.pdf created by Günter Steiner “guenseli”.


Any thoughts?




Link to comment
Share on other sites

Hi Kiko


You appear to have the fsuipc cfg entry incorrect. If you have set up vspe ports 2 and 4 - and your  mcp combo is on port 3, then your fsuipc cfg entry shoud be:



1=com3, com2


Just in case - VSPE needs to be running prior to FSim.

Also - not to sure if it makes any difference but perhaps you should run the Serial FP2.exe rather than the vrinsight.exe. But as I say not to sure on this one, but it is the one I use with NGX and my combo.


Hope this helps.



Link to comment
Share on other sites

Hi Kiko


Does the Combo actually do what it should be doing in the flightsim?


The VSPE does not change the com port (in your case 3) to which the Combo is set. A I understand it, in simple terms FSUIPC stops the Combo port from communicating directly with the flightsim. FSUIPC takes control and communicates with the flightsim using your virtual com ports 2 and 4. So the Combo will always remain on the original port, in your case 3.


I attach an extract from my fsuipc log to demonstrate:


 359 SimConnect_Open succeeded: waiting to check version okay
      359 Trying to use SimConnect Steam
      406 VRI port 1 "com3" opened
      406 VRI driver port 1 "com2" also opened
     1389 Running in "Microsoft Flight Simulator X", Version: 10.0.62615.0 (SimConnect: 10.0.62615.0)
     1389 Initialising SimConnect data requests now
     1389 FSUIPC Menu entry added
     1420 \\PLAIN-PC\Users\Martin Plain\Documents\Flight Simulator X Files\Transavia B738W.FLT
     1420 \\PLAIN-PC\Steam\steamapps\common\FSX\SimObjects\Airplanes\PMDG 737-800NGX WL\B737-800WL.air
     8752 Weather Mode now = Custom
    62479 Aircraft="Boeing 737-8K2NGX Transavia Airlines Winglets"
    62479 System time = 12/11/2015 20:17:50, Simulator time = 12:06:35 (11:06Z)
   110948 Sim stopped: average frame rate for last 48 secs = 22.2 fps
   126018 Starting everything now ...
   126080 ASN active function link set
   126080 Ready for ASN WX radar
   126096 Run: "c:\Program Files (x86)\VRInsight\bin\SerialFP2.exe"
   127048 VRI FMER ("MCP Combi") detected on port com3


Is this similar to what you are seeing in your log file?



Link to comment
Share on other sites

  • 4 months later...

Hello MartinP. It seems you have your FCU running with the virtual serial ports. I have it running partially but I think that FSUIPC is very fickle because, it seems to me, if one part works, the others should as well. Let me demonstrate, here is my setup:


VSPE pairs:









(I  had 1 and 2 the other way but then nothing worked - confused me).



USB serial port COM4 (CDU)

USB Serial Port COM6 (MCP2A)









(swapping these around had no observable impact - realized after deleting the .ini file, it just loads what it finds when it loads).


Here is is my FSUIPC4.log (in part):

FSUIPC4 Key is provided
WIDEFS7 not user registered, or expired
       46 System time = 09/04/2016 15:54:56
       46 FLT path = "H:\Documents and Settings\Administrator\My Documents\Flight Simulator X Files\"
       46 Trying to connect to SimConnect Acc/SP2 Oct07 ...
       62 FS path = "H:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"
     6406 LogOptions=00000000 00000001
     6406 SIM1 Frictions access gained
     6406 Wind smoothing fix is fully installed
     6406 G3D.DLL fix attempt installed ok
     6406 SimConnect_Open succeeded: waiting to check version okay
     6406 Trying to use SimConnect Acc/SP2 Oct07
     6453 VRI port 2 "COM4" opened
     6453 VRI driver port 2 "COM15" also opened
     6468 VRI port 1 "COM6" opened
     6468 VRI driver port 1 "COM13" also opened
    17546 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)
    17546 Initialising SimConnect data requests now
    17546 FSUIPC Menu entry added
    17609 H:\Documents and Settings\Administrator\My Documents\Flight Simulator X Files\A320UA-Default-running.FLT
    17609 H:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\jf_A320_IAE\jf_A320.AIR
    18703 System time = 09/04/2016 15:55:15, Simulator time = 12:39:36 (19:39Z)
    25031 Aircraft="jf_A320-232_IAE V2527-A5_UA"
    42890 Starting everything now ...
    44062 Advanced Weather Interface Enabled
    60328 VRI CDU ("CDU") detected on port COM4
   295046 Sim stopped: average frame rate for last 256 secs = 23.5 fps
   302250 System time = 09/04/2016 15:59:59, Simulator time = 12:43:51 (19:43Z)
   302250 *** FSUIPC log file being closed
Average frame rate for running time of 262 secs = 23.6 fps
G3D fix: Passes 11258, Null pointers 0, Bad pointers 0, Separate instances 0
Memory managed: 728 Allocs, 728 Freed
********* FSUIPC Log file closed ***********

 Notice that line 60328 is: 60328 VRI CDU ("CDU") detected on port COM4 but the log never shows MCP2A (FCU) is detected and yet, I can use the FCU on the default Airbus just fine, but the buttons aren't available like they are with the CDU. I noticed that when I start SerialFP2.exe the first time, it is ready to load COM16 for the CDU, that is fine, it works, I have access to the alternate buttons. But when I start SerialFP2 again, it wants to load the MCP2A using COM6 instead of COM14 unlike how SerialFP2 sees the CDU at the first loading. It seems to me that even though FSUIPC's serial diverter works for the CDU, it doesn't work for the MCP2A. Actually, I think it has something going on with FSUIPC because sometimes it works in some computers and sometimes it doesn't work in others even though I have used the same setup. I realize FSUIPC, by diverting COM ports is a bit unusual, but it's strange how inconsistent it is. In one computer, I had to force the MPanel to COM 3 and then it worked for the MPanel but that didn't work this time with MCP2A (FCU). Any advice?


Well, it's been awhile and there has been no response for help. After spending many hours trying to make it work for the FCU, I've come to the conclusion that neither using SerialFP2.exe nor VRiSim.exe will allow or recognize either the virtual serial port pairs or FSUIPC's port diverting.  I got it running for the CDU-I and mPanel but not for the Airbus FCU. In addition, I saw that the keymapper for the FCU allows direct mapping to FSUIPC's offsets so perhaps the diverting isn't required, although I like having access to the extra buttons I get with the CDU-I and mPanel because with many .xml gauges, I need a button to activate a key to control the gauge. I also tried through the years but I have not found that xml allows inputs from a game port adapter - unless somehow someone knows how to do that. Ugh, another correction: FCU's keymapping only allows mapping to FS's controls (6XXXX), and not FSUIPC's hex offsets (xXXXX), thus, making it more frustrating/awkward to use as hoped.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.