Jump to content
The simFlight Network Forums

Cannot install

Recommended Posts

I purchased and downloaded the .exe file to my desktop on Windows 11 for MSFS with the Modern file structure. Then right clicked and ran the .exe as administrator. Windows security flagged it as unsafe and after a few steps the program ran.

The first window that popped up was the install of mpeg codecs which I did. Next the program install window appeared. The first thing I noticed was the install path was for the Legacy file structure (x86). I inserted the correct path to my user/community folder and clicked install.

Windows once again said it could not install because I didn't have administrator rights. I have installed 21 addons into the community folder without a problem.

Next I created a folder on my desktop and extracted the files to it and then manually inserted it into the MSFS community folder and still nothing.

I opened up the folder and found a .exe so I ran it and the program ran outside of MSFS and showed connected to the sim. I tried to put the shortcut on the dropdown taskbar menu at the top of the sim and it had the program icon but when I clicked on it, it was blank. I tried the same with the P3D .exe and it ran outside of MSFS and when I put the program icon on the taskbar an empty box appeared.

I think the program is corrupted or outdated since during installation it defaults to the Legacy (x86) path.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.