Jump to content
The simFlight Network Forums

Recommended Posts

Note that mostly this Announcement will contain only the changed modules. You will almost always need the main release installed first. For those please also check http://www.schiratti.com/dowson

The FS modules here, when supplied without Installer, need copying into the FS modules folder once extracted.

Please note the format here. The links for all the updates are listed first. For interim releases only, notes about changes are listed separately, below.

 

FOR FS9 AND EARLIER ONLY

Install complete FSUIPC version 3.999z9b Install FSUIPC 3.999z9b for FS9 and before
-- For changes see the History document in the full install update.

FSUIPC version 3.999z9b only, for those with 3.999z1 or later already installed FSUIPC 3.999z9b
-- Fixes an ancient and obscure bug which nevertheless can crash FS on loading with certain INI file arrangements.
-- The z9b update merely enables Registrations purchased after the end of 2015 to work. The new registration period now applies till the end of 2025.

 

PFC driver version 2.41 for FS9 and earlier PFC 2.41
(ZIP includes documentation)

 

FOR FSX, FSX-SE and Prepar3D

Install complete FSUIPC version 4.972 Install FSUIPC4.972 for FSX, FSX-SE and Prepar3D versions 2.5, 3.0 - 3.4 (32-bit only: all versions to date of release)
Changes since 4.96 are now included in the History document in the FSUIPC Documents folder supplemented by the Changes document in the ZIP.

 

FOR Prepar3D 4 (64-bit)

Install complete FSUIPC version 5.122 Install FSUIPC5.122
This is the 64-bit equivalent to 4.972 above, but it remains an ongoing development. Please see the History document installed for you in the FSUIPC Documents folder for details of the changes since the very first release, 5.10, two months ago plus, for the changes since 5.11 document within the ZIP itself.
IMPORTANT: 5.122 and later versions are only suitable for use with P3D version 4.1 and later!  They will not work correctly with version 4.0.

 

PFCFSX driver for FSX, FSX-SE and P3D, and
PFCcom64 driver for P3D version 4

PFCFSX+PFCcom64
-- minor updates for FSX
-- 64-bit version for use with P3D 4 included

 

FOR ANY FS or its DERIVATIVES (but use on FS2002 and before not supportable)

WideFS version 6.999z4 WideFS 6.999z4
(Note, the WideServer.DLL module is ONLY used on FS9 and before)
Full release including documentation.
-- signature removed
-- See WideClient changes below.

WideClient 6.999z4 WideClient 6.999z4
-- 6.999x adds "ReconnectMinutes", a facility to automatically reconnect periodically.
-- 6.999y fixes a bug in event.offset for strings which now truncates the string length to <= 256
-- 6.999z2 adds Lua global sharing over network (with FSUIPC 4.958 or later)
-- 6.999z3 adds more facilities to the Lua "wnd" library - title, show and hide. (See latest Lua docs)

PFC HID device driver for FS9, FSX, FSX-SE and P3D PFCHID
includes PFChid.DLL for 32-bit sims, and PFChid64.dll for P3D4.

 

Pete Dowson 17th November 2017

 

  • Upvote 1

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×