Jump to content
The simFlight Network Forums


  • Content count

  • Joined

  • Last visited

Community Reputation

0 Neutral

About rkmyers

  • Rank

Profile Information

  • Gender
  • Location
    United Kingdom
  1. Pete, Thanks for your assistance, indeed my controllers and their associated IDs had changed. Putting these back as they were (taken from a regular backup) fixed all my issues. I will look at changing to Joy Letters! As for your question about 'Mode3' on that particular controller. The Saitek Pro Flight Yoke has a scroll wheel on the back on the yoke, which if you use the default software that comes with the controller effectively allows you to program three sets of key assignments to each button. Moving the mode scroll wheel allows you to switch between the various assignments. As you say, FSUIPC knows nothing of this scroll wheel or the modes associated with the controller but I didn't know that until the time of writing the comment. I have subsequently found this article (https://www.avsim.com/forums/topic/477157-saitek-yoke-mode-1-2-3-switch-fsuipc-newbie/) which described how you can edit the ini files to make use of this feature of the Saitek Yoke. Your help as always is much appreciated.
  2. So having done a bit more head scratching. I've taken a copy of FSUIPC4.ini and fired up FSX. Opened the FSUIPC GUI and selected the 'Profile Specific' checkbox. Observed that the profile I would expect is displayed in the title bar. Assigned 'Shift+2' to Button 15 in mode3 of my Pro Flight Yoke. Gracefully exited FSX and taken another copy of the FSUIPC.ini file for comparison. The hope was to compare, what I thought I could see assigned in the .ini file and what the GUI was assigning. I have a screenshot of the files in Notepad++ compare but the forum won't allow me to upload any more images :-( I'll try and describe what I see: 26=P3,15,K50,9 -{Key press: shft+2}- 27=P3,14,K51,9 -{Key press: shft+3}- 28=P3,17,K55,9 -{Key press: shft+7}- 29=P3,16,K52,9 -{Key press: shft+4}- 30=P0,15,K50,9 -{Key press: shft+2}- So, lines 26 to 29 are the same in both the before and after . ini files. Line 30 gets added by my assignment in game using the GUI and is only present in the after .ini file. If I've read line 30 correctly, the controller has changed? Here are my joystick assignments... [JoyNames] AutoAssignLetters=No 0=Saitek Pro Flight Yoke 0.GUID={A3887730-8C9A-11E5-8001-444553540000} 2=Joystick - HOTAS Warthog 2.GUID={BF4BD590-98DD-11E4-8008-444553540000} 1=Saitek Pro Flight Rudder Pedals 1.GUID={BF4B3950-98DD-11E4-8004-444553540000} 3=Throttle - HOTAS Warthog 3.GUID={BF4B1240-98DD-11E4-8003-444553540000} So, does that mean the ID numbers of my controllers have changed somehow? Would manually changing the controller assignments in the ini file under the '[Buttons.Piper Cherokee 180]' section fix the issue? Thanks again. PS. The error I get when trying to upload a screenshot is 'There was a problem processing the uploaded file. Please contact us for assistance.' The file was a .png, 73Kb. I also tried a .jpg, 128Kb
  3. Hi Pete, I've paid for and updated to the latest ver of EzDok. I was using the latest ver of FSUIPC but I think the crash must have occurred before the reinstall. I am now using the latest ver (Screenshot attached). You mention a corrupted ini. How could I establish if that's the case and if it were corrupted, what's the best way of repairing/replacing it? To answer your other question, the controls in question didn't stop working mid-flight. Over night with the PC being shut down and started in between. Would the ini file help? Thanks.
  4. Hi Pete, Thank you for your response. I don’t have the useProfile=Files flag set so my profiles are indeed stored in my FSUIPC4.ini file. The term ‘lost’ was a poor choice. I mean that FSUIPC appears to have my desired axis and button assignments for my selected aircraft and profile in the ini file but that isn’t translated to a response from the aircraft in SIM when certain axis’s and buttons are activated. The GUI appears to recognise the button or axis but has no assigned action. I though having used the following download link http://fsuipc.simflight.com/beta/FSUIPC4.zip I would have been getting the latest version but since you mention the latest version number, I can clearly see I’m on an old version. I’ll get the latest and report back as the next step. The if I still have issues, I’ll work on updating or removing EZDok. Thank you again for your support.
  5. Dear Pete, I have a registered copy of FSUIPC which I've been enjoying for some time. Yesterday I flew the A2A Piper Cherokee 180 in the latest ver of FSX SE with no issue. Tonight, some of my control assignments are not working. Let me elaborate. As a matter of course, I disable FSX controllers and use FSUIPC for direct axis assignment, buttons, macros etc. When I say 'some' assignments aren't working, an example would be: Throttle assigned direct axis through FSUIPC - Black Lever of a Saitek Pro Flight Yoke - worked before this problem started happening - worked after the problem started happening Mixture assigned direct axis through FSUIPC - Red Lever of a Saitek Pro Flight Yoke - worked before this problem started happening - suddenly FSUIPC GUI doesn't report this axis as assigned and the control does not respond in flight. Open Panel (Shift + 2) Assigned to button #15 of a Saitek Pro Flight Yoke - worked before the problem started happening - suddenly FSUIPC GUI doesn't report this button as assigned and the button has no affect in flight. So from my originally assigned controls, some still work, some don't. The steps I took to solve the issue were: Close FSX SE Inspect the FSUIPC4.ini, looking in the profile section, for the aircraft I was flying to see that the assignments I would expect, are there. In loading FSX SE back up again, it took longer than usual to load and chucked an error (below). My options were to continue loading FSX without FSUIPC or to continue. I chose continue and the FSX Fatal Error: Faulting application name: fsx.exe, version: 10.0.62615.0, time stamp: 0x559f9a9a Faulting module name: FSUIPC4.dll, version:, time stamp: 0x58933f1b Exception code: 0xc0000005 Fault offset: 0x0001f145 Faulting process id: 0x1f8c Faulting application start time: 0x01d3b65e79e37e81 Faulting application path: C:\Program Files (x86)\Steam\steamapps\common\FSX\fsx.exe Faulting module path: C:\Program Files (x86)\Steam\steamapps\common\FSX\Modules\FSUIPC4.dll Report Id: d6aefcec-2251-11e8-82ae-2cd05a9207f2 Faulting package full name: Faulting package-relative application ID: I then couldn't start FSX SE from then on without FSUIPC crashing. So I downloaded a fresh installer, and reinstalled FSUIPC and ensured, it was registered. Since, it's been okay in so far as it loads again without issue and no more errors. I still have the problem with the assigned controls on the PA-28. I then edited the FSUIPC4.ini file to remove the association of the specific PA-28 I fly from the profile. Specifically, I removed the last line in the code below: [Profile.Piper Cherokee 180] 1=Piper Cherokee 180 2=Piper Pa-28-180 Cherokee 5 For reference, from the aircraft CFG, I fly G-KELS [fltsim.5] title=Piper Pa-28-180 Cherokee 5 sim=PA28_180 model= panel= sound= texture=white-grey kb_checklists= kb_reference= atc_id=G-KELS ui_manufacturer="A2A Piper" ui_type="PA28-180 Cherokee" ui_variation="White-Grey" ui_typerole="Single Engine Prop" ui_createdby="A2A Simulations Inc." Any idea what would be preventing the axis and button assignments that I see in my FSUIPC4.ini file from being available (ie working) in FSX? I should also note other addons I have that may or may not be having an affect. I use EzDok (EZCA.exe), an older version because believe it or not, I found it to me the most stable but it does fill up my error logs, for a pastime. One of many examples: Faulting application name: EZCA.exe, version:, time stamp: 0x2a425e19 Faulting module name: unknown, version:, time stamp: 0x00000000 Exception code: 0xc0000005 Fault offset: 0xff300000 Faulting process id: 0x1e74 Faulting application start time: 0x01d3b65e84452a69 Faulting application path: C:\Program Files (x86)\EZCA\EZCA.exe Faulting module path: unknown Report Id: c32c6c8c-2251-11e8-82ae-2cd05a9207f2 Faulting package full name: Faulting package-relative application ID: Thanks, PS. I read through your 'read this before posting a support question post' and hope I have sufficiently explained the issue and provided detail where possible. Also hope it's not something really daft :-0