Jump to content
The simFlight Network Forums

cellular55

Members
  • Content Count

    200
  • Joined

  • Last visited

Everything posted by cellular55

  1. Hi, I'm trying to use the VRInsight CDU Device with FSUIPC to set values of some offsets (i.e 66EA set to 1). For that I have followed the instructions in the advanced manual using VSPE. Even if seems that everything is OK and I see the joystick buttons enumerated in the FSUIPC interface, the value of the offset is not changing. Below the log entries that I think could be useful : VRI port 1 "COM6" opened (this is the port appearing in the VR software: VRI or SerialPF2) 1435 VRI driver port 1 "COM3" also opened (this is the port part of the pair in VSPE: COM2, COM3) ..... ...... 171195 VRI COM6 <--- CMDRST [to Device] 171398 VRI COM6 <--- CMDCON [to Device] 171429 VRI COM3 <--- CMDCON [to VRI Driver] 171585 VRI COM6 <--- CMDFUN [to Device] 171601 VRI CDU ("CDU") detected on port COM6 171601 VRI COM3 <--- CMDCDU [to VRI Driver] 171803 VRI COM6 <--- CMDVER [to Device] 171850 VRI COM3 <--- CMD2.520 [to VRI Driver] 189432 WRITE0[4616] 330A, 2 bytes: D2 07 .. 192942 Deactivated for PID=2072, "explorer.exe" 197668 ### Mode is NORMAL ... .... 206202 VRI command CDUR4C0 trapped as Joy 266 Btn 3 Toggle ( device button clicked to try to set to 1 the offset 66EA) 229571 VRI command CDUR4C0 trapped as Joy 266 Btn 3 Toggle 230148 VRI command CDUR4C0 trapped as Joy 266 Btn 3 Toggle 230694 VRI command CDUR4C0 trapped as Joy 266 Btn 3 Toggle 231131 VRI command CDUR4C0 trapped as Joy 266 Btn 3 Toggle 231567 VRI command CDUR4C0 trapped as Joy 266 Btn 3 Toggle What am I missing or eventually is not possible to address offsets valus in this way? Thanks and Kind Regards Joe
  2. Hi Pete, sorry to have bothered you for a stupid my mistake: I was forgetting that I had already programmed those buttons in the FSUIPC profile for my PMDG737. It is evident that the profile was utilised and the new general asignment was not considered. Sorry again and kind regards Joe
  3. Hi, attached another log where appears more clear that the button is intercepted but is still executing the original PMDG control for the L1 button of the CDU instead the change of the ofset that I have forced in FSUIPC. FSUIPC5.log
  4. Hi Pete, Correct. What I have done: I have created on VSPE the pair COM2 - COM3 After the launch of P3D I have launched the VRSIM (and also tried launching the old SerialPF2). The CDU device appears on COM6. i activate the VRInsight driver (With the VRInsight profile keymap of the loaded aircraft) In FSUIPC i click the button I want to be assigned to set the offset 66EA to 1 and define the assignment like I do normally buttons on other devices. I do not know if this is important, but the joystick name and number button are shown in FSUIPC only when I activate the function FMC/CDU on the VRInsight device (clicking on the EXEC button of the device) After that when I click the button the screen of the VRINsight device changes but the offset is still at 0. As asked attached the log Thanks for the support Joe FSUIPC.log
  5. Hi, loading a flight plan I am able to see my user flight in the board for the departure, but not at arrival airport. Is there a way to solve the issue? Thanks and KR Joe
  6. cellular55

    No arrival for user aircraft

    Hi, I did the test: with that aircraft the flight number is OK, so it seems that the issue is related to PMDG. KR Joe
  7. cellular55

    No arrival for user aircraft

    Hi, thanks again for the prompt support. Attached the trace.. flight number is still 0 despite it is set in the aircraft.cfg. KR Joe STBClient.Trace.txt
  8. cellular55

    No arrival for user aircraft

    Hi, sorry for the delay.. attached the aicraft.cfg related the aircraft I use. KR Joe aircraft.cfg
  9. cellular55

    No arrival for user aircraft

    Hi, happy to inform that after the beta installation the issue has been solved!!! Now I see the flight at departure and arrival airports! Thanks a lot for the great support. By the way the minor issue related the flight number (displayed as LH0) is still present: is there a way to solve it?... by the way not so important. KR Joe
  10. cellular55

    No arrival for user aircraft

    Hi, thanks a lot... I will do in the week-end and let you know the results. KR Joe
  11. cellular55

    No arrival for user aircraft

    Hi, attached the flightplan KR Joe LICR Reggio Calabria - LIRZ Perugia.pln
  12. cellular55

    No arrival for user aircraft

    Hi, thanks for the prompt reply. To answer your questions: 1. STB 4.2.2018.20200 on P3D 4.4 (but was the same also with P3D 4.3). 2. All airports seem to be affected ( I cannot send a screen capture before the end of the week.. but I see my user flight at the departure airport with the right destination and parking gate info, but nothing (no row) at the arrival airport). Another minor issue (but may be significant?) is that at departure the only missing info is the flight number (displayed as 'LH0') even if I have set it in the aircraft.cfg (as 'LH955'). 3. Below an example of a flight plan I loaded: <?xml version="1.0" encoding="Windows-1252"?><SimBase.Document Type="AceXML" version="1,0"> <Descr>AceXML Document</Descr> <FlightPlan.FlightPlan> <Title>LICR Reggio Calabria - LIRZ Perugia</Title> <FPType>IFR</FPType> <RouteType>HighAlt</RouteType> <CruisingAlt>32000</CruisingAlt> <DepartureID>LICR</DepartureID> <DepartureLLA>N38° 4' 31.00", E15° 39' 21.00", +000095.50</DepartureLLA> <DestinationID>LIRZ</DestinationID> <DestinationLLA>N43° 5' 84.00", E12° 30' 60.00", +000692.50</DestinationLLA> <Descr>LICR, LIRZ</Descr> <DeparturePosition></DeparturePosition> <DepartureName>Reggio Calabria</DepartureName> <DestinationName>San Egidio</DestinationName> <AppVersion> <AppVersionMajor>10</AppVersionMajor> <AppVersionBuild>61472</AppVersionBuild> </AppVersion> <ATCWaypoint id="LICR"> <ATCWaypointType>Airport</ATCWaypointType> <WorldPosition>N38° 4' 31.00", E15° 39' 21.00", +000095.50</WorldPosition> <ICAO> <ICAOIdent>LICR</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="PIGER"> <ATCWaypointType>Intersection</ATCWaypointType> <WorldPosition>N38° 32' 80.00",E15° 24' 40.00",+010500.00</WorldPosition> <Descr>PIGER</Descr> <ICAO> <ICAOIdent>PIGER</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="AGNIS"> <ATCWaypointType>Intersection</ATCWaypointType> <WorldPosition>N39° 48' 40.00",E14° 45' 00.00",+034000.00</WorldPosition> <Descr>AGNIS</Descr> <ICAO> <ICAOIdent>AGNIS</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="SOR"> <ATCWaypointType>Intersection</ATCWaypointType> <WorldPosition>N40° 34' 95.00",E14° 20' 10.00",+034000.00</WorldPosition> <Descr>SOR</Descr> <ICAO> <ICAOIdent>SOR</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="TEA"> <ATCWaypointType>Intersection</ATCWaypointType> <WorldPosition>N41° 17' 80.00",E13° 58' 23.00",+034000.00</WorldPosition> <Descr>TEA</Descr> <ICAO> <ICAOIdent>TEA</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="VELIM"> <ATCWaypointType>Intersection</ATCWaypointType> <WorldPosition>N42° 8' 53.00",E13° 15' 91.00",+021000.00</WorldPosition> <Descr>VELIM</Descr> <ICAO> <ICAOIdent>VELIM</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="PRU"> <ATCWaypointType>Intersection</ATCWaypointType> <WorldPosition>N43° 6' 10.00",E12° 30' 71.00",+001000.00</WorldPosition> <Descr>PRU</Descr> <ICAO> <ICAOIdent>PRU</ICAOIdent> </ICAO> </ATCWaypoint> <ATCWaypoint id="LIRZ"> <ATCWaypointType>Airport</ATCWaypointType> <WorldPosition>N43° 5' 84.00",E12° 30' 60.00",+000692.50</WorldPosition> <Descr>LIRZ</Descr> <ICAO> <ICAOIdent>LIRZ</ICAOIdent> </ICAO> </ATCWaypoint> </FlightPlan.FlightPlan> </SimBase.Document> Thanks again and KR Joe
  13. Hi Pete, I have some troubles with my multiple USB devices. When some of them loose the connection from the PC or if I add a new device, my FSUIPC.INI becomes a mess in the sense that several commands move from a device to another (i.e. commands assigned to device F move to E and viceversa). It seems that fo some reason the letters assigned and stored in FSUIPC.INI go messed. In these cases I have everytime to manually change the assigned commands to reset them to the orign assignement I gave them on the proper device and switch. I do not understand what I do or I have done wrong in my settings to have this result. Is there a way, eventually adding some parameters to FSUIPC.INI, to avoid that? Thanks and Kind Regards Joe
  14. Hi Pete, yes.. all the HUBs are powered. I think taht is a problem of some connector entries: more or less the devices going disconnected are the same. Unplagging and repulugging they get back the connection. and yes .. you are right: I do not know how Windows manages that, but I have noticed that If I add a new device (even if not related to P3D) and I change the HUB connector entry of one P3D device the GUIDs change (I did that adding those lights). KR Joe
  15. Hi Pete, I will try to explain a little more and in detail. The devices are identical in the sense that the issue occurrs always on the devices on the USB HUBs. No problem with the joke, rudder pedals and the two serial devices (MCP and CDU). Issue1: Device disconnected If I launch P3D no checking before if all the devices installed on different USB HUBs are connected and one of them is disconnected (may be the connectors on hubs are not so good) I do not have only the command disappearing on the disconnected devices, but its commands move on another device connected on another Hub substituting the original assignment. In this case I have found that is enough to close P3D and relaunch it being sure that all the connections are ok (I have written a tool to check that) and everything is back to nornal. Issue 2: Adding new connection on HUB This is an issue stranger and harder as the only solution I have found until now is to manually reassign the commands on the impacted devices as they were before. This occurred for example when I added, through one existing HUB, some LED lights to illuminate the cockpit devices: after that, commands on two devices (one on the same HUB where I installed the light and another on a differen HUB) were swapped. Hope this helps to clarify. KR Joe P.S. Yes.. I disconnected the Cessna wheel and did not update the conf file
  16. Hi Pete, attached my FSUIPC.INI file. I have also attached th INI related the PMDG profile that I normally use as aircraft. KR Joe fsuipc5.ini PMDG.ini
  17. Hi Pete, sorry I misunderstood you: I was meaning that are identical in term of type of devices, but of course in the ini file they have different GUI and Name. The problem occurs when one of them lose the connection from the hub or/and in case I add other devices. I would that in case of disconnection the assigned commands are not moved on other device, but only appearing as not available and that when I add a new device the already existing devices do not have the name/assignments changed with others. KR Joe
  18. Hi, yes .. the effected devices are identical (VRInsight Toggle and Tact Switch Panel). KR Joe
  19. cellular55

    Issue with auto airport

    Hi, I have selected the auto airport option to have the board related the airport where I'm located. Since today that is not properly running. moreover if I manually select the airport (writing the related ICAO) the data appears only for few seconds and the drop down list of airports is empty. Is there a possoble reason for that and a solution Thanks and best regards Joe
  20. Hi, I have just installed the last version to use it (in networked configuration) with Traffic Global, but the client is unable to connect to P3D4.2. The server is correctly connected to P3D, but when I click Connect on the client I get the message: 'Unabel to connect t P3D v4. Please make sure a flight has completed loafing before trying again to connect. Could you please support on how to solve the issue? Thanks and best regards Joe
  21. cellular55

    Issue with last update and Traffic Global

    Hi, sorry... it was my mistake (Dumb !). I forgot to change the port in the simconnect.cfg file. Everything k after that Thanks and KR Joe
  22. Hi Sabrefly, not so easy: my app is a compiled VB application that I use to manage my cockpit and my personal ATC flight guidance. It can run in right way only with my specific configurations and configuring in FSUIPC some special free offsets that manage different devices and switches. One of the many functions I have developed there, is the monitoring of the FPS. By the way nothing really special for that specific function: I read and show the offset 274 in VB: Call FSUIPC_Read1(&H274, 2, VarPtr(FPS), dwresult1) Call FSUIPC_Process1(dwresult1) Let me know if you want that I do for you an 'extract' of my app to only calculate,, following the VB method, the FPS. KR Joe
  23. Hi, I show the FPS through a networked app I wrote that uses Wideclient 7.14a and FSUIPC 5.124a on P3D 4.2 with the option UsePDK=Yes. I can confirm that the FPS shown are correct. KR Joe
  24. Hi Peter, I would know if with FSUIPC5 (ver 5.122a) there are limitations for the use of the 'event.textmenu' in LUA scripts. In fact I definitevely moved from FSX to P3Dv41, but a lua using that instruction (to have HIfi AS and GSX messages shown through Widefs to another PC and not in the simulator) correctly running in FSX is no more running in P3D (the messages are shown in the simulator and not intercepted by the LUA). I have in my FSUIPC.ini the line NewInterceptTextMenu=Yes and the log related the LUA under Widefs is only reporting that the LUA is normally launched and running. Thanks in advance and Kind regards Joe
  25. cellular55

    LUA with event.textmenu in P3D41

    Great! So something is moving.. I will wait for the new version. Thanks and kind regards Joe
×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.