Jump to content
The simFlight Network Forums

Keyboard keys not recognized

Recommended Posts


I have a problem communicating with RCV4.

I have made logs from FSUIPC4 and RCV4.

I only entered the keys for RCV4 excluding all other key stokes except for the last test.

My problem:

Test 1:

I started a flight with FSX. After loading the FP in both FSX and RC I started the flight procedures.

In the first test I entered 2 then 4 then7; 1; 1;3. Everything went smoothly with RC.

Then I entered 1 again. No response. I entered it 2 more times. No answer. I stopped the test

First RCV4 log shows no final 1 key pressed. The last one was 3.

To my surprise FSUIPC log also shows that the last key stroke was 3. No key stroke 1 appears.


Same routine to start. This time only 2 key strokes were recognized: 2 & 4.

Then 7: radio silence. No more key strokes answered to.

At this moment I pressed Q (nothing related to RC) to mute the FSX. O.K. I press again Q to resume the sound: O.K.

But the FSUIPC log doesn't show the Q stroke nor of course the last #7 stroke.

Conclusion: FSX recognize the strokes but for one reason or another it is not passed to FSUIPC.

Can you help me ?

Here are the specs of the PC:

Antec P182A case, OCZ GameXtreme 700W PSU, Abit AW9D-Maw mother board, Intel Core 2 E6750/2.66GHz processor,

Corsair 2Gb-800 DDR2 PC-6400 Dominator memory, 2x250GB WD Caviar SATA Hard Disk (RAID 0), EVGA e-GeForce 8800 GTS 640 MB,

DVD R/W NEC Sony AD7173A, Samsung 931BF 19" 2ms monitor, WD e-SATA external HD, Windows XP Professional.

XP, FSX are English soft.

My keyboards are AZERTY french belgium defined as such in XP while the rest is english. This worked before with XP non prof and FS9 and all previous FS and Windows.

One KB is wireless Logitech and the other a DELL wired KB.

My last tests are done with the DELL KB but the Logitech gives the same results.

FSX and RC are both on the same PC. FSUIPC is version 4.20 from October 23rd 2007. (registered version)

Wide FS is downloaded but not installed nor used.

No other active addons used. Only FSgenesis, Ultimate terrrain, Scenery Tech.

I can send you the logs if you want. Just give me an address where they can be sent.

Roger Potie

Link to comment
Share on other sites


More info:

I have already noticed that when I press Alt or Alt-Enter it MAY unblock the situation. In fact what seems to unblock at each attempt is by going to View, Panel Instruments and choose a panel. In my case itis the Groundhandling. Now before anybody accuses the freeware Groundhandling, I did have the same problem before implementing this module.

Not being an expert with FSUIPC or FSX, I cannot understand why moving in or out a panel on the screen can change the acceptance of a code ofrom the KB, especially that I move the panel without touching the KB.


Link to comment
Share on other sites


Problem solved.

I fly FSX using 2 monitors. On monitor 1 is used for FSX main window (cockpit). On monitor 2 I put the radio stack and GPS.

If my last action was with a click in GPS or Radio stack, then pressing one of the keys for RC was not intercepted. If I click anywhere on monitor 1 then FSUIPC intercepts the keystroke and sends it to RC. This is what jd calls the focused window.

I never experienced this with FS9.

Well everything is O.K. for me now.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.