Jump to content
The simFlight Network Forums

GOFLIGHT -->FSUIPC-->FLIGHT1 MD80 SUPER PRO


KAPTEJNLN
 Share

Recommended Posts

Latest update scrol down 13/12-2010:

HELLO FELLOW PILOTS now i have found what we have been looking fore. As i have found a way to get goflight mcp to comunicate whit MD80. I have still not found a better way to get the same funktion on the altitude but if you do right the default mcp comando would over wride md80 and climb to 8000 ft shown on the goflight device. and not to the vaulv shown in the add-on. but here is what to do to get heading working:

step 1: Go to your goflight config as normaly and turn of hdg knob and hdg hold button ( No Assignment ) and save it.

step 2: Start FS and select MD80 at your choice just take the one you fly often.

step 3: When fs is running go to fsuipc and find logging and enabel the following and i know not all is requierede but do so acording to manual. set Buttons and key operations, events (non-axis controls), LUA program logging

step 4: go in fsuipc to buttons + switches select, then select Create Mouse Macro give it a name i would say as my is AA-MD80 AND SAY OK AND OK AGAIN TO GET OUT OF FSUIPC. I say AA becaus then you are don whit creating macro you would find your comands if you scrol the hole way down it is easy.

step 5: open mcp by pressing shift 5 as default then pres on the knob + only 1 time give it the name hdg+ then hold down the button and stop whent the text box is whit as you would se it would changes white, red, whit, red set it to hdg++ and the same way whit -

Step 6: Then finished the rotation buttons go down to the black button locatet right under the heading display (the knob) and pres it you would se it moves then give it the name like hdg hold as you then know what it is to go to FSUIPC again and to buttons + switches select and say End macro.

step 7: Now rotate the goflight hdg button slow only 1 time (1 degree) to right as + then it would display a joy and a btn for the knob then set Aircraft specific? rotate again if it dosent display it anymore and select for fs control.

step 8: then you should go to the control sent when button pressed and go scrool the hole way down and find the command look for AA-MD80:HDG+ and set it do it the same way down at when button released then it is done then rotate the goflight agan but fast then a new btn number should bee sen and set it to AA-MD80:hdg++ do the same on the minus and pres hdg hold button and set it the same way. then you are done press ok and it should work whit flight director on. It dosent show the same on goflight as in sim when f/d is off but set the hdg on ground and turn on f/d if goflight dosent show the same pres your hdg hold on the goflight and it then corect it and as long f/d is on goflight show the same as the md80 add-on autopilot :-) and wel to get more control of add-on mcp set more macro by your own choice.

!!UPDATET 18/03-10!! SO FAR USE THE DEFAULT ALTITUDE AS I HAV NOT FOUND A BETTER SOLUTION.

Best regards Lars

Link to comment
Share on other sites

  • 2 months later...
  • 6 months later...

UPdatet:

Have just tested and seems to work so here is the file for the comands i use to the SAS registration: LN-RLE. So now all you have to do is set goflight menu like picture 1 then start FS and following picture 2 from post above whit out end macro as that job have been done.

Just select the key/button/rotation on the goflight unit and find the comand in the drop down menu and then select it when it only shows the comand you want you can select another key by pressing it and then check "Select for FS crontrol" it normaly turns off when selecting anoter key so remember to turn it on again manualy. when all keys is set just press ok and you are ready to fly.

Just remember you have to do this for all the md 80 planes you use. it is posible to do the comands 1 time so it work to all of them but effcts all other planes therfor, not a good thing.

If yo get problems check this first:

importan remember to have the latest version of FSUIPC and goflight drivers.

If FSUIPC dont read when you try use a button or so go to gofligh folder and copy the: GFDev.dll and place it in the modul folder.

Have a nice flight..

MD80_macro.zip

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.