Jump to content
The simFlight Network Forums
Sign in to follow this  
Lude2Envy

Addon Menu

Recommended Posts

I know this isn't the appropriate forum for this question, but since support for the Leonardo-SH Maddog no longer exists, I was hoping to find some help here. I have FSX installed on my main PC and I run my apps from a client PC through Simconnect, WideFS, etc. with no problems. I just installed a copy of FSX on my client PC because I want to try to run the LSH Maddog in a Multi-Crew setup. Everything seems to be fine, except the Maddog menu under the Addon menu isn't there. The LeonardoSH.dll is in the modules folder, it's listed correctly in the DLL.XML file along with FSUIPC 4, and my Simconnect log says that it loads ok. I have tried everything I can find on the internet to fix this problem with no luck. The RTM, SP1, and Acceleration SDKs are installed on both computers. The Simconnect.msi's have been installed. Everything is set to run as administrator (and was installed as administrator). All folders are excluded from my AV software. I'm totally lost here. It runs fine on my main FSX PC, just not on the client. I've included the 2 files to this post.

 

On a side note, I had this same problem last night (I uninstalled/reinstalled everything today). Last night, I installed one of my FSDT sceneries to see if the addon manager would work. It showed up in the Addon menu initially, but on the 2nd load of FSX, it disappeared from the Addon menu and the scenery was no longer showing in FSX - despite being checked in the Scenery Library. After that I started to get "can't init simconnect error" while trying to load FSX. 

 

The only thing I can think of is that there's an issue because I already had the client set up to run ASN through Simconnect to my main FSX PC. I don't understand how it could affect it though since the client computer only has the SimConnect.cfg file in the My Documents folder for ASN. Despite all of these issues, the FSUIPC menu HAS consistently been available in the Addon menu and working on the client PC the entire time. I'm totally at a loss as to why FSUIPC works while the FSDT Addon manager and LeonardoSH.dll have not. If anyone, or Pete, can assist me with this I'll greatly appreciate it. Thanks!

 

- Ian 

SimConnect.zip

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.