Jump to content
The simFlight Network Forums

Trouble assigning keys to GPS

Recommended Posts


   I am currently running Prepar3D v3 (latest version), with FSUIPC4. I am trying to assign the keys on my Emuteq GNS530 to the simulator through the FSUIPC4.INI file. The issue is that after I write my changes in the file and save it, it gets re-written by Prepar3d when I load the program. I am currently using the configurations on this forum http://www.avsim.com/topic/450753-fsuipc-settings-for-mindstar-gns-530-in-p3d-23/ to get the GPS to work like I want it to. However, the INI file is not keeping my configuration, so the button assignments are not doing anything. I have tried both enabling and disabling the default controller settings within P3D, and there is no effect. I have also tried assigning the keys in FSUIPC within P3D, and that is also doing nothing. I know FSUIPC is seeing the buttons, as I can assign, for example, the enter key on the GPS to act as the enter key in P3D, but nothing happens. Every time I open the FSUIPC4.INI file, it looks like it has reverted to defaults. Anyone know how to resolve this? 



EDIT: [RESOLVED]-- I forgot to set the controller number in the INI file. 

Edited by FlyHAA
Found solution
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.