Jump to content
The simFlight Network Forums

Writing negative values to LVar


Recommended Posts



I seem to be unable to set LVars to negative values, via FsLVar from MSFSVariableServices.LVars.


 One specific example is Fenix A320 lvar for VS knob: ‘S_FCU_VERTICAL_SPEED’. 

When the VS knob is pushed in the S_FCU_VERTICAL_SPEED is decremented by -1, pulled it is increased by +1.

The logic in the plane is when the variable is decremented by one, the plane execute the “push” logic, or “pull” logic when incremented by one.

 It works great when the numbers are in positive range. I can use _my_fsLvar.SetValue(_my_fsLvar.value +/- 1) to replicate pull/push.

If the numbers get into negative numbers I can only read the value, not longer set it.
I get the same behaviour/issues using the “MSFSVariableServices Example Code” application. Monitoring the LVAr shows Fenix aircraft start with a value of 0 and have no problem operating in positive or negative range. 

Anyone have any idea where the problem is. I suspect it is located somewhere between my monitor and chair as usual 😁

Link to comment
Share on other sites


I can't see anything in the MSFSVariableServices code that would prevent writing negative values.

First, please make sure you have all the latest versions: 

  • FSUIPC 7.3.11
  • WAPIID dll 0.9.0
  • My dll 3.2.21

The first two can be found at fsuipc.com

If it still doesn't work please try the following:

In the "FSUIPC WASM Module 0.9.0 + WAPI 0.9.0" package (fsuipc.com), find the WASMClient.exe and run it. Try using that program to write your negative values.

If that works then the problem is with my DLL. Let me know and I'll investigate further.

If it doesn't work in that program then it's not my DLL. You'll need to ask John about it in the FSUIPC7 (MSFS) support forum. Let him know you've tried it with the WASMClient.exe.


Link to comment
Share on other sites

I did have older versions, upgraded and tried again but with the same results.

Also tried via the WASMClient.exe. Same results, so it is not your DLL:-)

I’ll do as you suggested and check in the fsuip7 (msfs) forum.


  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.