Jump to content


Photo

FSUIPC interface problem with ACS MD-11 panel


  • Please log in to reply
7 replies to this topic

#1 lowery

lowery

    Newbie

  • Members
  • Pip
  • 4 posts
  • LocationAustralia

Posted 13 January 2005 - 02:21 AM

Hello Peter,

I sent the following to Alain Capt and append below the reply.

Dear Alain Capt,

I am sorry to disturb you but ask in desperation for your help.

I had update 248 of your MD-11 panel working very well with Fs9 (version
9.0.0.30612 of the gps dlls) and FSUIPC 3.40. Everything, including the
"map vector graphic" gauge, the TCAS and the WX Radar, worked perfectly.

Then I upgraded to Fs9.1 (version 9.1.0.40901 of the gps dlls) and FSUIPC
3.44 and found that the "map vector graphics", TCAS and WX Radar no longer worked.

I uninstalled everything and then re-installed following exactly the
instructions that came with "ACSMD11panel_247.zip" and
"ACSMD11panel_U_251.zip". I used your "Install.exe" to assign the panel to my "iFDG_MD11_Alitalia" aircraft and all appeared to install correctly.

However, the "map vector graphic" gauge, TCAS and WX Radar will still not work.

Have I not followed instructions correctly? Is there something I am doing
wrong?

I would be very thankful for any help you can give.


Dear Roger,

From what you describe in your message, I see no fault you would have done.

An important information for you: versions 2.47 to 2.51 are all 100%
compatible with FS9.1. I do test all these versions. Same with the last
version of FSUIPC 3.44 which I also tested recently. So you can be sure it
SHOULD work.

From what you say, it seem that FSUIPC key auto-registration or even
probably, all communications with this module and my gauge are not working properly on your system for an unknow reason. The auto-registration with FSUIPC is in my gauge "ACS.Zulu-MD11.gau" and the key is "EHTMOBYEXWXI". On this matter, maybe you will found more informations in the file "Module\FSUIPC.log". You may also seek for help on the FSUIPC forum.

Apparently you are not the first to experience such communication problems with FSUIPC, after a FS9.1 upgrade. Maybe on this forum you will found the solution.

Keep me informed, especially if you found the solution.

Regards,

Alain Capt

On receipt of this reply, I checked everything for correct version number, deleted FSUIPC, then re-installed and re-registered it. I still get no TCAS or WX information, nor can I transfere flight plans from my FSGarmin 530 to Fs9.1 aircraft.

Can you help?
  • 0

#2 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 26,468 posts
  • LocationNear Stoke-on-Trent, UK

Posted 13 January 2005 - 10:36 AM

From what you say, it seem that FSUIPC key auto-registration or even
probably, all communications with this module and my gauge are not working properly on your system for an unknow reason. The auto-registration with FSUIPC is in my gauge "ACS.Zulu-MD11.gau" and the key is "EHTMOBYEXWXI". On this matter, maybe you will found more informations in the file "Module\FSUIPC.log". You may also seek for help on the FSUIPC forum.
...
Can you help?


I assume you are using a free install of FSUIPC? i.e. you've not registered it?

Can you show me the Log file please? I need whatever information is included in the file, as Mr. Capt pointed out already.

Also please tell me if you are using Windows 98 or Windows XP, or what other?

Then, AFTER getting the Log for me, please, you can also try manually registering the gauge, before loading the aircraft. Do this by going to the FSUIPC options (Modules menu, FSUIPC), selecting the "Register an application program" button, then entering the details Mr. Capt gave you. i.e.

Program: ACS.Zulu-MD11.gau
Key: EHTM OBYE XWXI

You will only need to do this once, as it is remembered in your Key file.

If this works, and you are using Windows 98 or Windows Me, then it may be the same problem reported to me yesterday with another program entirely. I am working on this now. But I need to see the log, and know the version of Windows you are using, to be sure.

Thanks

Regards,

Pete
  • 0

#3 lowery

lowery

    Newbie

  • Members
  • Pip
  • 4 posts
  • LocationAustralia

Posted 13 January 2005 - 10:08 PM

Hello Peter,

I am amazed and very thankful for your prompt response to customer problems.

I am running WinXP SP2 with Fs9.1.

My FSUIPC v3.44 is fully registered; attached is the log file as requested. By my reading of this file, FSUIPC claims to recognize all the items that are not working.

After your initial reply, I completely removed FSUIPC and re-installed it as unregistered. I registered "ACS.Zulu-MD11.gau", restarted Fltsim and then re-registered FSUIPC. I'm afraid it didn't work and I still seem to be getting no interface betweem Fs9.1 and Fsuipc.

As before, I still can't transfere a flight plan from FSGarmin 530 to the gps system in Fs9.1.

BTW, I am having trouble adding the attachment. It tells me I can't attach "log" files or "txt" files. I'll keep trying. :cry:

No luck with the attachment so I'll add the log text here:

********* FSUIPC, Version 3.44 by Pete Dowson *********
Running inside FS2004 (FS9.1 CONTROLS.DLL, FS9.1 WEATHER.DLL)
User Name="Roger Lowery"
User Addr="lowery@pcug.org.au"
FSUIPC Key is provided
WIDEFS not user registered, or expired
Module base=61000000
ClassOptions: UIPCMAIN=FF7F, FS98MAIN=FF7F, FS2KMAIN=FF5E
WeatherOptions(Orig)=4800B681[4800B681]
InitDelay: 0 seconds
WeatherReadInterval=4
LogOptions=00000001
DebugStatus=15
3687 System time = 20:01:56
3687 E:\Simulators\FS2004\
3703 System time = 20:01:56, FS2004 time = 12:00:00 (00:00Z)
9422 C:\Documents and Settings\win\My Documents\Flight Simulator Files\B707 (John Trivolta) ready for take-off at Mascot.flt
9625 AIRCRAFT\Legendary_707\cs707.air
10625 Aircraft="CS Boeing 707 Paint20"
21750 Module [M1] identified = "fsflightmax.dll"
28547 C:\Documents and Settings\win\My Documents\Flight Simulator Files\MD-11 (Alitalia) ready for take-off at Mascot.flt
28719 AIRCRAFT\iFDG_MD11_Alitalia\MD-11_acs.air
29734 Aircraft="iFDG MD11 Alitalia"
33109 Clear All Weather requested: external weather discarded
36265 Module [M2] identified = "ACS.zulu-MD11.GAU"
36265 Module [M2] "ACS.Zulu-MD11.gau" access registration is okay
40984 Advanced Weather Interface Enabled
68906 Traffic File #43 = "addon scenery\raaf ai\scenery\traffic_raafai"
69609 Traffic File #40 = "addon scenery\aeropelican\scenery\trafficaeropel"
69906 Traffic File #36 = "addon scenery\sydney sea bases\scenery\trafficybwt"
70344 Traffic File #41 = "addon scenery\aeropelican\scenery\trafficypel"
70437 Traffic File #39 = "addon scenery\sydney sea bases\scenery\trafficyrsb"
70765 Traffic File #23 = "addon scenery\hoxton park\scenery\traffichox"
70859 Traffic File #26 = "addon scenery\tasmania\scenery\traffic_tassie"
70984 Traffic File #37 = "addon scenery\sydney sea bases\scenery\trafficygfd"
71172 Traffic File #14 = "scenery\world\scenery\traffic"
71781 Traffic File #15 = "scenery\world\scenery\traffic030528"
71906 Traffic File #38 = "addon scenery\sydney sea bases\scenery\trafficylgj"
72422 Traffic File #18 = "scenery\world\scenery\traffic_raafai"
155656 System time = 20:04:28, FS2004 time = 08:45:05 (22:45Z)
155656 *** FSUIPC log file being closed
Memory managed: 2 Allocs, 172 Freed
********* FSUIPC Log file closed ****


Thanks for your support, Roger
  • 0

#4 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 26,468 posts
  • LocationNear Stoke-on-Trent, UK

Posted 13 January 2005 - 11:56 PM

My FSUIPC v3.44 is fully registered.


Ah. I wish you'd said it was registered in the first place. With a correctly user-registered FSUIPC the Gauge registration is not relevant (it is bypassed -- though as an aid to developers FSUIPC still logs it as good or bad), so Mr Capt's reply was not actually at all relevant, unfortunately.

After your initial reply, I completely removed FSUIPC and re-installed it as unregistered. I registered "ACS.Zulu-MD11.gau", restarted Fltsim and then re-registered FSUIPC. I'm afraid it didn't work and I still seem to be getting no interface betweem Fs9.1 and Fsuipc.


Just as an experiment, try removing the FSUIPC.KEY file from the FS Modules folder and see if it then works. If so, then it sounds like there is something wrong with your user key (or FSUIPC's checks on it). In that case, please Zip up the FSUIPC.KEY file and send it to me at petedowson@btconnect.com and I'll work out what is happening.

If, however, it still does not work, then I'm afraid we are dependent upon Mr. Capt finding out what is going on, as the log shows that the interface is working perfectly correctly between the gauge and FSUIPC.

You could, also, enable IPC read and write logging (in the FSUIPC Logging page), which will show us the sort of interchange that is happening. But take care, the Log file could get very large.

As before, I still can't transfere a flight plan from FSGarmin 530 to the gps system in Fs9.1.


Hmmm. There's no interface for such things in FSUIPC in any case, so that is something else.

BTW, I am having trouble adding the attachment. It tells me I can't attach "log" files or "txt" files. I'll keep trying. :cry:



Maybe it will take ZIPs?

Regards,

Pete
  • 0

#5 lowery

lowery

    Newbie

  • Members
  • Pip
  • 4 posts
  • LocationAustralia

Posted 17 January 2005 - 05:24 AM

I tried your suggestion, Pete, but it still doesn't work.

I conclude that there is nothing wrong with my FSUIPC installation and that the problem lies with the "ACS.Zulu-MD11.gau".

I think I have gone as far as my expertise permits and I thank you sincerely for your time and advice.

Best wishes, Roger
  • 0

#6 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 26,468 posts
  • LocationNear Stoke-on-Trent, UK

Posted 17 January 2005 - 10:48 AM

I tried your suggestion, Pete, but it still doesn't work.

I conclude that there is nothing wrong with my FSUIPC installation and that the problem lies with the "ACS.Zulu-MD11.gau".

I think I have gone as far as my expertise permits and I thank you sincerely for your time and advice.


I hope Mr. Capt is able to help you!

Regards,

Pete
  • 0

#7 lowery

lowery

    Newbie

  • Members
  • Pip
  • 4 posts
  • LocationAustralia

Posted 24 January 2005 - 03:36 AM

Hello Peter,

Success! I found out how to get the FSGarmin 530 and MD-11 cockpit working again. Ater a week or so of swapping new DLLs for Old, etc, etc, I finally trashed my Fs9.cfg file and re-started Fs9.1. :)

Everything, TCAS, flight plan transferes, Wx, etc all now function correctly.

Hoverver, I can find nothing in the newly created cfg file that obviously corrects the problem. :?:

Thanks for your help,

Roger Lowery
  • 0

#8 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 26,468 posts
  • LocationNear Stoke-on-Trent, UK

Posted 24 January 2005 - 09:56 AM

Hoverver, I can find nothing in the newly created cfg file that obviously corrects the problem. :?:


Hmmm. There's a load of parameters in the CFG file that I haven't the foggiest idea about -- those concerning the graphics especially. Maybe some setting amongst those affected specifically the drawing in the types of gauges you were having problems with.

Regards,

Pete
  • 0




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


About simFlight - simflight.com - simflight.de - simflight.fr - simflight.nl - simflight.pt - simflight.es - simflight.it - simflight.jp - simrussia.com - simMarket