Jump to content


Photo

Enable Controller checkbox disable permanently


  • Please log in to reply
4 replies to this topic

#1 Barbs

Barbs

    Member

  • Members
  • PipPip
  • 15 posts

Posted 02 July 2013 - 12:07 AM

Hi guys,

Tried AVSIM with no luck. Does anyone here know how to ensure that the Enable Controller checkbox in the FSX menu is disabled (unchecked) and stays that way. I am finding that it is enabled randomly and I have to remember to uncheck it every time I load FSX otherwise it causes issues with my FSUIPC setup.

Is there a CFG tweak or something I can use? Anything?
  • 0
Greg

#2 Pete Dowson

Pete Dowson

    Advanced Member

  • Moderators
  • 27,105 posts
  • LocationNear Stoke-on-Trent, UK

Posted 02 July 2013 - 12:11 AM

Hi guys,

Tried AVSIM with no luck. Does anyone here know how to ensure that the Enable Controller checkbox in the FSX menu is disabled (unchecked) and stays that way. I am finding that it is enabled randomly and I have to remember to uncheck it every time I load FSX otherwise it causes issues with my FSUIPC setup.

Is there a CFG tweak or something I can use? Anything?

 

 

I've never heard of it becoming re-enabled by itself. I think it is morte likely that your FSX.CFG file isn't being updated when you close FSX. Perhaps FSX isn't closing correctly, but crashing instead?

 

Take a look in your FSX.CFG file. In the section called [CONTROLS] you should have

 

JOYSTICKS=0
 

 

If not just set it that way.

 

Pete


  • 0

#3 Barbs

Barbs

    Member

  • Members
  • PipPip
  • 15 posts

Posted 03 July 2013 - 11:52 PM

Hi Pete,

Ordinarily I would have thought the same thing. Nevertheless sometimes when loading FSX the checkbox would be unchecked from last time, yet another time I would load FSX and it would be Enabled.

The JOYSTICKS=0 wasn't there but I have added it as that's exactly the kind of thing I was looking for.. I'll report back whether the problem persists.
  • 0
Greg

#4 Barbs

Barbs

    Member

  • Members
  • PipPip
  • 15 posts

Posted 13 July 2013 - 07:01 AM

Just to report back.  Adding JOYSTICKS=0 doesn't appear to have worked. It would appear that whenever the controller configuration on the system changes (say I unplug a throttle to use the USB port or something) the next time I load up FSX, the controllers are enabled again.


  • 0
Greg

#5 English Rebel

English Rebel

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts
  • LocationTriad Area of North Carolina

Posted 14 July 2013 - 12:28 PM

Just to report back.  Adding JOYSTICKS=0 doesn't appear to have worked. It would appear that whenever the controller configuration on the system changes (say I unplug a throttle to use the USB port or something) the next time I load up FSX, the controllers are enabled again.

Greg

That's normal.  FS thinks it's a new device and enables the controls.  I have mine disabled and it's never been re-enabled.  Have you set your joystick numbering so that FS "remembers" them and doesn't think they are new devices?  Look at page 27 in the User Guide for information.

Alan


  • 0
MB ASUS P8Z68-V PRO Z68; GPU nVIDIA GTX 570 ; CPU INTEL i7 2600K 3.4; MEMORY MUSHKIN 8GB DDR3 1600 (PC3 12800) 7 LATENCY; ANTEC CPU WATER COOLER KUHLER H20 620; WD VELOCIRAPTOR 600GB; WIN7 HOME PREMIUM 64BIT
FSX with SP1 and SP2; ORBX PF, PNW, NRM, DARRINGTON MUNI.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users


About simFlight - simflight.com - simflight.de - simflight.fr - simflight.nl - simflight.pt - simflight.es - simflight.it - simflight.jp - simrussia.com - simMarket