Jump to content
The simFlight Network Forums

New to WideFS and connection problems


Recommended Posts

I've checked forum messages and read the manual with WideFS, but still stumped.

I've just set up a network (two computer, running Windows XP Home). Using FS9 on one computer and WideFS and AS2004 on other. Not sure if my problem is a WideFS one or AS2004 or both, so my apologies in advance. I don't think WideFS is connecting and I know AS2004 cannot connect to FS (it says so!).

Here is my log file:

********* WideClient.DLL Log [version 6.101] Class=FS98MAIN *********

Date (dmy): 16/01/04, Time 11:48:17.010: Client name is BASE

341 Attempting to connect now

361 Trying TCP/IP host "Base." ...

361Okay, IP Address = 192.168.0.100

1382 Error on client pre-Connection Select() [Error=10061] Connection refused

1392 Ready to try connection again

1412 Attempting to connect now

20259 Reception maximum achieved: 0 frames/sec, 0 bytes/sec

20259 Max receive buffer = 0, Max send depth = 0

20259 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

Any help is appreciated, and if more info needed I'd be pleased to provide it.

Cheers

Rod Mann

Link to comment
Share on other sites

361 Trying TCP/IP host "Base." ...

361Okay, IP Address = 192.168.0.100

1382 Error on client pre-Connection Select() [Error=10061] Connection refused

1392 Ready to try connection again

All I can say really is what it says there -- for some reason your Server PC is refusing to allow the Client to connect to it. Maybe you have a firewall blocking it? There's a firewall facility in WinXP, maybe that's enabled? Or perhaps you are running ZoneAlarm or something similar, and need to make some changes there? Again, another possibility is that the connection is via a router or switch which is blocking it?

The message being logged is simply what the Windows Netwrok interface is telling WideClient when it tries to connect.

I don't really know enough about networks to help any more explicitly, but maybe someone else will read this and help. Otherwise, Katy Pluta over in the FS2004 Forum knows quite a bit about this sort of stuff.

Regards,

Pete

Link to comment
Share on other sites

Pete, it may be my router. As I said, I'm new to the whole networking thing and I will check out the firewall in my router and see if that is where the solution lies (it's a DLink DI-604). I didn't really understand what the log file was saying, so knowing it relates to the server refusing to communicate offers me some clues.

thanks, and I will check with Katy too.

Any others who have experience with routers, input much appreciated.

thx.

Rod Mann

Link to comment
Share on other sites

Pete, I've posted in the FlightSim forum, but also wanted to follow up with you here too. I'm not sure its' my router/firewall that is the problem, and wanted to post my ini files here just to ensure they are properly set up. Here is how my ini's are set up right now:

My ini files on the server side (where WideFS is installed) are as follows:

Wideclient ini

Port=8002

Window=43,44,886,589

Visible=Yes

UseTCPIP=Yes

ServerName=Base.

; -----------------------------------------------

Log=Errors+

Wideserver ini

Port=8002

UseTCPIP=Yes

ServerName=Base.

; -----------------------------------------------

Log=Errors+

On the client side (where FS9 runs), my

Wideserver ini

Port=8002

UseTCPIP=Yes

ServerName=Base.

I've got wideserver.dll and wideserver.ini on FS9 in the modules folder and, on the server side I have a folder for WideClient, with wideclient.exe; wideclient.ini; wideserver.dll and wideserver.ini

As far as I can tell, this is as per the installation instructions. Does all this look ok? Anything else from a WideFS point of view to look at?

Link to comment
Share on other sites

ServerName=Base.

Having a name with a dot (.) in it seems a bit unusual, but if the system accepts it I suppose it should be okay -- but there is a slight possibility that something en route may not like that.

Wideserver ini

Port=8002

UseTCPIP=Yes

ServerName=Base.

Well, of course, there's no parameter "ServerName" in the Server's INI file -- it doesn't need to know the server name as it never needs to contact it, being in the Server PC itself already. :) But it won't do any harm either.

On the client side (where FS9 runs), my

Wideserver ini

FS9 doesn't (can't) run on the client. FS9 runs the Server. There is no "WideServer" on the Client side -- the Client runs WideClient, the Server runs FS with WideServer. That's why the parts are so named, of course.

I've got wideserver.dll and wideserver.ini on FS9 in the modules folder and, on the server side I have a folder for WideClient, with wideclient.exe; wideclient.ini; wideserver.dll and wideserver.ini

ErThe Server is where FS9 is running, and WideServer needs to be installed there, in FS9's modules folder. Nowhere else! Conversely, the Client is where your Client applications go and where WideClient.exe is run. You do NOT have any FS9 nor WideServer there at all. I am now completely confused by your statements. Only one PC is the Server, any number of PCs can be Clients, but none are both!

You seem to have everything either the wrong way around or completely duplicated! How many FS9 installations are you talking about?

As far as I can tell, this is as per the installation instructions.

Ouch! Sorry, but how do you read that FS9 goes on the Client PC and runs WideServer whilst the Client applications go on the Server PC and run WideClient? Don't the terms "Client" and "Server" mean anything here?

I'm sorry, but I cannot possibly imagine how you work that out from my documents. Can you explain how, please, so I can correct them (after all these years? :( :cry: )

Thanks & Regards,

Pete

Link to comment
Share on other sites

There is one thing I've accomplished today, confusing everyone!!

Pete, it was a matter of terminology confusion on my part and once I read your post and realized the computer that I called "server" and the one client, were for purposes of FS9 and WideFS, totally reversed, for the reasons you mentioned. As soon as I figured that out, I walked myself back through the install process and ensured I had computers named appropriately and pointed to in the ini files.

Problem solved!!

It had nothing to do with the router!

Thanks for your patience.

Rod

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.