Jump to content
The simFlight Network Forums

Wide Client Window problem


 Share

Recommended Posts

Hello Pete:

Three times now when I started Wide Client the window would go right to the task bar. The only way to open it was to right click on the task bar and click "maximize". When I tried to "restore down" the window would go right to the task bar again. Reinstalling the program got it to work for the session but if I shut down the computer and try again the same thing happens.

Suggestions?

Thanks

Link to comment
Share on other sites

Three time now when I started Wide Client the window would go right to the task bar. The only way to open it was to right click on the task bar and click "maximize". When I tried to "restore down" the window would go right to the task bar again. Reinstalling the program got it to work for the session but if I shut down the computer and try again the same thing happens.

The only thing which affects how it starts is the parameter in the WideClient.INI file. Did you check? Take a look please, or just delete your INI file and start again.

BTW I always need to know version numbers in any query or problem report, please!

[LATER]

The business of "restore" making the Window disappear (for that's what it is doing -- there will always be a Task bar entry in any case) will be due to corrupted Window coordinates in the WideClient.INI file too -- delete the line containing the 4 numbers. It is likely that the position is off-screen because you changed screen resolutions or monitor connections or similar.

As an alternative, of ccurse, you could "restore" then "move" and use the cursor keys in assorted directions until you see the window frame coming into view.

Pete

Link to comment
Share on other sites

Hello Pete:

This is a copy of the INI file.

[Config]

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

PollInterval=2000

Port=8002

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

UseTCPIP=Yes

WaitForNewData=500

MaxSendQ=100

OnMaxSendQ=Log

NewSendScanTime=50

Priority=3,1,2

Window=32000,32000,160,34

The window size is way out of kilter as you can see. I delete the INI file, let the program build a new one which works of for a day or so then back to this window size.

Besides constant deleting any suggestions?

Thanks.

Link to comment
Share on other sites

Window=32000,32000,160,34

The window size is way out of kilter as you can see. I delete the INI file, let the program build a new one which works of for a day or so then back to this window size.

Besides constant deleting any suggestions?

WideClient itself NEVER decides its own 'restored' window position or size -- you have something else which is doing that. Some background program or windows organiser, or possibly a video driver "remember positions" facility that is going wrong. Something like that in any case. There is really nothing WideClient can do to stop other programs resizing or repositioning its Window without also stopping you doing so too.

I'm not sure what you want the WideClient window to be visible for (is it for the ButtonScreen option?), as most would want it hidden. You could try using the "Visible=" parameter to force a specific size. You have the options of

Visible=Min to initialise minimised

Visible=Max to initialise maximised, i.e. the whole screen.

Apart from that I can only suggest you look for whatever it is which is moving the (rather small?) window you have. As a possible "last resort" you could, I suppose, try making the INI file read-only, so that it loads okay next time, but this wouldn't prevent it being moved whilst running.

Perhaps you can show me what the Window parameter looks like when you have WideClient as you want it?

Regards,

Pete

Link to comment
Share on other sites

This is the size I'm looking for.

Window=75,81,593,489

Doesn't look to be anything wrong with that.

Sorry, I'm out of ideas. Something in your system is moving the Window. How or why I can't say, sorry. Check what things you have added which deal with window positions. There really must be something doing it.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.