Jump to content
The simFlight Network Forums

Erratic reading of GoFlight rotaries


Recommended Posts

Peter; I'm a newbe at this, having started putting my cockpit together a few weeks ago - as a matter of fact, I used FSUIPC for the fist time today!!!

I'm trying to assign keystrokes to the GoFlight RP48 rotaries, and FSUIPC seems to "catch" the rotaries' motions about every other "click". This happens both during actual operation as well as during "programming" via the FSUIPS "buttons" tab GUI. It DOES recognize slow vs. fast rotation, but during slow rotation it catches approximately every other "click" about once in ten it catches two consecutive clicks).

I do NOT have these rotaries assigned via GFConfig, and I am NOT running GFKeys. I run a three months-old mega-machine (AMD 64 FX 57 w. 2Gigs of DDR) with a clean OS installation and minimal services on (and no WideFS, networking, etc.) so "computrons" should not be an issue.

I seem to have scanned through a post of yours concerning FSUIPC getting the CORRECT GFDev.dll; the version of GFDev.dll I have is 1.53 Build 1, but I also have a "GFDev2k4.dll" in the GoFlight folder... BTW, I could not find a pointer to GFDev.dll in either the registry or FSUIPC.ini.

What could I be doing wrong? Can I set up some diagnostic log that could help?

Tnx,

- Antonio

Link to comment
Share on other sites

...FSUIPC seems to "catch" the rotaries' motions about every other "click".

Correct. Well noticed! However, you seem to not have noticed the explanation, which is actually in the FSUIPC user guide, thus:

Please note that rotary input is implemented by alternately setting a switch on then off. Each change will usually be one ‘click’ of the knob. If you want action on each and every click you will have to program the same thing on both the “press” and “release”. Do not set the repeat option with the rotary switches.
What could I be doing wrong?

Nothing. You seem to be just misinterpreting what you are seeing.

Regards

Pete

Link to comment
Share on other sites

Alas! I neglected to indicate I *had* programmed the keystroke on both press and release... so that's not it... I tried loggin events, but the results overwhelm me... any further hints?

No -- each click here most certainly gives either a press or release, unless you turn it too fast, then you get a lesser number of "fast" button returns -- the are 4 possible button numbers on each rotary, remember. Two clockwise, fast and slow, two counter-clockwise fast and slow. You can program them all differently, or use the fast ones for "fast" controls (where they exist) or just for multiple controls (for the latter you'd need to edit the FSUIPC.INI file).

It sounds like you are turning them fast and expecting each click to be recognised separately?

Pete

Link to comment
Share on other sites

No... I was moving the rotary very slowly, to see if it would respond to a single "click"... however, I made the following discovery: the problem seems to occur only when I program these buttons as "aircraft-specific" - If I DO NOT program as aircraft-specific, (leave the check box clear) THEN they work as documented. If I only program them as aircraft-specific, then I get this "almost-every-other-click" response. I'm happy with making this programming non-aircraft specific.

I know, that's not the way it's supposed to be... I'll keep experimenting... Thanks for following my ramblings - it shows you care.

Antonio

BTW, I'm integrating a GoFlight RP48 with a $180USD Chinese 8" touch-sensitive automotive LCD display to display and control the RealityXP Garmin 530 - I use the touch-sense feature of the LCD for the 14 pushbuttons, and the GoFlight rotaries for the, well, rotaries, which are not gracefully controllable using the touch panel. Works great (especially now that I've got the rotaries to respond click-by-click) - the resulting device is about the same size as a real 530 (I have 530's on both of my real aircraft - my avatar is a picture of my 310's panel and if you look closely you can see a 530)

Link to comment
Share on other sites

... the problem seems to occur only when I program these buttons as "aircraft-specific" - If I DO NOT program as aircraft-specific, (leave the check box clear) THEN they work as documented. If I only program them as aircraft-specific, then I get this "almost-every-other-click" response.

Hmmmhow very strange. The code is the very same code. The table is just one table. All that happens is that the entries for buttons inapplicable to the current aircraft are reoved when the ones which are applicable are read.

Were the same button numbers also programmed for non-specific use as well? Maybe it is something to do with the double check -- I could investigate that. Perhaps you could reproduce it with Button logging enabled (in FSUIPC's Logging options) and show me the log, with a little explanation about which button is which, please? The buttons sections of your INI would be needed too.

Thanks,

Pete

Link to comment
Share on other sites

Hi Antonio,

Well, I fished out my RP48 and connected it up, programmed one of the rotaries to inc/dec the 737 A/P IAS value in aircraft-specific mode, and every click did operate it. So I then also programmed the same rotary in non-aircraft-specific mode, to inc/dec the course (VOR1 OBI inc/dec).

Both worked fine. When the specific aircraft was loaded the rotary adjusted the IAS on every click, and for all other aircraft it operated the course on every click.

I had a look through my code too to see if there's anything there which was capable of missing the clicks in any circumstances, but really I couldn't find anything.

Which leaves me in need of more information, please.

I was hoping that, should this turn out to be a bug, I could fix it in the next release, but I must release 3.52 this week, preferably well before the weekend. So we have missed that one. Then I'm really a bit stuck till February. I may have a little time early in the new year, so if you could do that logging and show me the INI file details I'd still look at it. You can ZIP stuff up and send it to me at petedowson@btconnect.com.

By the way, I notice in your first message here that you said:

I also have a "GFDev2k4.dll" in the GoFlight folder

This FS module is the one which operates the GoFlight programming for the buttons et cetera. All you need to do is to make sure that the GoFlight programming for the rotaries you use in FSUIPC is cleared -- i.e. you don't want both GoFlight and FSUIPC processing the same 'clicks'.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.