Jump to content
The simFlight Network Forums

acp compact from aerosoft bug with fsuipc.dll


Recommended Posts

Dear Mr. Dawson,

The heading bug and obs of my keyboard emulator have two speeds.

one is low increment when starting to turn the knobs and second speed is much higher when having turned a while.

Now when FSUIPC is loaded only the low increment speed is active, making ifr training difficult because it takes 2 minutes to make a 360 with the heading bug. The obvious things I have tried.

Can you help?

Regards,

Link to comment
Share on other sites

Dear Mr. Dawson

It's Dowson, not Dawson.

The heading bug and obs of my keyboard emulator have two speeds.

one is low increment when starting to turn the knobs and second speed is much higher when having turned a while.

Now when FSUIPC is loaded only the low increment speed is active, making ifr training difficult because it takes 2 minutes to make a 360 with the heading bug.

I'm not sure how it manages a "high speed" and "low speed", as it is only emulating the keys you can use on the Keyboard yourself. Have you tried the keyboard, for comparison? It is most liely relying on FS's own acceleration.

Does this happen with default aircraft, or only with the more sophisticated ones? The most likely thing is either that you have enabled the control acceleration fix in FSUIPC's Technical options page when it isn't wanted, or, vice versa, you are using a cockpit which interferes with the acceleration, in which case try the fix in FSUIPC.

There really is no way FSUIPC itself interferes one way or the other, but the acceleration fix may be set wrong for what you want.

Regards,

Pete

Link to comment
Share on other sites

Dear Mr. Dawson,

Your solution worked great! You must be the most knowledgeable guy on the web for mfs!

Some other things you might want to look at;

-It remains very hard to get a natural feel with flightsimyoke from CH. (Actually I am a Prof/IFR/ME.)

I run CHmngr 4.0 in direct mode and FSUIPC at the same time. It is a bit better but still not terrific. Is there any data on top settings for this to work without the annoying pitch sensitivity. I already made a new mooney ifr with max pitch stability etc.

-annoying red differential braking sign, probably my potmeter is almost dead: Can I get rid of it?

-Propellor pitch is swinging around after each adjustment, even with your filter applied. Any suggestions?

-Framerate with 2 of the most expensive ati 9800 radeon cards running 3 screens is only 25 fps at highest settings. after flying 20' it gets down to 15 why? A restart of mfs solves this...

Regards!

Link to comment
Share on other sites

Dear Mr. Dawson

It is still "Dowson", not "Dawson". I think I'd rather have you call me "Pete" than get my name wrong all the time, please.

I run CHmngr 4.0 in direct mode and FSUIPC at the same time. It is a bit better but still not terrific. Is there any data on top settings for this to work without the annoying pitch sensitivity. I already made a new mooney ifr with max pitch stability etc.

Sensitivity of controls should vary quite a bit from one aircraft to another, and is all about how that aircraft is designed. A jet fighter will be many times more sensitive than a 747. I don't know enough about FS aircraft design to help you make one, but there will be parameters you can place in the Aircraft.CFG file which will change things -- not pitch stability necessarily, but the scalars affecting elevator effectiveness and that sort of thing. There will also be moments of inertia.

As far as joysticks are concerned, the main improvment you can make is to use the slopes I provide, with a somewhat flattened response near the centre.

annoying red differential braking sign, probably my potmeter is almost dead: Can I get rid of it?

Get rid of the message? There's an FS9.CFG file parameter for that I think. Check the FS2004 FAQ. Look in the FS2004 Forum. Ask there if you can't find it.

Not sure what you mean by "probably my potmeter is almost dead". Sorry.

-Propellor pitch is swinging around after each adjustment, even with your filter applied. Any suggestions?

No idea on that one, sorry. Sounds like you are using a pretty poor aircraft? Look for another, maybe?

-Framerate with 2 of the most expensive ati 9800 radeon cards running 3 screens is only 25 fps at highest settings

That's pretty good! Why say "only"? Are the three screens running as one window? If you actually have multiple 3D windows I'm amazed it gets anywhere near as high as that.

. after flying 20' it gets down to 15 why? A restart of mfs solves this...

Two possibilities I can think of -- a memory leak someplace, so your available main memory decreases and you get more disk activity. Or it is something to do with garbage collection on the video cards -- their memory is getting full of old textures and stuff and its taking longer to change them out. However, on both counts I'm guessing. These are definitely the sort of questions you should ask over in the FS2004 forum.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.