Jump to content
The simFlight Network Forums

Can't get Widefs to connect.


Recommended Posts

Pete, thank you for all that you have done for flightsimmers the world over.

I am confused. I have one desktop with both fs2k2 and fs9. I have had no problem with 2k2 connecting to Widefs but fs9 will not. I have fsuipc and widefs loaded and registered in fs9. All is pretty much up to date. The following is data from both the server and the client:

********* WideServer.DLL Log [version 6.51] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 23/04/06, Time 07:12:46.984: Server name is BOBOWABO

412516 Initialising TCP/IP server

412578 Initialising IPX/SPX server

412594 IPX/SPX socket() failed [Error=10047] Address family not supported by protocol family

412594 Failed to start IPX/SPX Server

412594 Broadcasting service every 1 mSecs

423641 Restarting service due to total lack of use

423641 Failed to start IPX/SPX Server

11087328 Closing down now ...

Memory managed: Offset records: 0 alloc, 0 free

Throughput maximum achieved: 0 frames/sec, 0 bytes/sec

Throughput average achieved for complete session: 0 frames/sec, 0 bytes/sec

********* Log file closed *********

; PLEASE SEE WideFS documentation for parameter details

; =====================================================

[Config]

Port=8002

Window=558,3,886,85

Visible=Yes

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

PollInterval=2000

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

UseTCPIP=Yes

WaitForNewData=500

MaxSendQ=100

OnMaxSendQ=Log

NewSendScanTime=50

Priority=3,1,2

ServerName=BobMichele

; -----------------------------------------------

[user]

Log=Errors+

; ===============================================

********* WideClient Log [version 6.47] Class=FS98MAIN *********

Date (dmy): 23/04/06, Time 13:42:48.984: Client name is BOBOWABO

515 Attempting to connect now

2625 Trying TCP/IP host "BobMichele" port 8002 ...

2625Okay, IP Address = 172.16.1.34

3578 Error on client pre-Connection Select() [Error=10061] Connection refused

3578 Ready to try connection again

3640 Attempting to connect now

5343 ****** End of session performance summary ******

5343 Total time connected = 0 seconds

5343 Reception maximum: 0 frames/sec, 0 bytes/sec

5343 Transmission maximum: 0 frames/sec, 0 bytes/sec

5343 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

5343 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

I hope this is enough info, if not let me know.

Regards,

Bob

Link to comment
Share on other sites

The following is data from both the server and the client

Yes, and the answer is staring out from that. Look:

Date (dmy): 23/04/06, Time 07:12:46.984: Server name is BOBOWABO

and

Date (dmy): 23/04/06, Time 13:42:48.984: Client name is BOBOWABO

515 Attempting to connect now

2625 Trying TCP/IP host "BobMichele" port 8002 ...

Don't you notice anything odd? Both Server and Client are named "BOBOWABO"! Uh? And the client INI is told to connect to "BobMichele" which is neither of them.

Also you are using WideServer 6.51 but WideClient 6.47. Please make sure you update both parts, not just one!

Regards,

Pete

Link to comment
Share on other sites

I do see something here. I am not sure why the server is coming up with 'bobowabo' when the machine is 'bobmichele'.

Well that's the name it is getting from the registry there. Are you sure you are getting the Logs from the right places? There really isn't anyway I know for the Server to get the Client's name before any connection in any case.

What does the FS2002 one come up with?

Would it helped if I delete all trace of widefs and install everything new?

Well, there's not much to them, so I don't see the point. But certainly make sure you are using 6.51 or later all round, not a 6.47 client as now. and if it works on your FS2002 why not simply copy the INI files over from that? WideFS doesn't really care what version of FS it is and that certainly doesn't affect the connection part.

The line

... Okay, IP Address = 172.16.1.34

in the Client log shows that it is finding "BobMichele", but the error

Error on client pre-Connection Select() [Error=10061] Connection refused

implies that access is blocked. You usually get that with a firewall problem, or maybe FS wasn't ready then. The two logs aren't for the same attempt (unless your clocks are wildly different) so it isn't easy to tell.

Regards,

Pete

Link to comment
Share on other sites

I have since renamed the server computer to 'UPS700' and updated both computers with ver 6.51. I still can't connect. I see that the client needs the name of the server. How does that take place? See the following;

********* WideClient Log [version 6.51] Class=FS98MAIN *********

Date (dmy): 24/04/06, Time 17:26:44.546: Client name is BOBOWABO

985 Attempting to connect now

1985 Failed to connect: waiting to try again

3031 Attempting to connect now

44266 Trying to locate server: TCP/IP needs ServerName or IP address!

45735 ****** End of session performance summary ******

45735 Total time connected = 0 seconds

45735 Reception maximum: 0 frames/sec, 0 bytes/sec

45735 Transmission maximum: 0 frames/sec, 0 bytes/sec

45735 Max receive buffer = 0, Max send depth = 0, Send frames lost = 0

45735 ********* Log file closed (Buffers: MaxUsed 0, Alloc 0 Freed 0 Refused 0) *********

********* WideServer.DLL Log [version 6.51] *********

Blocksize guide = 4096 (double allowed)

Date (dmy): 24/04/06, Time 17:23:04.671: Server name is UPS700

146344 Initialising TCP/IP server

146406 Initialising IPX/SPX server

146406 IPX/SPX socket() failed [Error=10047] Address family not supported by protocol family

146406 Failed to start IPX/SPX Server

146422 Broadcasting service every 1 mSecs

157719 Restarting service due to total lack of use

157719 Failed to start IPX/SPX Server

272328 Closing down now ...

Memory managed: Offset records: 0 alloc, 0 free

Throughput maximum achieved: 0 frames/sec, 0 bytes/sec

Throughput average achieved for complete session: 0 frames/sec, 0 bytes/sec

********* Log file closed *********

Sorry for all the trouble,

Bob

Link to comment
Share on other sites

I have since renamed the server computer to 'UPS700' and updated both computers with ver 6.51. I still can't connect. I see that the client needs the name of the server. How does that take place?

Didn't you find the documentation in the ZIP? It's called "WIDEFS.DOC". It does explain the parameters there -- you can tell the Client the name of the Server in the ServerName parameter.

Anyway, I thought you said you had it working in FS2002 but not in FS2004? Why not simply use the same INI files for both? WideFS isn't bothered by what version of FS it is -- it leaves all that to FSUIPC.

Is your client PC not running WinXP or Win2K? If it is, are both PCs in the same workgroup? It is a little odd that the Server is broadcasting its details but the client isn't seeing them -- the broadcasts use the Windows Mailslot facilities, which only work in Win2K and WinXP (and seem to need the PCs in the same workgroup). Otherwise you have to specify the server to the client, as in earlier WideFS releases such as the 6.47 you were using last time -- you did specify the ServerName that time, it was just wrong.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.