Jump to content
The simFlight Network Forums

Separate Mixture axis problems


Recommended Posts

I have run into a problem while trying to assign my various joystick/throttle levers to various axes via FSUIPC. A brief search of the forum did not reveal any immediate results on this topic either.

I'm trying to assign the 6 levers in my CH TQ to the 6 levers in the Default DC-3. Throttle and Propeller I can get no problem.

When trying to do the mixture, however, I have trouble. Since I am trying to assign two levers to two mixture controls, I am using the "Mixture1" and "Mixture2" controls rather than the generic "mixture" control. Here's what I run into:

Since the separate mixtures have both a min/max and a center zone (Min, Idle, and Max) the throttles, once calibrated, do not progress smoothly from 0 to 16384 as reported in the "OUT" box. It appears as if the "Idle" zone actually corresponds to a mixture of 8192 (50% rich) whereas the "Min" corresponds to 0% (Cut-off). Therefore when I calibrate the "Idle" detent to the physical detent in the CH TQ, the output jumps quickly from 0 to 8192 in the space where the physical mixture lever is moved from full down to the detent. Then if I push the lever forward past the detent the OUT value increases gradually to 16384.

The problem with this is that since the Idle detent corresponds with 8192, the lowest usable mixture value I can assign to the engine is 50%. If I try to go lower, I will enter the cut off zone and cut fuel to the engine.

What I'm looking for is to calibrate it such that movement from the absolute bottom fo the throttle into the detent is cut-off, then any advancement forward past the detent should proceed linearly from 0 to 16384, giving me full mixture range.

Note that when I previously applied calibrations to my other aircraft (i.e. default Cessna) I did not have this problem, since I could assign the solitary mixture axis to the generic "Mixture" command. Also, there is no trouble with turboprops either using "Mixture1" and "Mixture2" because 50% corresponds well to "Low Idle" (Also you don't adjust the mixture of a turboprop). I have only reached this issue now that I am trying to calibrate for a twin-engine, reciprocal aircraft.

PS I did a quick test and also encounter this trouble on the default Baron 58, which again requires a 0-100% mixture working range.

What's the solution for this? Any way to disable the idle detent in the separate mixture controls?

Ruahrc

Link to comment
Share on other sites

It appears as if the "Idle" zone actually corresponds to a mixture of 8192 (50% rich) whereas the "Min" corresponds to 0% (Cut-off).

Didn't you check the FSUIPC user documentation. Here, I'll quote the relevant part from the table documenting all the axis calibrations:

0 (lean or cut-off) via 8192 (idle) to +16384 (rich)

Centering is provided for the 8192 value so that turbo controls with détentes on the mixture levers can be calibrated with a usable ‘dead’ zone. By default, however, this dead zone is eliminated by having both upper and lower input values for it set the same.

On a turbo the 8192 level is used by FS as the idle level, not 50% rich.

What I'm looking for is to calibrate it such that movement from the absolute bottom fo the throttle into the detent is cut-off, then any advancement forward past the detent should proceed linearly from 0 to 16384, giving me full mixture range.

If you are not using a turbo aircraft with separate cut-off and idle positions, simply calibrate the minimum at your detente, and make sure the two centre values are identical and approximate to the correct position on the lever. It sounds like you are calibrating for a turbo.

Regards,

Pete

Link to comment
Share on other sites

Yeah I figured out I can remove the "detent" zone by calibrating the two center values to be the same: I calculated the center of my travel (min: -10,000, max:16384 = center at ~3000, etc) and put the dead zone there.

Then I realized that I had to adjust the "response curve" to -15 (center-flat, exponential) in order to get what most appears like a linear travel on the mixture control, judging by the OUT value. If I have it up at 0, even with a "zero" dead zone and the center set at approximately half-travel, I will still get mixture OUT values "jumping" from say 4,000 to 11,000 as soon as I pass the center. Only by changing the response sensitivity can I get it to work.

Ruahrc

Link to comment
Share on other sites

  • 2 weeks later...

Then I realized that I had to adjust the "response curve" to -15 (center-flat, exponential) in order to get what most appears like a linear travel on the mixture control, judging by the OUT value. If I have it up at 0, even with a "zero" dead zone and the center set at approximately half-travel, I will still get mixture OUT values "jumping" from say 4,000 to 11,000 as soon as I pass the center. Only by changing the response sensitivity can I get it to work.

Sounds like the axis is using a Log pot, not a Linear one.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.