Jump to content
The simFlight Network Forums

WideFS 6.65 no Connect


Recommended Posts

Hi,

I have just updated to FSUIPC 3.65 and WideFS 6.6.5 (both registered).

I copied the new FSUIPC.DLL and the new WideServer.DLL to the Modules folder of my FS9 installation and the new WideClient.Exe to the WideClient folder of my Client PC always overwriting the previous versions.

Unfortunately now WideClient.exe doesn't connect to the server.

If I replace the WideClient.Exe version 6.6.5 with my previous version 6.5.1 everything seems to work fine.

Here is the WideClient.Log for the not working WideClient 6.6.5

********* WideClient Log [version 6.65] Class=FS98MAIN *********

Date (dmy): 29/06/06, Time 00:10:29.953: Client name is CW106

297 Attempting to connect now

297 Trying to locate server: IP protocol needs ServerName or IP address!

297 Failed to connect: waiting to try again

1328 Attempting to connect now

Why does version 6.5.1 work but version 6.6.5 doesn't? Any ideas would be appreciated.

Thanks in advance

Peter

Link to comment
Share on other sites

If I replace the WideClient.Exe version 6.6.5 with my previous version 6.5.1 everything seems to work fine.

Odd, because WideClient 6.65 actually corrects a problem in 6.51 with WideClient not reconnecting after a restart of FS.

I need to see the WideClient INI and WideServer.INI files, and I need to know what operating system you are using in Server and Client PCs please.

Here is the WideClient.Log for the not working WideClient 6.6.5

And how does that compare with the 6.51 log, please? All it looks like is that the Mailshot transmissions from the Server aren't being seen at the Client.

Why does version 6.5.1 work but version 6.6.5 doesn't? Any ideas would be appreciated.

I can't guess at that yet. Let me see more information, please.

Regards

Pete

Link to comment
Share on other sites

I have had the same problem.

After adding the server-name (ServerName=xxxxxxx) in the WideClient.ini (previously I had only the ServerIPAddr-Entry) everything was ok.

AhI'll try that.

The code for all this changed substantially to make the automatic protocol ("ProtocolPreferred") and so on work well.

ServerName usage is much preferred over IP addresses in any case, but if you have Win2K or WinXP all round anyway it is far easier just to leave any mention of the Server out and let WideFS do it all automatically -- that was the case in 6.51 too.

Meanwhile, I'll re-test the case of IPAddress specified here.

Thanks,

Pete

Link to comment
Share on other sites

Hi Pete, hi Peter

both Server (name cw101; IP 192.168.0.101) and Client (name cw106; IP 192.168.0.106) are using Win XP SP2.

@Peter: Thanks for the tip about the ServerName-entry. When I add the ServerName=xxxx line everything works fine.

And it works as well if I remove the line ServerIPAddr=192.168.0.101 from the WideClient.ini.

Thanks for your help

Peter

P.S.

Here ist my WideClient.INI, (the one which doesnt connect):

##################################

; PLEASE SEE WideFS documentation for parameter details

; =====================================================

[Config]

Port=8002

Window=32000,32000,160,34

;Visible=Min

Visible=Yes

ServerIPAddr=192.168.0.101

;ServerName=cw101

ButtonScanInterval=20

ClassInstance=0

NetworkTiming=5,1

PollInterval=2000

ResponseTime=18

ApplicationDelay=0

TCPcoalesce=No

WaitForNewData=500

MaxSendQ=100

Priority=3,1,2

OnMaxSendQ=Log

NewSendScanTime=50

MailslotTiming=2000,1000

Port2=9002

Protocol=TCP

; -----------------------------------------------

[user]

Log=Errors+

UseSendInput=Yes

KeySend1=123,16

KeySend2=123,24

##########################################

and the WideServer.in:

###########################################

; PLEASE SEE the documentation for parameter details

; ==================================================

[Config]

Port=8002

AutoRestart=0

AutoUpdateTime=13

MaximumBlock=4096

NoStoppedRestarts=Yes

RestartTime=10

SendTimeout=15

TCPcoalesce=No

AdvertiseService=1

Port2=9002

; -----------------------------------------------

[user]

Log=Errors+

KeySend1=7

KeySend2=7,1

; ===============================================

[ClientNames]

1=CW106

###########################################

Link to comment
Share on other sites

both Server (name cw101; IP 192.168.0.101) and Client (name cw106; IP 192.168.0.106) are using Win XP SP2.

@Peter: Thanks for the tip about the ServerName-entry. When I add the ServerName=xxxx line everything works fine.

And it works as well if I remove the line ServerIPAddr=192.168.0.101 from the WideClient.ini.

Okay, I've reproduced the problem. I'll fix it in the next update.

It only occurs if you specify a Protocol and the ServerIPAddr. Somehow this combination slipped through my test list -- there are too many combinations now! ;-)

Since you are using TCP protocol you do not need the Protocol parameter. It is odd that you still have it, as WideClient automatically removes the old "UseTCPIP=Yes" parameter and doesn't replace it -- it only puts a Protocol parameter in if you were using SPX before.

Since you are using XP on all PCs you do not need the ServerName or the ServerIPAddr parameters either -- unless you have two Servers running at the same time, which is usually very unlikely.

Really, for an all WinXP setup, the best and most flexible way is to specify nothing at all in the Wideclient INI files (no protocol, no server details), and just use ProtocolPreferred in the Server's INI to select TCP, SPX or UDP. I use UDP throughout these days, but configuring it as I say allows you to change over just by changing that one Server parameter.

Regards,

Pete

Link to comment
Share on other sites

Don't know whether it is relevant but I have the same problem. I have found however that not only will WideFS not now connect but I also lose all file sharing access between my computers.

I tried removing WideFS completely and I now find that when I light up the computers the file sharing works fine but if I start FS9 I lose it (note that this is with Wide FS modules now removed). I am sure this has something to do with the non-functioning of WideFS but can't see why. If I remove the WideFS module is anything left in my PC which can interfere with my network?

Very odd!

Barry

Link to comment
Share on other sites

Don't know whether it is relevant but I have the same problem.

Amazing how many folks set the parameters in Wideclient INI so restrictively! I make things as easy and automatic as possible, and it is all defeated by folks specifying IP addresses and protocols explicitly! :-(

Please just delete the ServerIPAddr parameter. If you must specify the Server (eg you are using Win98 or WinMe), please use the ServerName for now.

I have found however that not only will WideFS not now connect but I also lose all file sharing access between my computers.

Sorry, but that cannot possibly be anything whatsoever to do with WideFS. In fact the reverse is likely -- you have something wrong with the Network and that is affecting WideFS too.

Note that the problem mentioned in this thread and reproduced here is simply that if you specify both the Protocol and the ServerIPAddr parameters in Wideclient.INI, then WideClient doesn't connect. More than that, it doesn't even attempt to connect -- in fact it touches absolutely nothing on the Network at all! That was the problem -- a particular combination with no code to back it up.

I am sure this has something to do with the non-functioning of WideFS but can't see why.

Why are you sure then? I tell you, it is not possible for it to be anything at all to do with WideFS. Sorry, but there it is.

Regards,

Pete

Link to comment
Share on other sites

Hi Pete,

Really, for an all WinXP setup, the best and most flexible way is to specify nothing at all in the Wideclient INI files (no protocol, no server details), and just use ProtocolPreferred in the Server's INI to select TCP, SPX or UDP. I use UDP throughout these days, but configuring it as I say allows you to change over just by changing that one Server parameter.

I have done, what you have suggested. Now, everything is ok again.

I should have read the manual and cleaned up my Ini-files earlier, but "never change a running system" :D

Thanks a lot for your quick response.

And BTW thanks for your great work, keep it up.

Regards

Peter

Link to comment
Share on other sites

FWIW, I also hit my head against the ServerIPAddr and Portotcol= issue. Actually, I had the problem on 6.6.1.7 beta, and went back to 6.5.1, then I just d/led 6.6.5 and find the problem is still there. You (Pete) were on holiday at the time IIRC so didn't post.

I take it to set PreferredProtocol on the server I also have to set advertiseservice=yes?

I'm getting so many variant copieis of the inis now on my systems I'm kind of getting lost. I ended up dumping my inis and using the ones in the zip file; that at least got me connected again.

I guess I'm old school and just prefer calling servers by IP address.

scott s.

.

Link to comment
Share on other sites

FWIW, I also hit my head against the ServerIPAddr and Portotcol= issue. Actually, I had the problem on 6.6.1.7 beta, and went back to 6.5.1, then I just d/led 6.6.5 and find the problem is still there. You (Pete) were on holiday at the time IIRC so didn't post.

It only happens if you specify both the protocol and the Server's IP address. It's just a very unusual combination which slipped my testing. I've fixed it here but there are other things I want to do so it hasn't made release yet.

It has never really been a good idea to select the Server by its IP address -- the Name is much more flexible and safe in case your IP addresses change. And if you are using Win2000 or WinXP all round it hasn't been necessary to specify the server at all for several releases.

I take it to set PreferredProtocol on the server I also have to set advertiseservice=yes?

It defaults to being on in any case (and i think the value is 1 for 1 second). You don't have to change it unless you have turned it off before -- but why would you do that?

I'm getting so many variant copieis of the inis now on my systems I'm kind of getting lost. I ended up dumping my inis and using the ones in the zip file; that at least got me connected again.

If you are using Win2000 or WinXP all round, your best bet would have been to dump all the Client INIs and not replace them in any case, just let WideClient make new ones. I think the ones in the ZIP are the same default in any case.

I guess I'm old school and just prefer calling servers by IP address.

Well, if you need to select between several servers running FS at the same time, then you need either the Name or the Address. But if, as in most cases, you only have the one FS Server then you haven't needed either for a while. ;-)

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.