Jump to content
The simFlight Network Forums

11D4 and 3364 (sim1 available, fs is flying) always return 0


Recommended Posts

Hello Pete

In the FSUIPC 3.7.0.0 the offsets

11D4 and 3364 always return 0 (even when FS is flying)

I could confirm that by both using my own code, and your FSInterrogate2std.exe

appication

Is it possible to fix it ? We use these offsets to see the simulator state.

Thanks.

Best Regards,

Oleksiy Frolov

Link to comment
Share on other sites

In the FSUIPC 3.7.0.0 the offsets

11D4 and 3364 always return 0 (even when FS is flying)

11D4 was only ever used when SIM1 was moveable and sometimes loaded with flights (especially before FS2002 ewhen it was "SIM1.SIM"). Since FS2004 (i.e. for three years now) 11D4 hasn't been used and is clearly marked as "not applicable" in the documentation.

3364 taken together with 3365 is used for "ready to fly" (check them to be zero) and works fine. If you set "Log Extras" in FSUIPC logging you can see it log when the bits in this change. 3364 is actually only non-zero during FS loading, but 3365 deals okay with menus and dialogues.

Regards,

Pete

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.