Jump to content
The simFlight Network Forums

Add on menu bar disappearing in FSX


Recommended Posts

Hi Pete

I thought I should report this.

I also experienced the problem that the addon menu disappeared.

It was working fine until I was setting up IVAP to connect through

simconnect. I disabled the loading of IVAP in the dll.xml file.

I created a new file named "simconnect.dll" in the folder:

C:\Documents and Settings\gilles\Application Data\Microsoft\FSX

with the following content:

<?xml version="1.0" encoding="Windows-1252"?>

SimConnect

SimConnect.xml

False

False

IPv4

global

192.168.0.1

6810

After having created and saved that file, I started FSX, the addon menu had disappeared. When I close FSX and I delete that file simconnect.dll

and start FSX again, the addon menu is there again.

I found no solution for that problem.

Many thanks

Gilles

Link to comment
Share on other sites

I created a new file named "simconnect.dll" in the folder:

C:\Documents and Settings\gilles\Application Data\Microsoft\FSX

with the following content:

You shouldn't do that! An XML file has filetype XML, not DLL. The SimConnect DLL is the compiled program part of FSX which loads and runs all SimConnect client programs!

This XML file:

<?xml version="1.0" encoding="Windows-1252"?>

SimConnect

SimConnect.xml

False

False

IPv4

global

192.168.0.1

6810

should be called Simconnect.XML, and is only needed if you are running SimConnect client EXE programs on a Networked computer other than the FSX PC.

After having created and saved that file, I started FSX, the addon menu had disappeared. When I close FSX and I delete that file simconnect.dll

and start FSX again, the addon menu is there again.

I found no solution for that problem.

Why create the file, then? And odder, why call it SimConnect.dll?

If you think you have found a bug in FSX you really need to report it to MS rather than me -- send all the details to tell_fs@microsoft.com.

Regards

Pete

Link to comment
Share on other sites

And you are right, I have called the file simconnect.xml.

Ah .. so the problem you are saying is that if you set SimConnect to operate on multiple PCs on a Network, it either doesn't service any of the local Simconnect client programs, or perhaps just doesn't obey the DLL.XML and EXE.XML instructions to load them?

If this is true it is extremely serious and certainly needs attention. I will try some experiments here. Thank you.

Regards

Pete

Link to comment
Share on other sites

<?xml version="1.0" encoding="Windows-1252"?>

SimConnect

SimConnect.xml

False

False

IPv4

global

192.168.0.1

6810

Okay, I've experimented and soon found the problem. I don't think you need report it to MS, except maybe to get it clarified in documentation somewhere.

I'm not sure where you got the above content for the XML file from, but as far as I can tell, by including that file you are overriding the default setting for how SimConnect uses TCP/IP protocols in the current (FSX) PC. SimConnect is still loading modules according to DLL.XML and programs according to EXE.DLL, but it cannot communicate with them because you have changed the port and IP address.

If I change your file to read:

<?xml version="1.0" encoding="Windows-1252"?>

SimConnect

SimConnect.xml

False

False

IPv4

global

192.168.0.1

6810

False

IPv4

local

127.0.0.1

6820

Then everything works again. I'm not sure I need the Port number, and probably the Protocol should be Auto in any case to allow it to use IPv6 if installed, but the critical part is the 127.0.0.1 which universally means "this PC". I also set scope as "local" but, again, I'm not sure how necessary that is.

Regards

Pete

Link to comment
Share on other sites

Hi:

Peter, your post finally solved my problem. I also had the Simconnet.XML file for the Ivap remote operation and that caused that I did not see the add on menu, adding your new lines to the file added the add on option to my menu bar.

I´ve tested to connect to the network with Ivap in remote operation and it works fine also.

Thanks,

Francisco

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.