Jump to content
The simFlight Network Forums

Radar Contact and RemoveATC variable


Recommended Posts

First a BIG THANKS for the wonderful utilities, Mr Dowson. Your work IS appreciated.

I realize that you have many things going on so I'm not asking you to do anything about it, other than please, if you happen to know the answer, or reason, for a strange behaviour, maybe you can tell me.

I run the latest RC4 and I think the latest fsuipc for FS9 (downloaded it about 2 months ago). It all works!

Now, the behaviour and let's forget about RC4 for a moment: when I have fsuipc with the variable "RemoveATC=Yes", marker beacon sounds are mute (no sound). With the variable commented out, I hear them OK regardless of the ATC sound slider in FS9.

Any particular reason why patching the atc.dll would disable the marker beacon sounds?

Thanks in advance,

Link to comment
Share on other sites

I run the latest RC4 and I think the latest fsuipc for FS9 (downloaded it about 2 months ago).

It won't be the latest then. That was released last week. ;-)

when I have fsuipc with the variable "RemoveATC=Yes", marker beacon sounds are mute (no sound). With the variable commented out, I hear them OK regardless of the ATC sound slider in FS9. Any particular reason why patching the atc.dll would disable the marker beacon sounds?

No. It doesn't seem to here, or at least I've never noticed them missing (though there's usualy such a lot going on at final approach, with RC and AI to contend with, that I may simply not have noticed). The patches which it applies are actually in no way related to marker sounds, or markers at all. However, the patches were arrived at by experiment, to find a way to avoid crashing FS9, so I suppose there's a possibility that there are side effects. After all I am making the ATC part bypass some code. I just don't see how the ATC stuff affects markers -- unlike COM frequencies, of course, which play a major part in the ATC operation.

There's really nothing I can do about it either way. The patches are at the very last place possible to stop the condition which causes the crash. Microsoft know all about what causes the crash, and say it is fixed in FSX, but they were not willing to help me devise a certain work-around for FS9. Sorry.

Regards

Pete

P.S. I assume you have checked that the marker sound switch is not "off" in the radio switch gauge?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.