Jump to content

FSX doesn't remember FSUIPC key


Recommended Posts

I recently upgraded to FSX and Vista O/S for which I purchased a new FSUIPC and WideFS key to go with the latest FSCUIPC 4.070 which I have downloaded.

I installed it using the exe file.

The "add on" tab appears in flightsim and allows me to open the FSUIPC window which tells me software is unregistered etc.

I open register FSUIPC window and enter details including new key and click OK. It seems to accept this and tells me I need to restart flightsim for registration to become active.

I press confirm

When I restart flightsim and look at FSUIPC it has gone back to showing unregistered.

Can anyone help, what am I doing wrong or is their a known problem ??

thanks and regards

Link to comment
Share on other sites

Here is the log file for FSUIPC from the FSX modules folder.

Seems to show that it is seeing my registration but not activating it.

I have tried removing and re-instal but exactly the same, and yes I have looked closely at the name, email and key to make sure they are exactly what I got from Simmarket.

********* FSUIPC4, Version 4.070 by Pete Dowson *********

User Name="Alan Whitlock"

User Addr="awhitlock@hotmail.com"

FSUIPC Key is provided

FSUIPC not user registered

WIDEFS not user registered, or expired

Running inside FSX

Module base=61000000

LogOptions=00000001

DebugStatus=3

110 System time = 14:38:34

110 FLT UNC path = "C:\Users\Alan\Documents\Flight Simulator X Files\"

110 FS UNC path = "E:\FSX\"

1844 SimConnect_Open succeeded: proceeding to initialise interface!

6094 Running in "Microsoft Flight Simulator X", Version: 10.0.60905.0 (SimConnect: 2.0.60905.0)

21797 SimStart Event: Initialising SimConnect data requests

21797 FSUIPC Menu entry added

22047 C:\Users\Alan\AppData\Roaming\Microsoft\FSX\Previous flight.FLT

22047 E:\FSX\SimObjects\Airplanes\C172\Cessna172SP.AIR

54891 System time = 14:39:29, FSX time = 11:47:31 (11:47Z)

62360 Advanced Weather Interface Enabled

261719 System time = 14:42:56, FSX time = 11:47:52 (11:47Z)

261719 *** FSUIPC log file being closed

Memory managed: 104 Allocs, 104 Freed

********* FSUIPC Log file closed ***********

Any help appreciated, I have no idea what to do next. My old XP/FS9/FSUIPC 3.x worked fine

Link to comment
Share on other sites

My FSUIPC V4 has now registered within windows vista.

Here is the answer:

Although I installed all software on this P/C and am the only user and seem to have normal admin rights within Vista, (I've been installing programs and setting it up), it seems for some reason FSX does not recognise this.

When I right clicked on the FSX start icon and selected "Run as Administrator", FSX started and like before I found and entered my FSUIPC details. Then I closed FSX as instructed, and restarted it, to my amazement FSUIPC was now registered.

It seems that although you might seem to have admin priv. in all other respects in Vista, you need to specifically open FSX as an admin to register FSUIPC.

Once registered you can open FSX anyway you like and it is all ok.

This discovery has taken me many hours, hope it saves someone else a lot of head scratching !!!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.