Jump to content

Failure to register FSUIPC in FSX/Windows Vista64bit


Recommended Posts

HELP?

I cannot register FSUIPC4_4072 in FSX running in Vista 64bit!

I had FSUIPC4_4067 successfully registered in FSX running in Windows XP SP2 but of course the frame rates were low(6 to 15).

I installed Vista 64bit by booting from disc and presumably because I had 2 hard drives I was left with a copy of FSX with FSUIPC4_4067 previously registered as above but now unregistered.

I have now installed a clean copy of FSX on the drive with Vista 64bit and downloaded and installed FSUIPC4-4072 which appears in the add on menu but unregistered. Attempts to register result in acceptance of my key and OK and confirm actions but the FSUIPC is not registered on next start up of FSX.

Just in case of problems I cut my old copy of FSX from the D drive to an external hard drive but still no joy.

Perhaps FSUIPC4_4072 will not work with Vista 64bit(I haven't tried it with 32 bit)

Link to comment
Share on other sites

I cannot register FSUIPC4_4072 in FSX running in Vista 64bit!

Have you tried running FSX as Administrator? (Run As ...). I've been told that is necessary.

Also if you have installed FSX to the default location in Program Files I think Vista prevents programs writing to any folder there unless you set some user (group?) permissions. There are other mentions here in the forum with solutions. If you don't set the correct permissions then no FSUIPC settings, whether registration or options, will "stick" as the files can't be written.

I think this is Vista being over-protective and stopping you changing your own files! :-(

I am investigating whether anything can be done automatically, but I'm afraid I am not in a position to install Vista here for a while -- maybe not for as much as six months. So I am relying on feedback. during Vista Beta testing folks using the 32-bit version managed okay with the above considerations.

If you find the correct way to set adequate permissions, could you tell me step-by-step what you did, please, so I can (a) document it for now, and (b) work out if there's a way to doit automatically. Thanks.

Regards

Pete

Link to comment
Share on other sites

Thanks!!

FSUIPC now registered on FSX/64bit Vista.

The answer as you suggested was to use "Run as administrator" to start FSX.

I hope the answer wasn't in the FSUIPC instructions which I of course failed to read after changing from FS9 to FSX. :lol:

Link to comment
Share on other sites

Thanks!!

FSUIPC now registered on FSX/64bit Vista.

The answer as you suggested was to use "Run as administrator" to start FSX.

I think there may still be problems if you set options in FSUIPC4, as it won't be able to write to the FSX Modules folder unless the permissions for that are set correctly. I think this problem only applies if you installed FSX to the Program Files folder, as it will by default. Vista appears to stop anyone without elevated Administrative priileges writing there.

I've been looking for a way to set specific permissions for Modules programmatically, but I fear this is not possible, as the whole purpose of the protection is to stop (rogue) programs from altering Program installations.

The alternative solution, which I am working on now, is to have FSUIPC.INI, LOG and KEY files placed in the "My Documents\Flight Simulator X files" folder, alongside the saved flights and so on. I'll make the next version check for those files in the Modules folder first, and if they are present copy them over, and from then on maintain them there. This will be for Vista only.

Regards

Pete

Link to comment
Share on other sites

quote="Pete Dowson"]

Thanks!!

FSUIPC now registered on FSX/64bit Vista.

The answer as you suggested was to use "Run as administrator" to start FSX.[/quote

Thanks

I have set some joystick button assignments and they appear to stick OK after restarting FSX.

Link to comment
Share on other sites

I have set some joystick button assignments and they appear to stick OK after restarting FSX.

Yes, but is this with you running FSX "as administrator" even after restarting? Or do you have FSX installed elsewhere than the "Program Files" folder? I think the folder permissions problem is only related to the Program Files folder, which of course is used by default by FS installer.

Anyway, I've sorted out a PC and gone out and bought a copy of Vista for testing which I hope to start on next week. By the next release I should know all about the problems which may be arising and can try to deal with them, even if only by better information in the documentation.

Regards

Pete

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.