Jump to content

How Ignore thrust Reverse on Axis


Recommended Posts

I'm making my throttle reversers with buttons, and is working fine but

now I have to make the axis calibration to ignore the reverse.

Could someone help me, because when I put the throttle on Idle it start

rev.

Regards

Pedro

Link to comment
Share on other sites

I'm making my throttle reversers with buttons, and is working fine but now I have to make the axis calibration to ignore the reverse.

Could someone help me, because when I put the throttle on Idle it start

rev.

How are you assigning and calibrating the throttles? FS's own assignments don't normally provide reverse on the THROTTLE axes. Are you using the FSUIPC Joystick Calibrations, with 2 or more separate throttles?

if so, then you need to calibrate it so that the lower of centre pair of values (which denote the dle) are pretty much the same as the left-hand minimum value, which is for max reverse. The upper of the centre values then denotes the high end of your IDLE zone.

If you cannot do this close enough, then either make the IDLE zone larger and devise a way to never bring the levers right back (some sort of block), or edit the throttle entries in the [JoystickCalibration] section of the FSUIPC.INI file after you've done it in the options screen as best you can. You'll see the numbers there. Just make the first two numbers the same, or, better, reduce them to -16394.

Regards

Pete

Link to comment
Share on other sites

Thanks for your fast answer.

This is my actual configuration in fsuipc.ini

Throttle1=-16255,-16253,-13253,16383

Throttle2=-16255,-16253,-13253,16383

Throttle3=-16255,-16253,-13253,16383

Throttle4=-16255,-16253,-13253,16383

With this config, the one that gives me better results, If I pull the

levers very slow for Idle, it does not enter REV, but if I do it a little

more faster it enters REV.

With this configuration I don't like, but I can block mechanicly the levers

and the problem is solved.

There is not a way to disable REV via fsuipc ??

Many thanks.

Pedro

Link to comment
Share on other sites

This is my actual configuration in fsuipc.ini

Throttle1=-16255,-16253,-13253,16383

Throttle2=-16255,-16253,-13253,16383

Throttle3=-16255,-16253,-13253,16383

Throttle4=-16255,-16253,-13253,16383

With this config, the one that gives me better results, If I pull the

levers very slow for Idle, it does not enter REV, but if I do it a little

more faster it enters REV.

It sounds like you have the throttles in non-linear time-based mode. You'd do better to follow the recommendations in my documentation, thus:

For more predictable responses from your joystick, consider editing the FS CFG file and adding:

STICK_SENSITIVITY_MODE=0

To the [CONTROLS] section. This makes FS treat the raw joystick readings in a linear fashion. By default, since FS2000, FS has applied a time-change formula to the axes that, in my opinion at least, which can give rise to some unwanted behaviour. You will need to edit the CFG file before running FS, as any changes you make whilst FS is running will be overwritten.

Additionally, if you edited the INI file (as I suggested), so that the reverse range is impossible to get to, something like this:

Throttle1=-16383,-16382,-13253,16383

Throttle2=-16383,-16382,-13253,16383

Throttle3=-16383,-16382,-13253,16383

Throttle4=-16383,-16382,-13253,16383

then it should never engage in any case.

Additionally, I see that you have left no leeway at all at the MAX end of the range (16383 being the max possible), so if there is a slight variation in the values coming from the axes you may not always be able to reach MAX thrust. The whole point of using FSUIPC's more precise calibration is to get around typical FS problems like this. Try reducing that maximum input, by perhaps 256 or 512, to leave a little movement at the top. Unless your hardware is really always very precise, of course! ;-)

Regards

Pete

Link to comment
Share on other sites

Sorry my ignorance, but what is the name of the fs cfg file for

fs2004 ??

FS9.CFG. You'll find it in your Windows drive (C:\ usually) in

Documents and Settings\\Application Data\Microsoft\FS9.

Some of that may be different for a nonEnglish installation of Windows.

Regards

Pete

Link to comment
Share on other sites

nope, the same behaviour...

I think I have to mechanically stop the levers.

My FSUIPC.INI:

[JoystickCalibration]

ExclThrottleSet=No

SepRevsJetsOnly=No

ApplyHeloTrim=No

FlapsSetControl=0

FlapDetents=No

ReverserControl=66292

Reverser1Control=66422

Reverser2Control=66425

Reverser3Control=66428

Reverser4Control=66431

MaxThrottleForReverser=256

AileronTrimControl=0

RudderTrimControl=0

CowlFlaps1Control=0

CowlFlaps2Control=0

CowlFlaps3Control=0

CowlFlaps4Control=0

MaxSteerSpeed=60

Throttle1=-16383,-16382,-13253,16383

Throttle2=-16383,-16382,-13253,16383

Throttle3=-16383,-16382,-13253,16383

Throttle4=-16383,-16382,-13253,16383

FS9.cfg:

[CONTROLS]

KBDAIL=64

KBDELEV=64

KBDRUD=64

PAN_RATE=400

STICK_SENSITIVITY_MODE=0

Regards.

Pedro

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.